What's new

Android Devices Won't Connect to ASUS RT-AC5300 5GHz Band

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

Rana Imran

Occasional Visitor
Hello everyone,

I'm encountering an issue with my ASUS RT-AC5300 (AiMesh Router) that has me scratching my head and I'm hoping someone here can offer some guidance or suggestions.

I'm based in Pakistan. While most of my devices, including my iPhone, can easily connect to the 5GHz band without any trouble, I'm facing difficulties with my Android devices. Interestingly, these Android devices have no problem connecting to the 5GHz band on my ISP-provided Dual Band ZTE F670L GPON ONT. Upon investigating further, I noticed that the 5GHz channels available on my ZTE router include 149, 153, 157 and 161. However, the channels available on my ASUS router are limited to 36, 40, 44 and 48, regardless of the region setting I choose. I've tried changing the region setting on my ASUS router to various options including Asia, China, Europe, Australia, Singapore and USA, but to no avail. Even when I select Europe, I still get the same limited channels along with some DFS channels.

What's more perplexing is that all my Android devices are officially approved by the Pakistan Telecommunication Authority (PTA). Additionally, the GPON ONT provided by my ISP is also approved. Therefore, it seems that these channels are not restricted in Pakistan.

Then why I'm unable to access 149, 153, 157, 161 5GHz channels on my ASUS router, especially when they are available on other routers in the same region. Can anyone shed some light on this issue or offer any suggestions on how I might be able to resolve it? Thanks.
AC5300 has 3 radios: 2.4G, 5G#1 (low band) [&] 5G#2 (high band)

Try accessing the "high band" settings
Last edited:

I've noticed that the Mac Address of the 5GHz-2 band isn't present on both of my RT-AC5300 routers. Additionally, I've found that I can't manually select higher channels beyond the lower ones, becasue they are not present. This leads me to suspect a hardware failure.

In light of these challenges, I'm considering a solution: transitioning the AiMesh Router role to my RT-AC68U and assigning both RT-AC5300 devices as AiMesh Nodes. Upon further investigation, I've confirmed that my RT-AC68U supports the higher channels.

Now, my question is this: If I designate the RT-AC68U as the AiMesh Router and incorporate the RT-AC5300s as AiMesh Nodes, would this configuration enable my devices to connect to the 5GHz upper channels? As far as I understand, the settings are broadcasted from the AiMesh Router to the AiMesh Nodes. Has anyone else faced a similar situation or attempted this kind of setup before?

Here’s my setup:
  • ISP-provided ZTE F670L ONT device
  • ASUS RT-AC5300 attached to the ONT device as AiMesh Router
  • ASUS RT-AC5300 as AiMesh Node via Ethernet to AiMesh Router
  • ASUS RT-AC68u as AiMesh Node via Wireless Backhaul
Thank you all in advance for your help and support!

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!