Release ASUS RT-AC68U Firmware version 3.0.0.4.386.40558 (05-Nov-2020)

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

wouterv

Very Senior Member
has anyone did a wifi performnace benchmark compare to 385.20633? I assume more feature means slower wifi performance.
Unless you use all the features to their limits with a high number of client devices, you shoudn't see a significant difference in WiFi performance.
The wireless drivers are the same since long time.
I do not see a difference here.
 

bbunge

Very Senior Member
What's the proper way to fully reset the router? Is it ok to use the initialize settings? And after that, "Format JFFS partition at next boot" is necessary? I don't use any script whatsoever.
Different routers have different hard reset procedures. See: https://www.asus.com/support/FAQ/1039074/
No format of /jffs for Asus factory firmware. And the reset with initialize settings is usually adequate for the factory firmware.
 

bbunge

Very Senior Member
One of the improvements that I was looking for in this new release is the improvement in handling Wifi Calling while "roaming" from node to node on AiMesh. Just upgrade to this new release and hard reset all (router and 2 Mesh node). Unfortunately, I'm still dropping calls while moving from one node to another. I'm using MS Teams and Skype. Any suggestions?
Stand still while on a call?
DO you have the 2.4 and 5 GHZ SSID's the same? If not try it.
 

cannondale

New Around Here
FYI, a heads up if you start noticing new IP space on your guest networks and/or you have DHCP static leases that stop working. We discovered this when 386 dropped for the RT-AC86U recently.

ASUSWRT 386 new guest network IP space and DHCP static IPs
That jives with what I have seen. Some of my smart devices had trouble connecting to guest network 1 after the update. I had to disable guest network 1 and create a new guest network 2 with the same SSID & authentication details. That made all my smart devices work again.

EDIT: I should add that I am running my Asus router in AP mode, but it may appear that, after the update, clients connecting to guest network 1 weren't able to be assigned an IP address by my main router (an OPNsense box) anymore -- perhaps as an unintended side effect of this firmware change. Switching from guest network 1 to 2 solved that issue for me.
 
Last edited:

RJM

New Around Here
Updating to 3.0.0.4.386.40558 broke my Guest network so that no devices could connect (both 2.4 and 5 GHz). I re-entered Guest network settings in case they were damaged by the update. Still broken.

Reverted to 3.0.0.4.385.20633 and all good again.

I'm very surprised Asus hasn't pulled this release from their web site.
 

keefrto

Occasional Visitor
Updating to 3.0.0.4.386.40558 broke my Guest network so that no devices could connect (both 2.4 and 5 GHz). I re-entered Guest network settings in case they were damaged by the update. Still broken.

Reverted to 3.0.0.4.385.20633 and all good again.

I'm very surprised Asus hasn't pulled this release from their web site.
For me both the 86u and this upgrade making too nervous as my wife has her own home business and I would not have any nuts left if I was left without internet. I shall take a pass for now both upgrades
 

cannondale

New Around Here
Updating to 3.0.0.4.386.40558 broke my Guest network so that no devices could connect (both 2.4 and 5 GHz). I re-entered Guest network settings in case they were damaged by the update. Still broken.

Reverted to 3.0.0.4.385.20633 and all good again.

I'm very surprised Asus hasn't pulled this release from their web site.
Known issue. You just need to read the two posts right above yours for an explanation. Just use Guest network 2 instead of 1 and use the exact same SSID & password as before. Will work right away.
 

cyberwiz

New Around Here
Hello all,

Just registered here to update this thread with my findings after upgrading to firmware 3.0.0.4.386_40558:

A bit of background:
I've got 3 Asus RT-AC68 routers (all are original retail Asus routers bought in their box). All routers are on firmware 3.0.0.4.385_20633. One is the main router, the others are set up in AP mode. The APs are connected to the main router with 1Gbps Ethernet. Each router broadcasts a home network and a guest network. I used the Roaming Assistant to configure the routers manually for an optimal roaming experience. Apart from the extra work to configure each router separately, the only real issue with this setup is that the Guest network broadcast by the two AP routers actually sits on the main LAN, and without special measures, guests would be able to connect to devices on that main LAN (the Guest network broadcast by the main router, on the other hand, does not sit on the main LAN). The IP addresses given out to clients on the Guest networks are all in the same range as the IP addresses given out on the home network. I am very happy with this network; the routers provide excellent WiFi performance throughout the entire area.

After upgrading the two AP mode routers to 3.0.0.4.386_40558, they seemed to continue to work properly with the same configuration (I did not perform a complete reset).
I then proceeded to upgrade the main router to 3.0.0.4.386_40558, and, after the upgrade, the UI seemed to be a little more sluggish, but everything did seem to work properly (I did not perform a complete reset).
I then decided to test AiMesh, by completely resetting the two AP mode routers, and telling the main router to add these two routers as AiMesh nodes. This worked, although the UI on the main router became even more sluggish. The new AiMesh UI showed the two AiMesh nodes, and showed their (wired) connections properly. I then configured the main router in Ethernet backhaul mode to avoid the main router from communicating with its two AiMesh nodes using WiFi. Everything seemed to work properly except for the Guest network, which was present only on the main router and not on the two AiMesh nodes. The Guest network also was giving out IP addresses in a different range; I figured this was in preparation for the ability to extend the Guest network to the AiMesh nodes while not allowing guest clients to connect to the main LAN.

To get the AiMesh nodes to broadcast the Guest network as well, I then modified the new Guest network setting "Sync to AiMesh node" on the main router from "Router Only" to "All". (As an aside, I have noticed that this setting appears only on the first Guest network, and not on the other two. I do not know if this setting is therefore possible and affecting only the first Guest network, or all three Guest networks).
At this point, the AiMesh nodes disappeared from the new AiMesh UI, which showed them as "disconnected". Even after a long wait of 15 minutes, they did not reconnect. The main router also behaved erratically regarding other functionality. I therefore decided to remove the AiMesh nodes, give the nodes a full reset again, and then add them back into the AiMesh network while the Guest network setting "Sync to AiMesh node" was already set to "All" (I figured perhaps there was an issue with the functionality of extending the Guest network after the AiMesh nodes had already been operational). But unfortunately the result was the same (the nodes disappeared/disconnected and did not reconnect). I removed the AiMesh nodes again, gave them a full reset again, and, on the main router, disabled the first Guest network and instead configured the second Guest network (with the same settings as the first Guest network had, except that the option "Sync to AiMesh node" did not show up for the second Guest network). I then proceeded to add the AiMesh nodes back. The result was the same as before: the nodes disappeared/disconnected and did not reconnect, the AiMesh UI on the main router was sluggish/erratic, and other functions on the main router were erratic as well.

Left with no other choice, I reverted all routers to 3.0.0.4.385_20633 and went back to my previous configuration (of which I had made a backup so restoring the correct settings after the firmware downgrade was a snap).

Please note that one thing I did not try, was to fully reset the main router after upgrading to 3.0.0.4.386_40558.

At this point, my confidence level regarding firmware 3.0.0.4.386_40558 is such that I will wait with the upgrade until we can figure out what caused this behavior (perhaps I should have fully reset the main router), or Asus releases a fix/patch relating to the issues I have experienced.
 

wouterv

Very Senior Member
Hello all,

Just registered here to update this thread with my findings after upgrading to firmware 3.0.0.4.386_40558:

A bit of background:
I've got 3 Asus RT-AC68 routers (all are original retail Asus routers bought in their box). All routers are on firmware 3.0.0.4.385_20633. One is the main router, the others are set up in AP mode. The APs are connected to the main router with 1Gbps Ethernet. Each router broadcasts a home network and a guest network. I used the Roaming Assistant to configure the routers manually for an optimal roaming experience. Apart from the extra work to configure each router separately, the only real issue with this setup is that the Guest network broadcast by the two AP routers actually sits on the main LAN, and without special measures, guests would be able to connect to devices on that main LAN (the Guest network broadcast by the main router, on the other hand, does not sit on the main LAN). The IP addresses given out to clients on the Guest networks are all in the same range as the IP addresses given out on the home network. I am very happy with this network; the routers provide excellent WiFi performance throughout the entire area.

After upgrading the two AP mode routers to 3.0.0.4.386_40558, they seemed to continue to work properly with the same configuration (I did not perform a complete reset).
I then proceeded to upgrade the main router to 3.0.0.4.386_40558, and, after the upgrade, the UI seemed to be a little more sluggish, but everything did seem to work properly (I did not perform a complete reset).
I then decided to test AiMesh, by completely resetting the two AP mode routers, and telling the main router to add these two routers as AiMesh nodes. This worked, although the UI on the main router became even more sluggish. The new AiMesh UI showed the two AiMesh nodes, and showed their (wired) connections properly. I then configured the main router in Ethernet backhaul mode to avoid the main router from communicating with its two AiMesh nodes using WiFi. Everything seemed to work properly except for the Guest network, which was present only on the main router and not on the two AiMesh nodes. The Guest network also was giving out IP addresses in a different range; I figured this was in preparation for the ability to extend the Guest network to the AiMesh nodes while not allowing guest clients to connect to the main LAN.

To get the AiMesh nodes to broadcast the Guest network as well, I then modified the new Guest network setting "Sync to AiMesh node" on the main router from "Router Only" to "All". (As an aside, I have noticed that this setting appears only on the first Guest network, and not on the other two. I do not know if this setting is therefore possible and affecting only the first Guest network, or all three Guest networks).
At this point, the AiMesh nodes disappeared from the new AiMesh UI, which showed them as "disconnected". Even after a long wait of 15 minutes, they did not reconnect. The main router also behaved erratically regarding other functionality. I therefore decided to remove the AiMesh nodes, give the nodes a full reset again, and then add them back into the AiMesh network while the Guest network setting "Sync to AiMesh node" was already set to "All" (I figured perhaps there was an issue with the functionality of extending the Guest network after the AiMesh nodes had already been operational). But unfortunately the result was the same (the nodes disappeared/disconnected and did not reconnect). I removed the AiMesh nodes again, gave them a full reset again, and, on the main router, disabled the first Guest network and instead configured the second Guest network (with the same settings as the first Guest network had, except that the option "Sync to AiMesh node" did not show up for the second Guest network). I then proceeded to add the AiMesh nodes back. The result was the same as before: the nodes disappeared/disconnected and did not reconnect, the AiMesh UI on the main router was sluggish/erratic, and other functions on the main router were erratic as well.

Left with no other choice, I reverted all routers to 3.0.0.4.385_20633 and went back to my previous configuration (of which I had made a backup so restoring the correct settings after the firmware downgrade was a snap).

Please note that one thing I did not try, was to fully reset the main router after upgrading to 3.0.0.4.386_40558.

At this point, my confidence level regarding firmware 3.0.0.4.386_40558 is such that I will wait with the upgrade until we can figure out what caused this behavior (perhaps I should have fully reset the main router), or Asus releases a fix/patch relating to the issues I have experienced.
A long story, short answer: if you change the setup to AiMesh I strongly suggest to make a real fresh start, back to factory defaults for all involved routers and configure them from scratch.
 

OzarkEdge

Part of the Furniture
Hello all,

Just registered here to update this thread with my findings after upgrading to firmware 3.0.0.4.386_40558:

A bit of background:
I've got 3 Asus RT-AC68 routers (all are original retail Asus routers bought in their box). All routers are on firmware 3.0.0.4.385_20633. One is the main router, the others are set up in AP mode. The APs are connected to the main router with 1Gbps Ethernet. Each router broadcasts a home network and a guest network. I used the Roaming Assistant to configure the routers manually for an optimal roaming experience. Apart from the extra work to configure each router separately, the only real issue with this setup is that the Guest network broadcast by the two AP routers actually sits on the main LAN, and without special measures, guests would be able to connect to devices on that main LAN (the Guest network broadcast by the main router, on the other hand, does not sit on the main LAN). The IP addresses given out to clients on the Guest networks are all in the same range as the IP addresses given out on the home network. I am very happy with this network; the routers provide excellent WiFi performance throughout the entire area.

After upgrading the two AP mode routers to 3.0.0.4.386_40558, they seemed to continue to work properly with the same configuration (I did not perform a complete reset).
I then proceeded to upgrade the main router to 3.0.0.4.386_40558, and, after the upgrade, the UI seemed to be a little more sluggish, but everything did seem to work properly (I did not perform a complete reset).
I then decided to test AiMesh, by completely resetting the two AP mode routers, and telling the main router to add these two routers as AiMesh nodes. This worked, although the UI on the main router became even more sluggish. The new AiMesh UI showed the two AiMesh nodes, and showed their (wired) connections properly. I then configured the main router in Ethernet backhaul mode to avoid the main router from communicating with its two AiMesh nodes using WiFi. Everything seemed to work properly except for the Guest network, which was present only on the main router and not on the two AiMesh nodes. The Guest network also was giving out IP addresses in a different range; I figured this was in preparation for the ability to extend the Guest network to the AiMesh nodes while not allowing guest clients to connect to the main LAN.

To get the AiMesh nodes to broadcast the Guest network as well, I then modified the new Guest network setting "Sync to AiMesh node" on the main router from "Router Only" to "All". (As an aside, I have noticed that this setting appears only on the first Guest network, and not on the other two. I do not know if this setting is therefore possible and affecting only the first Guest network, or all three Guest networks).
At this point, the AiMesh nodes disappeared from the new AiMesh UI, which showed them as "disconnected". Even after a long wait of 15 minutes, they did not reconnect. The main router also behaved erratically regarding other functionality. I therefore decided to remove the AiMesh nodes, give the nodes a full reset again, and then add them back into the AiMesh network while the Guest network setting "Sync to AiMesh node" was already set to "All" (I figured perhaps there was an issue with the functionality of extending the Guest network after the AiMesh nodes had already been operational). But unfortunately the result was the same (the nodes disappeared/disconnected and did not reconnect). I removed the AiMesh nodes again, gave them a full reset again, and, on the main router, disabled the first Guest network and instead configured the second Guest network (with the same settings as the first Guest network had, except that the option "Sync to AiMesh node" did not show up for the second Guest network). I then proceeded to add the AiMesh nodes back. The result was the same as before: the nodes disappeared/disconnected and did not reconnect, the AiMesh UI on the main router was sluggish/erratic, and other functions on the main router were erratic as well.

Left with no other choice, I reverted all routers to 3.0.0.4.385_20633 and went back to my previous configuration (of which I had made a backup so restoring the correct settings after the firmware downgrade was a snap).

Please note that one thing I did not try, was to fully reset the main router after upgrading to 3.0.0.4.386_40558.

At this point, my confidence level regarding firmware 3.0.0.4.386_40558 is such that I will wait with the upgrade until we can figure out what caused this behavior (perhaps I should have fully reset the main router), or Asus releases a fix/patch relating to the issues I have experienced.
The setting 'Sync to all nodes' only applies to guest1 WLANs.

Next time reset all firmware to factory defaults before configuration from scratch.

You might want to jump ahead to the latest AiMesh 2.0 beta firmware RC2-8:


OE
 

netmann

Occasional Visitor
Used Asus app on my iPhone to update my AC-RT68U to .386....I know, always use the Asus WRT web GUI... Five minutes passed and the message said Firmware Update Failed... Check the firmware again....It was indeed updated with no issues...! And no, I don't have airmesh or guest network setups...
 

RJM

New Around Here
Known issue. You just need to read the two posts right above yours for an explanation. Just use Guest network 2 instead of 1 and use the exact same SSID & password as before. Will work right away.
What/where is Guest network 2? I do not see it in the settings.
 

cyberwiz

New Around Here
What/where is Guest network 2? I do not see it in the settings.
If you click on "Guest Network" on the left, you should see a screen similar to this screen:
Asus Guest Network Screen.png

Under the header 2.4GHz you should have three buttons, and under the header 5GHz you should have three more buttons.
The first column from the left is for Guest Network 1, which, according to this reply:
The setting 'Sync to all nodes' only applies to guest1 WLANs.
is the only guest network that can be extended to the other AiMesh nodes (with the setting "Sync to all nodes" not shown in the above screenshot).
The second column is for Guest Network 2, and the third column is for Guest Network 3.

Therefore, if you wanted to enable Guest Network 2, you would click on the "Enable" button in the second (middle) column, the top one for a guest network in the 2.4GHz band, and/or the bottom one for a guest network in the 5G band. To the best of my knowledge, you can enable and disable any combination of these six guest networks.
 

RJM

New Around Here
Therefore, if you wanted to enable Guest Network 2, you would click on the "Enable" button in the second (middle) column, the top one for a guest network in the 2.4GHz band, and/or the bottom one for a guest network in the 5G band. To the best of my knowledge, you can enable and disable any combination of these six guest networks.
Thank you, I understand now.

People concerned about security should be using Guest for home automation, and this update will break home automation systems. Nothing in Asus's release notes inform that Guest1 can no longer be used and Guest2 must be set up instead. They are insane not to pull this release or at least provide better update instructions.

Will we be required to use Guest2 in future releases?
 

Arctic Ace

New Around Here
After installing v3.0.0.4.386.40558 to my RT-AC68U I am no longer able to open to the router web interface or login to router in via mobile app. Network and internet works fine, but not admin GUI / Access. Mobile app says that "unable to reach…"
 

Arctic Ace

New Around Here
After installing v3.0.0.4.386.40558 to my RT-AC68U I am no longer able to open to the router web interface or login to router in via mobile app. Network and internet works fine, but not admin GUI / Access. Mobile app says that "unable to reach…"
Access to admin GUI restored after few hours waiting w/o that I did anything. Looks like system/os is still doing something after the upgrade?
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top