What's new

Solved ASUS RT-AC68U router can't reach specific website - known issue?

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
I have been running an ASUS RT-AC68U router utilizing Merlin's firmware for several years, and it has been remarkably stable. I will literally reboot it once-a-year for preventive maintenance, but that is typically the extent of my intervention.

A couple of days after my traditional January 1st reboot, I noticed that I couldn't reach one of the IT-based web pages that I visit on a regular basis, How To Geek. I received an error that said "Secure Connection Failed." I assumed that the web masters didn't update their site certificates, but continued to troubleshoot as follows:
  • I tried to access the web page from Firefox and Edge within Windows 10 on two different computers (both an Ethernet connection as well as WiFi), Firefox and Safari on an iPhone, using a Chromebook, and even my wife's Kindle. None of those devices would reach https://www.howtogeek.com/ successfully.
  • I had stayed on Merlin's firmware version 380.58_0 for several years because it has been rock-solid.
  • I decided this was an ideal opportunity to upgrade the firmware, so I downloaded Merlin's 386.12_4, upgraded the firmware, and performed a factory reset immediately afterwards. Before customizing any router settings other than the default password and WiFi, I tried again from my hardwired desktop computer but still couldn't reach that one web page.
  • It doesn't appear to be a DNS issue, because I was using my ISP's servers for years without any problem. However, just to be thorough I also tried switching to Cloudflare DNS servers, but that didn't alleviate the problem, either. Regardless of the DNS servers an nslookup command prompt query on howtogeek.com always resolved.
  • Every other web page that my family typically uses resolves without any problems at all.
  • Our connection is still reliable and relatively fast, consistently clocking about 595 Mbps download on Speedtest.net.
  • Notably, if I open a portable Tor Browser and navigate to howtogeek.com from there, it does work! While in there, I noticed that the howtogeek.com certificate had been renewed on January 3rd with LetsEncrypt.
  • The router's firewall is enabled, but URL Filter, Keyword Filter, and Network Services Filter are all disabled.
  • In the interest of thorough troubleshooting I also got around to rebooting the separate cable modem, but the problem persists.
  • Last but not least, I took a laptop down to the patch panel closet, bypassed the router completely, rebooted the cable modem again, and connected the laptop directly to the cable modem via an Ethernet cable. That configuration does work, also.
Based upon that series of troubleshooting steps, it seem like the web page must be blocked at least partially because of the router. However, that doesn't really seem to be logical either, because the factory reset after the firmware upgrade should have provided a very simple baseline that would allow access to https://www.howtogeek.com/.

By any chance, is this a known issue or have any of you encountered something similar?
Last edited:
It seems more likely they are rejecting the WAN IP assigned to the router. Did the public IP change when you plugged the laptop in directly?

Clone the MAC address from the laptop on the routers WAN page and try again.
I appreciate the feedback! It is good to know that the same router/firmware combination is working perfectly elsewhere.

Perhaps it is something as innocuous as being blacklisted by their domain, because most of our local logins allow HowToGeek to have an Adblock Plus bypass, but not all of them. When I get back to work tomorrow, I will use their "Contact Us" page and reach out to their webmasters.
Last edited:
Another datapoint. No problems accessing https://www.howtogeek.com/ with a RT-AC68U with basic configuration (post hard factory reset) running 386.12_4. AiProtection not enabled. No extra scripts or anything. DNS servers set to ISP's. No VPN (client or server). PS: Example:
Last edited:
I appreciate the additional sanity check, Bennor. I reached out to their webmasters via their "Contact Us" page two days ago, but haven't heard anything back from them yet. If I still haven't received a reply after a full week has passed by, I will try reaching out to them via their social media accounts.
Epilogue: one week ago today (Saturday, January 27th), I sent an email to contact@howtogeek.com explaining the entire scenario. Within 24 hours, my home network was unblocked and I received an email from their staff Monday morning that said the following:
We contacted our I.T. department and got the following response back:
"This reader tripped the rate limiter by accessing the same URL like a hundred times in a few seconds at the beginning of the month. Most likely some kind of browser malfunction. Would have been unblocked in a couple of days, unblocked manually for now."
HTG Management

Apparently, my WAN IP address had earned a 1-month ban. I can only make an educated guess regarding the root cause, though. I know that there was an Adblock Plus update right around that same time frame that caused problems with the YouTube web site, so perhaps it inadvertently triggered the issues with https://www.howtogeek.com/, also.

Once again, I am grateful for the community's feedback, especially those of you who tested the same router/firmware combination to aid my process-of-elimination troubleshooting. Thanks for your help!

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!