What's new

Asus RT-AC68U SSH not responsive after time, reboot not helping.

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

Heronimos

New Around Here
I have a the Asus 68U and I have a strange problem.

I was working with putty on SSH port 22. It was getting slower. Sometime 1 a 2 minutes to get a loginprompt
After a while a disconnect. Now I can connect to port 22 but I don't get any prompt to login (I use username + password).

Reset did help 1 time, but now even with a reset I cannot connect with putty.
Reset of the client doesn't change that. I can make connection on port 22 but don't get a prompt.

After a change to port 44 for SSH in the WebUI. I could connect to port 44.
But after a while the same problem. Now I also connect to port 44 but no prompt. Nothing
I do get connection, but I don't get a prompt and can't do anything.

Now I can't get in to the router anymore.
WebUI works fine
Router also works fine
CPU load and mem load is also fine

Just can't get into SSH.

Anyone any help?

O I am running Merlin 386.12.4
 
How is the PC conected to the RT-AC68U? Directly connected to the router using Ethernet? Or is it connecting to the router using WiFi?
Check the Putty settings/config to ensure it's accessing the proper IP address for the router and the proper port #.
What specific error is putting giving when it cannot connect?
You may want to turn on Putty Logging to see if it shows any issues or a specific problem when trying to access the router.
May want to remove the Putty entry for the router and create a new one to see if it will trigger the user to accept the SSH key/cert from the router.
If you haven't done so already, you may want to disable SSH in the router GUI, reboot the router, then reenable SSH and see if that clears the issue.
Are you using any sort of SSH authorized keys in the router GUI?
Make sure SSH is set to LAN Only and return to using port 22 as a test if you've change the port(s).
 
Thanks

1 - Both. Tested on a wired PC and on a laptop. Problem is in router it looks like
2 - Tried the use SSH keys after password didn't work, same problem
3 - No error. Just a black screen in putty no prompt. After a while sometimes a disconnect
4. And Yes, Lan only and tried again port 22 (and 44, 88, 222 and 444 none works)

The rest I will test..
 
5. Remove router from Putty was not effective
6. SSH disable, reboot, enable, did nothing on port 22
7. Putty logging on output level doesn't does give anything. On SSH package level is not understandable for me.

But! After a try on port 99 I got a short window. In that window I removed Skynet and now everything works again.
Also on port 22. It was a hunch. I thought I saw something in the log (but can't find it now).

Must I do something in Skynet to keep SSH working?
 
Yep, Skynet not installed no problem.
Skynet installed and again I can't get anywhere. Hopefully I can get in by luck again and disable.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top