Release Asus RT-AX92U - New Firmware: 3.0.0.4.386_45898

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

HKcow

Occasional Visitor
I also experienced two times WAN go down without any error in the system log with the latest firmware. I gave up trusting that new firmware will fix this issue, I think ASUS is not aware of the root cause and this is not affecting most of the people. I will try the auto detect WAN down and reset script.
 

HKcow

Occasional Visitor
Need some help here.. I tried to follow the instruction in the following link to call the script at every start of the router but not success.


I am able to login to the router through SSH, and successfully downloaded the ChkWAN.sh into the directory "/jffs/scripts/". One thing look strange is there is no directory "scripts" under "/jffs" and I had to manually create it. Therefore there is no "/jffs/scripts/wan-start" exists. I tried to manually create the script "wan-start" with one line of command "sh /jffs/scripts/ChkWAN.sh &" but the Chk-WAN script does not auto-run after I restart the router. Since I am really a noob for scripting in router.. can someone help to explain how I can schedule the script the run every time the router restart?
 

HKcow

Occasional Visitor
Followed the instruction and the script is working fine now


credit to MartineauUK for the script and Carme for the guideline.
 

Thw0rted

Regular Contributor
I'm on 44695, and my only issue is that sometimes one or the other mesh node drops off and needs a long wait or manual reboot to rejoin the network. Frankly, from this thread it sounds like upgrading is a bad idea - not likely to fix my issue, but likely to introduce new ones. Is that the consensus?
 

leerees

Senior Member
I'm on 44695, and my only issue is that sometimes one or the other mesh node drops off and needs a long wait or manual reboot to rejoin the network. Frankly, from this thread it sounds like upgrading is a bad idea - not likely to fix my issue, but likely to introduce new ones. Is that the consensus?
I'm on 695 as well. Once you have it all setup, click optimisation in AI mesh. This will stop nodes from dropping off the network.
 

Thw0rted

Regular Contributor
I'm on 695 as well. Once you have it all setup, click optimisation in AI mesh. This will stop nodes from dropping off the network.
I've tried optimization, but it seems like a one-time fix. What usually happens is, I seem to have a weak connection via Node B so I'll open the web interface and find that both remotes are connected directly to the main router, rather than going Main -> A -> B, which reflects their physical topography. If I click Optimize, when it comes back up, they're usually connected "correctly". One of the nodes can still randomly drop offline, though, so I just put it down to random noise on the radio spectrum or something. (If there's a better way to find out the real root cause, I'd love to hear about it!)
 

leerees

Senior Member
I've tried optimization, but it seems like a one-time fix. What usually happens is, I seem to have a weak connection via Node B so I'll open the web interface and find that both remotes are connected directly to the main router, rather than going Main -> A -> B, which reflects their physical topography. If I click Optimize, when it comes back up, they're usually connected "correctly". One of the nodes can still randomly drop offline, though, so I just put it down to random noise on the radio spectrum or something. (If there's a better way to find out the real root cause, I'd love to hear about it!)
It sounds to me like you have a node placement issue. I have 8 nodes running and believe me, at the start it was an absolute nightmare to get it working. The way we did it was to build the network one by one, ensuring that each node has a "great" connection to the prior node before adding the next. Then, once everything is up, click optimise in the AI Mesh screen.
 

Thw0rted

Regular Contributor
The nodes do say "great" when they're linked the way they should be (Main -> A -> B). The mesh page in the web interface shows a backhaul PHY rate around 1Gb for each node every time I check.

The place isn't that big but it's old construction, and there's literally steel wool (or something very similar) mashed into the fill between floors -- very unfriendly to RF. So, I have one node right above the main router, and the second at the other end of the hall from the first. The only way I think I could rearrange things to have stronger signals would be to run wired backhaul, but that's not happening, which is the whole reason I bought mesh kit to begin with.
 

leerees

Senior Member
The nodes do say "great" when they're linked the way they should be (Main -> A -> B). The mesh page in the web interface shows a backhaul PHY rate around 1Gb for each node every time I check.

The place isn't that big but it's old construction, and there's literally steel wool (or something very similar) mashed into the fill between floors -- very unfriendly to RF. So, I have one node right above the main router, and the second at the other end of the hall from the first. The only way I think I could rearrange things to have stronger signals would be to run wired backhaul, but that's not happening, which is the whole reason I bought mesh kit to begin with.

The PHY rates should be close to 2gbps. Is the channel clear?
 

Thw0rted

Regular Contributor
The Wireless Log tab consistently shows "Noise" as -90/-91dB. I assume that's measured at the main router, but as I say the house isn't very big so it seems unlikely to vary much. That's good, I think?

That same page shows one connection at the end of the backhaul section, which I assume is the one from the "A" node back to the main router. It shows an RSSI of -63dB right now, and it's consistently between -60 and -63. I think this is OK but not great; it's also the best I'm going to get in this situation. I really can't run a wired backhaul; I've tried powerline and the result is terrible (the mesh protocol does *not* handle dropped packets well). I'm not going to spend $200+ on a *fourth* router for this tiny house, just to wire yet another node in the stairwell going up to the second floor or something, which is the only way I could avoid having the signal travel through the (extremely RF-hostile) floors.

I've run iperf3 for a pretty long time and gotten consistently good results, when the mesh network is "happy". I wouldn't even be mad if I occasionally got 10/20/30 second outages when some RF spike disrupted comms, and the nodes had to redo some kind of handshake. What bothers me is, nodes will fall off for multiple minutes at a time, then work perfectly within 90 seconds or so if I just power cycle them manually. I just want them to recover gracefully without manual intervention.
 

leerees

Senior Member
Your numbers are the same as mine, it should work. Did you click optimise? That fixed the issue of dropped nodes for me.

Try changing the wireless channels for the backhaul. We use the DFS channels. If you are already using DFS channels, try non DFS channels.

Maybe it's something that's connected to the node that's causing the issue.
 

Thw0rted

Regular Contributor
I do Optimize periodically, but it doesn't seem to prevent the nodes from dropping off. I could do it more often, if you think that would help?

The backhaul is on channel 120. In the Wireless Log, every channel under the backhaul channel says "RADAR Sensitive" -- that's DFS, right? It's just what I'm allowed to use here, I guess. Still better than the noisier AC bands, right?

Also, that reminds me -- I don't have "enable 160 MHz" enabled in the configuration for this band, could that be why my PHY speeds aren't 2GB? (I'd *much* rather a super-fast very stable connection than an unbelievably-fast unstable one.)
 

leerees

Senior Member
Enabling it is different depending on how it's setup. Is yours in dual band smart connect mode or tri band smart connect mode?
 

Thw0rted

Regular Contributor
Dual band smart connect, with 5GHz-2 reserved for backhaul on a separate SSID, in AX-only mode.

1637233072740.png
 

leerees

Senior Member
Tick enable 160mhz, select 160mhz only from the drop down menu.

If it does not connect at 160mhz, try every control channel until it does. You have to wait 15 minutes if using dfs channels.

In the UK, channel 100 dfs works fine with 160mhz
 

Thw0rted

Regular Contributor
Is this actually going to help me have a more reliable connection?

My understanding is that, if there is any interference (or protected traffic, like radar) anywhere in the band being used, the router has to "back off", which means that based on the (likely inaccurate) assumption that any interference would be evenly distributed, the wider your channel, the more likely it is to become unavailable.

Am I wrong? Does using a wider channel actually improve reliability for some reason?
 

leerees

Senior Member
Is this actually going to help me have a more reliable connection?

My understanding is that, if there is any interference (or protected traffic, like radar) anywhere in the band being used, the router has to "back off", which means that based on the (likely inaccurate) assumption that any interference would be evenly distributed, the wider your channel, the more likely it is to become unavailable.

Am I wrong? Does using a wider channel actually improve reliability for some reason?

You shouldn't see any interference in the DFS channels so it might help. However, if there are radar signals nearby then the router will switch the backhaul over to 2.4ghz.

The reason for using DFS is to avoid any interference from neighboring AP's.

Try it out and see if it works. If the channels are completely clear then use 160mhz for the speed benefit.
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top