Can't change wireless channel bandwidth or control channel


Occasional Visitor
I have RT-AC86U and Merlin 386.7_2. I'm unable to set the wireless channel bandwidth and control channel for 2.4 GHz and 5GHz frequencies. After I configure them and hit apply it just goes back to the default of 20/40 MHz, Auto control channel for 2.4 Ghz, 20/40/80 MHz, Auto control channel, Auto extension control for 5 GHz. I thought I used to be able to change these settings but now I can't remember.


Part of the Furniture
Does rebooting the router via the GUI help? If not, does pulling the power plug from the router, waiting a minute or so, then powering it back up help?

If neither of these doesn't give results when was the last time you fully reset the router without using a saved backup config file to set it up again?

Do you have any scripts running? Are amtm and all scripts/Entware up to date? Is your USB drive healthy?

Are you using AMesh?

What other options/features are you using on the router, past its defaults?


Occasional Visitor
I've already rebooted the router through the GUI and unplugged the router multiple times. I don't think I ever reset the router when I did the last Merlin update, which was months ago. Not using scripts or amesh or usb drive or anything beyond the default.

You think I should reset the router?


Occasional Visitor
Try with different web browser.

Ok I figured out the problem. It was the Adguard Adblocker extension that was causing it. The settings actually did change to what I wanted but if Adguard was enabled it would always show the settings as the default. I tested it with a different browser that had Adguard disabled and it showed the settings I configured in the other browser. Damn browser extensions. Thanks for the tip.

Btw do you have any recommendations for optimal wireless settings and channels for 2.4 & 5 GHz? Is it better to leave them on default? I set 2.4 GHz to 20/40 MHz, Control channel 1; 5 GHz to 40 MHz, Control channel 48.


Part of the Furniture
2.4GHz @20MHz and 5GHz @20/40/80MHz or straight 80MHz if it works reliably. Fix control channels to what works better for you. There is no optimal settings. Everyone's Wi-Fi environment is different. If you have no issues with default settings in Professional - leave it this way.

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!