What's new

Cisco RV-345P Dual WAN Gigabit PoE VPN Router Reviewed

Ozymandyus

Occasional Visitor
I appreciate the replies @coxhaus, and if it turns out to be operator error, I don't have any particular ego in it and would be happy to admit it. Before anything else, thank you for taking the time to respond and discuss, it's greatly appreciated.

The Cisco rep with whom I spoke freely admitted that the issues I was experiencing were related to bugs in the current firmware, and that I was far from the first person he'd worked with having difficulty. I will relate what happened to me in detail.

The first thing I did after connecting directly to the router is upgrade to the latest firmware from a file previously downloaded to my laptop. I do this to make sure I have the most up-to-date security fixes, but in this particular case it might not've been ideal.

The next several steps were very similar to yours. I connected initially via a DHCP-obtained address for simplicity, but knew I'd need to change it later. Went to LAN-VLAN1-Edit, and changed the IP address to what I'd wanted. You naturally lose your connection, so at this point I configured a static IP on the laptop in the new network. No connection. No matter how I tried to represent my laptop on the new network, it simply no longer connects. In order to be able to access the configuration again, I had to reboot the router (and lose my changes). After that, at the direction of the Cisco rep, I first setup remote management and saved the config (which doesn't break anything) and then connected through one of the WAN interfaces. Any change to the default VLAN1 renders it completely unusable.

Using the WAN port I was able to configure things and setup additional VLANs through which access on the LAN was possible. However, with the default VLAN unusable, I started running into other issues as well. It would be an easier situation if I had a layer 3 switch, but I do not. I've also had no luck getting VPN access working with the RV345, which I assume (but don't know for sure) has something to do with the default VLAN not working.

Basically, I'm at a skill level in networking where it's already challenging enough for me to get everything configured and working correctly. Having to fight the hardware itself on top of that makes it darn near impossible, and I don't have unlimited time to devote to trying. I figure that as a last resort, I'll try downgrading the firmware to see if that works better, although from what I read the earlier versions had their own problems.
 

coxhaus

Part of the Furniture
I used the current latest version of firmware on the RV340 router which is 100118. I did not use a DHCP IP address. I hard coded the IP address both times. Yes you lose your connection when you change the network or IP on the router. IF you reboot the router it reverts back to the original settings because the change only changes ram what Cisco calls running. You have to log back on to the router with the new IP without rebooting the router so you can save it to flash so it will be stored. I think this is your problem. You need to assign a new IP network to your PC to match the new router network. Can you be more specific and give me the exact IPs and networks assigned to both the router and PC for each step. I think we can sort this out.

The level of Cisco on these small routers is not the best. It covers basic software and hardware. Much better than any of the other vendors. The other vendors have zero networking support if you call.

PS
I assume after the firmware upgrade you did a factory reset? It is always safest to do this.

Using running and flash is the Cisco way of their big pro routers. It is a little more challenging but it will save you if you make a bad change. You can reboot back to the original setting before the change.
 
Last edited:

Ozymandyus

Occasional Visitor
Can you be more specific and give me the exact IPs and networks assigned to both the router and PC for each step. I think we can sort this out.
I'll go to PMs to give you the exact information (don't want my whole configuration out for the world to see), and can later post a summary here if we're successful. Thank you, sir.
 

sfx2000

Part of the Furniture
I don't believe there is any black eye for Cisco, I'd say more likely operator error.
I would tend to agree - with Cisco gear (not ex-Linksys), one has to be very explicit when setting things up, otherwise things go into a very dark place... that is what I meant about the "Cisco Way" of doing things - nothing is implied, from routes to vlan's to addressing and access control.

Helps to write things down and draw things out on paper to get the mind right about what needs to be done..
 

Ozymandyus

Occasional Visitor
Just wanted to drop a note thanking Coxhaus for the assistance. Had to do a couple of factory resets to clear out whatever was ailing the thing, then go through the trouble of reconfiguring it from scratch, but it appears to be functioning correctly now.

Next fun is trying to get the VPN functionality working, but that's a topic for another day.
 

coxhaus

Part of the Furniture
I was reading the review again and realized the RV340, RV345 and RV345P GUI has completely been replaced with a much nicer newer GUI interface.
 

Trip

Very Senior Member
Indeed. As of 1.0.02.x it has, as have most of the RV series and latest WAP APs. Only the SG switches have the old GUI at this point, which I suspect will change for the SG250/350/550 series at some point in the near future.
 

coxhaus

Part of the Furniture
The RV345P has 3 versions the RV340, RV345, and RV345P routers. The RV340 is the basic router. The RV345 is the basic router plus switch ports. And the RV345P is the basic router plus switch ports and POE+ power.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top