Voxel Custom firmware build for Orbi RBK50/RBK53 (RBR50, RBS50) v. 9.2.5.2.5SF-HW & v. 9.2.5.2.5.1SF-HW

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

paakofi

New Around Here
I flashed Voxel because I wanted the VPN client functionality but I cant see any simple step by step instructions on how to do this.
I see in some of the change logs that it supports Open VPN, Wireguard etc but not sure how to activate them.

I would appreciate some help here.
 

Voxel

Very Senior Member
I flashed Voxel because I wanted the VPN client functionality but I cant see any simple step by step instructions on how to do this.
I see in some of the change logs that it supports Open VPN, Wireguard etc but not sure how to activate them.

I would appreciate some help here.
There are simple instructions in ZIP archive with firmware, file QuickStart.txt.

. . .
12. WireGuard client.

To start its using you should
. . .

13. OpenVPN client.

Important: only TUN clients are supported
. . .


Voxel.
 

huh12312

New Around Here
Thanks Voxel for the wireguard integration! I'm trying to use this for a cloud based pihole implementation and it looks like I need additional parameters exposed/available in wireguard.conf then what your tutorial shows. Is it possible to enable Address, and ListenPort, and DNS lines from the interface side in your setup? It appeared that private/public/allowedIPs/endpoint were already available.

wireguard-04.png
 

Price665

New Around Here
This firmware bricked 3 of my RBS50s. I was on stock 2.7 series and I updated all three to this build - they are dead - strobing white lights. Anyone know how to recover?
 

Skippy Bosco

Regular Contributor
This firmware bricked 3 of my RBS50s. I was on stock 2.7 series and I updated all three to this build - they are dead.
1) This happened to me as well. 2.7 is a major change to the stock firmware. You need to flash an earlier stock firmware before flashing Voxel from my experience. If Voxel releases a firmware based on 2.7 that will hopefully address this issue.

strobing white lights. Anyone know how to recover?
You need to flash the stock ROM via TFTP. This explains how.

 
Last edited:

Needsmorecaffeine

New Around Here
I‘m trying to roll back to the stock firmware after trying to upgrade to voxel. I should’ve done more reading about issues with upgrading from the 2.7 firmware. I’m following the kb article detailing the process for rolling back but have been unsuccessful. I’m using an apple computer so the directions look different from the TFTP client they link too. Any help would be greatly appreciated!!
 

Skippy Bosco

Regular Contributor
I‘m trying to roll back to the stock firmware after trying to upgrade to voxel. I should’ve done more reading about issues with upgrading from the 2.7 firmware. I’m following the kb article detailing the process for rolling back but have been unsuccessful. I’m using an apple computer so the directions look different from the TFTP client they link too. Any help would be greatly appreciated!!
This thread has more specifics on doing this from an Apple

https://community.netgear.com/t5/Or...P-New-Purchase-not/m-p/1902281/highlight/true
 

SuperNero

New Around Here
Hello,
Thank you Voxel for making this firmware.
I have used my RBK50 system with stock firmware for 2 months. It worked well until last week, sometime the 2.4GHz channel is down.
I decide to flash Voxel firmware in the hope that it works more stable.
However, I don't know why in 4 recent days, my RBK50 system with Voxel-firmware has some weird problems:
-RBR50 reboots itself once.
-RBR50 lost internet connection 4 or 5 times. At the first time, I try to unplug internet cable, check internet access on this cable, plug internet cable into RBR50 again, but this does not help. I have to reboot RBR50.
 

Voxel

Very Senior Member
it looks like I need additional parameters exposed/available in wireguard.conf then what your tutorial shows. Is it possible to enable Address, and ListenPort, and DNS lines from the interface side in your setup?
You know, I cannot say that I am very great expert in WireGuard. I used this Quick Start manual


for implementation of WG client. If I add DNS line to config file generated by /etc/init.d/wg-client script, "wg" command just does not accept this line. Debian Linux for example has "wg-quick" processing such lines, but I do not implement such parser: it requires some additional binaries to be included (what is problematic in the case of firmware).

You can play with DNS by iptables rules or just to use e.g. DNSCrypt...

Regarding ListenPort. As far as I understand it is needed for WG server not client. "Port" is used in my instructions for client.

Voxel.
 

Voxel

Very Senior Member
RBR50 lost internet connection 4 or 5 times. At the first time, I try to unplug internet cable, check internet access on this cable, plug internet cable into RBR50 again, but this does not help. I have to reboot RBR50.
Maybe it has a sense to temporary flash the stock FW (2.5.x), reset your RBR to factory settings and flash again my build. As far as I know nobody reported such problem.

P.S.
Also, try to change first your cable. It happens sometimes that problem is in cable.

Voxel.
 

SuperNero

New Around Here
Maybe it has a sense to temporary flash the stock FW (2.5.x), reset your RBR to factory settings and flash again my build. As far as I know nobody reported such problem.

P.S.
Also, try to change first your cable. It happens sometimes that problem is in cable.

Voxel.
Thank you, maybe the problems came from the legacy settings of stock firmware. I will try again.
 

alceasan

Occasional Visitor
About the WireGuard VPN, I don't know if there are any future plans on implementing the WG server on Voxel firmware. I'm currently using it when outside home with a RaspB port forarded, and performance is much better than the OpenVPN server on the Orbi.

Thank you in any case for this great work Voxel.
 

Voxel

Very Senior Member

chiron

New Around Here
Hey All,

I only recently discovered Voxel by looking at the top posts on r/orbi and I was super excited to try it out. I flashed from Netgear 2.5.2.4 to Voxel V9.2.5.2.5.2SF-HW by doing each of my two satellites first via ethernet and then the router. Everything came up 100% and connected via 5Ghz Backhaul

All of it looks really good and my internet appears to be much more responsive, DNS lookups etc. Everything looked 100% until I tried to do speed tests over the Wifi. The speeds from the router are 250Mbps but from the Wifi clients (desktop + mobile) it averages out to a ridiculous 2Mbps. I noticed one other user appears to have had the same problem via this reddit post.

I'm almost certain I've missed some crucial step but I also followed the Quickstart guide (up to Step 3.)

Can anyone help me out?
 

Voxel

Very Senior Member
The speeds from the router are 250Mbps but from the Wifi clients (desktop + mobile) it averages out to a ridiculous 2Mbps.
Let us do the following: I'll release the new version tomorrow or after-tomorrow and you will check the speed of your Wi-Fi with this version.

As a rule I am using a bit newer version of my firmware vs released one (my internal testing releases). 2 or even 15Mbps is toooooo slow, no doubts. I've checked the speed by Wi-Fi client right now: 110Mbps by ookla - it is maximum what I can get in the place I am located now. The speed of Wi-Fi client<--->RBS is about 480-520Mbps. So... Tomorrow/after-tomorrow, OK?



Voxel.
 

Skippy Bosco

Regular Contributor
I respect US Region, but I'd prefer to release world-wide versions. Reason is obvious: I am not from US so I would be just restricted to use this version after my release :)

So, as a basis still (WW version):

RBR50 (Orbi Router) Firmware Version 2.5.2.4



Voxel.
You know, 2.7.0.70, download notes:

RBR50 (Orbi Router) Firmware Version 2.7.0.70 (for US Region Only)

I respect US Region, but I'd prefer to release world-wide versions. Reason is obvious: I am not from US so I would be just restricted to use this version after my release :)

So, as a basis still (WW version):

RBR50 (Orbi Router) Firmware Version 2.5.2.4



Voxel.
Could the region code be a clue as to what's causing the brick when going from 2.7 -> Voxel perhaps?

Curious if the brick during factory reset under Voxel is happening for the same reason?
 

Voxel

Very Senior Member
Could the region code be a clue as to what's causing the brick when going from 2.7 -> Voxel perhaps?
Very probably. I am sorry but I did not dig this in deep.

Curious if the brick during factory reset under Voxel is happening for the same reason?
I do not think so.... Rather no. IMO something is inside of precompiled binary from DNI/NG... Too difficult to debug this issue - I have to crash my Internet connection intensively used by my family.

Voxel.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top