Custom firmware build for R7800 v. 1.0.2.63SF

Voxel

Very Senior Member
But the weird things is if I use stock firmware, I get full speed in DSL Report speedtest, if Voxel firmware, download speed limited to half of it, no matter what version of Voxel
So you have concrete problem with concrete server(s) and service. But I talk about your _real_ speed. Overall. You should bother only if you _really_ face problems with your speed.

If you are interested in technical details: one of the key difference is that I:

1. Use yeah congestion control algorithm. NG is using cubic. But I left possibility of fine tuning: you may change yeah to cubic or to westwood+ or to highspeed or to illinois. If you are able to deal with Linux a bit.

2. I changed rmem_max/wmem_max values in /etc/sysctl.conf (increasing buffers). Usually this leads to increase of the _real_ speed.

You can search this forum re: congestion control, rmem/wmem, Voxel. Re how to change this. But you will work just for getting good scores with DSL Reports. But not increasing your _real_ speed.

P.S.
I am sorry, I do not accept reports as "issue" basing just on DSP Reports results.

Voxel.
 

heidarren

Occasional Visitor
So you have concrete problem with concrete server(s) and service. But I talk about your _real_ speed. Overall. You should bother only if you _really_ face problems with your speed.

If you are interested in technical details: one of the key difference is that I:

1. Use yeah congestion control algorithm. NG is using cubic. But I left possibility of fine tuning: you may change yeah to cubic or to westwood+ or to highspeed or to illinois. If you are able to deal with Linux a bit.

2. I changed rmem_max/wmem_max values in /etc/sysctl.conf (increasing buffers). Usually this leads to increase of the _real_ speed.

You can search this forum re: congestion control, rmem/wmem, Voxel. Re how to change this. But you will work just for getting good scores with DSL Reports. But not increasing your _real_ speed.

P.S.
I am sorry, I do not accept reports as "issue" basing just on DSP Reports results.

Voxel.
Got it, just wonder why would this happened, it's clear now.

Once again, thanks for your hard works in supporting this model, it makes it greater, really thanks!
 

LJ H

Occasional Visitor
Thanks bro!!!
Works like a charm and all the wifi drop issues seems to have been fixed. 5GHZ band signal strength is much better now.
were there known drop issues with Voxel's last firmware, or are you referring to NG's firmware?

I was experiencing some very infrequent drop issues with the last Voxel firmware (only during downloads), but I wasn't sure if it was my hardware or not
 

rk8531

Regular Contributor
were there known drop issues with Voxel's last firmware, or are you referring to NG's firmware?

I was experiencing some very infrequent drop issues with the last Voxel firmware (only during downloads), but I wasn't sure if it was my hardware or not
I don't know about any known issues with wifi in last firmware. My issue might be happening because i upgraded from DD Wrt. However, with this latest firmware I am not witnessing any issues with wifi stability. At least not in last 20 hours.
 

LJ H

Occasional Visitor
I don't know about any known issues with wifi in last firmware. My issue might be happening because i upgraded from DD Wrt. However, with this latest firmware I am not witnessing any issues with wifi stability. At least not in last 20 hours.
ha, i actually upgraded from ddwrt too, then i had to go back to a very old version of NG's official firmware and incrementally upgrade to Voxel's because I couldn't install his latest directly.

but yea, no issues thus far for me either. fingers crossed

oh and thanks voxel!
 

theedman

New Around Here
I have an internal PiHole set up on my network that did not work under stock .62. Using Voxel's modified .62 (.63SF), the issue with using an internal PiHole isn't present, so something he did fixed it. I'm not sure what he did to fix it but everything works as expected, and is super stable.
 

Voxel

Very Senior Member
so something he did fixed it. I'm not sure what he did to fix it but everything works as expected, and is super stable.
I did not fix because I was not aware of this. Just rather not including this bug into my version.

I think it is side effect of:

16. Funjsq service is removed:
Positive side effect for PiHole owners.

Voxel.
 

XheliPilot

Occasional Visitor
Thanks, but believe me: you are under risk if you are using WAN port in AP mode. Broken files.

Voxel.
10-4 understood.

JFYI I have always used the WAN on the R7800 as a wireless AP and have downloaded your FW and all windows updates wirelessly with no issues. Maybe I'm just getting lucky and may only occur on larger files.

I will of course change this to the LAN port per your advice. Thanks Voxel!
 

Voxel

Very Senior Member
I have never enabled or used DNScrypt before but wanted to try it with the DNS service I am currently using, Quad9. Is that possible?
Why not? You should just edit /etc/dnscrypt-proxy-2.toml changing the line

Code:
. . .
server_names = [...]
. . .
and adding your Quad9 servers. Use this list for Quad9 names:

https://dnscrypt.info/public-servers

After this do not forget to enable DNSCrypt Proxy 2.

Voxel.
 

Dave Parker

Senior Member
Props to Voxel. You know what Voxel if ppl dont appreciate your hard work that you put into the firmware, they dont have to use it. Personally my smb speeds are almost twice as fast as stock. Maybe ng should toss their team and bring you on imho. Thanks again
Props to Voxel. You know what Voxel if ppl dont appreciate your hard work that you put into the firmware, they dont have to use it. Personally my smb speeds are almost twice as fast as stock. Maybe ng should toss their team and bring you on imho. Thanks again
Hey Gallo, I got that router, know a lot more about Porter Cable than Asus.
 

ablatt

Regular Contributor
Thanks, but believe me: you are under risk if you are using WAN port in AP mode. Broken files.

Voxel.
What exactly does this mean? Broken files?

I've only used stock Netgear firmware up until now and have always used the WAN port in AP mode. Is there a known security or other issue doing this?
 

kamoj

Very Senior Member
Thank you Voxel!

Just installed and tried OpenVPN client speed against ookla.
Got a download speed of 124986 Kbps without my special optimizations,
but forcing full Voxel optimizations by restarting the OpenVPN client after boot.

This is the best I've seen ever with Voxel FW.
 

LJ H

Occasional Visitor
ha, i actually upgraded from ddwrt too, then i had to go back to a very old version of NG's official firmware and incrementally upgrade to Voxel's because I couldn't install his latest directly.

but yea, no issues thus far for me either. fingers crossed

oh and thanks voxel!
alright well i'm definitely still getting drop issues when downloading

not every single time, but only happens when downloading. every device connected to the 5ghz band drops

any suggestions?

hoping it's not a HW issue, but i didn't pay full price so w/e
 

vit5421

Occasional Visitor
My 5ghz is rock stable here for several months but it can be hundred different local reasons for instability.
Look around if you have any interference from neighbors and try to change channels and so on.
Once i had a problem with Astro wireless gaming headphones using 149-161 on 5ghz and affecting my router performance badly. And so on
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top