What's new

Custom firmware build for R7800 v. 1.0.2.68SF

Voxel

Very Senior Member
so what i must to do?
yes, I use telnet to see it by command cat /var/log/openvpn-client.log
I guess this is not /var/log/openvpn-client.log but two different processes produce mixed output to your console. I.e. first process is "cat /var/log/openvpn-client.log" and second is ReadyCLOUD startup script i.e. "/sbin/cloud update". ReadyCLOUD is NG's package, their design and it is installed automatically after flashing new fw.

In general this should NOT influence to the work of your OpenVPN client. But it is better to fix your cloud installation (according to log - it is installed partially or just incorrectly.

Variant 1: if you do not use and not need ReadyCLOUD, just disable it to save resources of your router. How: it is written in my README or here, I wrote this briefly, commands in telnet:

https://www.snbforums.com/threads/c...-v-1-0-4-31hf-1-0-4-31-1hf.56941/#post-501736

Variant 2: if you use ReaduCLOUD and you need it then you should recover its installation:

(a) stop OpenVPN client from telnet (/etc/init.d/openvpn-client stop). It is better to do to avoid re-installation of ReadyCLOUD from your OpenVPN traffic (slower or maybe problematic some time).
(b) kill all ReadyCLOUD programs running (killall cloud; killall xagent; killall run_server.sh; killall nas_service). To say true it is difficult to enlist all processes here. Depends on your concrete problem with ReadyCLOUD.
(c) uninstall ReadyCLOUD (/sbin/cloud uninstall)
(d) try to install it again with stopped OpenVPN client (/sbin/cloud update)
(e) reboot your router (reboot)

There could be some nuances when you stop ReadyCLOUD and uninstall it because I cannot guess what concretely was installed wrongly and what part is trying to access /opt/xagent.

Voxel.
 

ulaganath

Senior Member
View attachment 18708


Above is a screenshot from my iPhone.




Voxel.
Right when i enabled in stock it was there. But the current and previous version keep saying offline. When i tried to disable and re-enable the above pop up coming. Will try to reset if not flash the next firmware.
 

Voxel

Very Senior Member
Right when i enabled in stock it was there. But the current and previous version keep saying offline. When i tried to disable and re-enable the above pop up coming. Will try to reset if not flash the next firmware.
As I wrote two times, this is already third:

So check first that you are able to use ReadyCLOUD.
Something is wrong with your ReadyCLOUD installation. I've tried real remote management being far from my LAN and R7800. It is working when ReadyCLOUD is installed.

I wrote here:

https://www.snbforums.com/threads/c...r-r7800-v-1-0-2-68sf.57646/page-2#post-505735

in "Variant 2" how to repair your wrongly installed ReadyCLOUD from telnet. From p. (b) to (e).

Voxel.
 

mr-b

Occasional Visitor
Hi - just upgraded from .64 to .68 with no GUI login issues. :)

I had a couple of architecture questions though ...
I then changed the router from AP to router mode since I want to use the OpenVPN server.
To do this using DDNS it appears that I have to use the WAN port since otherwise DDNS won't work since it needs a WAN ip.
Is the potential WAN port AP corruption issue still possible even if not in AP mode? (https://www.snbforums.com/threads/r7800-data-corruption-when-in-accesspoint-mode.54744/)

Also since I'm still using the router as an AP, it seems then that I have to configure a different ip on the LAN interface, which then requires me to enable DHCP server for wifi clients. This isn't optimal for me since I run a separate DHCP server (on pfsense) and I'd prefer to have a single DHCP server managing everything (which was the case when using AP mode with the LAN port since I just had a single LAN ip address on the same subnet as the DHCP server).
So am I stuck with the two subnets?
 

ulaganath

Senior Member
As I wrote two times, this is already third:



Something is wrong with your ReadyCLOUD installation. I've tried real remote management being far from my LAN and R7800. It is working when ReadyCLOUD is installed.

I wrote here:

https://www.snbforums.com/threads/c...r-r7800-v-1-0-2-68sf.57646/page-2#post-505735

in "Variant 2" how to repair your wrongly installed ReadyCLOUD from telnet. From p. (b) to (e).

Voxel.
Thanks for the guide. I get the below error. Do i need to flash the firmware.

upload_2019-7-25_7-58-18.png
 

ulaganath

Senior Member
Now its working. Thanks.

it was simple fix. kudo's voxel. I was not checking earlier post apologies.

upload_2019-7-25_8-12-58.png
 

Voxel

Very Senior Member
Is the potential WAN port AP corruption issue still possible even if not in AP mode? (https://www.snbforums.com/threads/r7800-data-corruption-when-in-accesspoint-mode.54744/)
I think no. I did not face such problems in router mode. Only AP mode (and maybe bridge mode).


Also since I'm still using the router as an AP, it seems then that I have to configure a different ip on the LAN interface, which then requires me to enable DHCP server for wifi clients. This isn't optimal for me since I run a separate DHCP server (on pfsense) and I'd prefer to have a single DHCP server managing everything (which was the case when using AP mode with the LAN port since I just had a single LAN ip address on the same subnet as the DHCP server).
So am I stuck with the two subnets?
I am not sure. Seems all the logic of firmware does not allow this... A bit specific configuration.

Maybe it has a sense to try OpenVPN server in AP mode. Using e.g. Entware. For example, generate both OpenVPN server configs/certs/etc when your R7800 is in router mode (they are stored in /tmp/openvpn), download client configs and after that use these configs manually in AP mode installing Entware and OpenVPN from Entware. If you are in touch with Linux...

Voxel.
 

mr-b

Occasional Visitor
Thanks for the info. I've switched back to using the LAN port but will keep it in router mode, and will run OVPN on the Pfsense box for now as it just makes more sense there and it keeps the DHCP config simpler.
I will check out Entware when I feel like dusting off my ancient Unix "skills". ;-)
 

e38BimmerFN

Very Senior Member
I have my R7800 in AP mode using the WAN port connected to a Edge Router X since v68SF was loaded. Still running great here.
Thank you Voxel. ;)
 

Adam Bowers

New Around Here
I know this isn't specific to Voxel's firmwares, but is there any other way to set the device type and names? The GUI seems to have problems with about 1/2 of my devices where I can't update the settings in the Attached Devices list.
 

RMinNJ

Regular Contributor
I read some folks had luck with the NG phone app. But I've really given up on that page...it the buggiest page ..
 

LeKeiser

Regular Contributor
I totally agree, I also went for a R7800 because Voxel is working and delivering great firmwares for this router. Never been happier with a router :) And I often check if there is a new one firmware available to download and install.
So thanx a LOT Mr Voxel!! Keep up the great work as long as you can :)
 

spocko

Occasional Visitor
Unfortunately NG does not understand that I make money for them.
I wish they did. I was thinking that they should at least send you free samples of hardware to help you continue your development. Kinda of like how some cell phone vendors have provided seed hardware to developers.
 

kokishin

Regular Contributor

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top