Voxel Custom firmware build for R7800 v. 1.0.2.78SF

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Voxel

Very Senior Member
Continuation of
. . .
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-76sf-v-1-0-2-76-1sf.63488/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-77sf.64371/

New version of my custom firmware build: 1.0.2.78SF.

Changes (vs 1.0.2.77SF):

1. dropbear package is upgraded 2019.78->2020.79
(scp fix for CVE-2018-20685:
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-20685
support of ed25519 hostkeys and authorized_keys,
adding chacha20-poly1305 authenticated cipher etc).​
2. iptables package is upgraded 1.8.4->1.8.5.
3. ca-certificates package is upgraded 20190110->20200601.
4. DNSCrypt Proxy v.2 is upgraded 2.0.42->2.0.44.
5. curl package is upgraded 7.70.0->7.71.0.
6. haveged package is upgraded 1.9.8->1.9.12.
7. proftpd package is upgraded 1.3.6c->1.3.6d.
8. pcre package is upgraded 7.6->8.44.
9. sqlite package is upgraded 3320000->3320100.
10. sysstat package is upgraded 12.1.1->12.2.2.
11. transmission package: optimize for a size.
12. db4 package: optimize for a size.
13. Toolchain: Go is upgraded 1.14.3->1.14.4.

The link is:

https://www.voxel-firmware.com (thanks to vladlenas for his help with hosting).

Voxel.
 

microchip

Very Senior Member
Good work! Thanks!
 

Sekers

New Around Here
Thanks! Just downloaded. The R7800 is the most reliable router I've owned and has pretty decent range on the 5Ghz band and is enough to cover our entire condo from the router on one side to the balcony all the way to the other side of the condo (of course, the 2.4 band goes even further). I've been a fan of your firmware for a quite a while now. It's solid.
 

Thang

New Around Here
After contacting the admin / mod, I was able to comment and like your Voxel post. Thank you very much, today I have donated to you, although not much, but my appreciation for what you are doing. Thank you again !
From Gg trans !
 
Last edited:

ulaganath

Senior Member
Am i seeing this
upload_2020-6-27_10-43-2.png


Ignore it was my firewall blocking due to certificate issue. Managed to grab the firmware. Its just like a snap. It makes the flashing like a snap .

Thanks a lot Voxel. Without you i dont think netgear routers may not have such popularity.

I am waiting for the ax series of their line up from Qualcomm. I even raised why did they choose brodcom over Qualcomm and they refused to answer on netgear tech chat live session i used to attend every Friday and i believe it still happening.
 
Last edited:

ASCDE

New Around Here
Out-of topic:

Just interesting. R7800 is still most popular from the list of routers supported by me. 15 min after publishing this thread and about 100 downloads... First is from Arizona. Greetings Arizona ;).

Voxel.
Hey, all because you are doing a great job. Your FW is highly recommended especially as NG not taking care any vul. even high risk security issues are announced in the IT Tech news.##
https://www.tomsguide.com/news/netgear-security-firmware-patches
https://www.heise.de/security/meldu...nommen-erste-Sicherheits-Updates-3569299.html
THX
 

funmonkey

New Around Here
Thank you for your latest firmware so far I have had no problems. A question if anyone can answer this. Is there any way to get line stats from a modem (vigor 130) to be available through the wan port. Its enabled modem side but the IP is not exposed to the router to access it. The only way is to disconnect from the Wan port and plug it into the Lan port.
Thank You Voxel.
 

tarassippo

Regular Contributor
Is there any way to get line stats from a modem (vigor 130) to be available through the wan port. Its enabled modem side but the IP is not exposed to the router to access it. The only way is to disconnect from the Wan port and plug it into the Lan port.
On a router using standard iptables, you could easily do the following to access the modem web GUI - i.e. 192.168.2.1 is the modem IP address:
Code:
ifconfig $(nvram get wan_ifname):1 192.168.2.2 netmask 255.255.255.0

iptables -t nat -I POSTROUTING -s ! $(nvram get lan_ipaddr) -d 192.168.2.1 -j SNAT --to 192.168.2.2
Unfortunately, Netgear don't use standard iptables, so this method I believe can work for a short time until the firewall stops it...

I'm afraid I can't be of any further help...
 

R. Gerrits

Senior Member
If tarassippo's iptables commands do work, then you can simply put then in a script called /opt/scripts/firewall-start.sh (and make that script executable).
This way the rules are re-added everytime the firewall is restarted.

I do see a potential conflict with OpenVPN server though, as that also uses the range 192.168.2.x/24.
(if it is enabled, and if the regular lan subnet is 192.168.1.x/24)
 

funmonkey

New Around Here
On a router using standard iptables, you could easily do the following to access the modem web GUI - i.e. 192.168.2.1 is the modem IP address:
Code:
ifconfig $(nvram get wan_ifname):1 192.168.2.2 netmask 255.255.255.0

iptables -t nat -I POSTROUTING -s ! $(nvram get lan_ipaddr) -d 192.168.2.1 -j SNAT --to 192.168.2.2
Unfortunately, Netgear don't use standard iptables, so this method I believe can work for a short time until the firewall stops it...

I'm afraid I can't be of any further help...
Thanks for your help I have tried the commands, But unfortunately the second command comes up with an error. Router IP 192.168.1.1 Modem 192.168.2.1.

[email protected]:/$ iptables -t nat -I POSTROUTING -s ! $(nvram get lan_ipaddr) -d 192.168.2.1 -j SNAT --to 192.168.2.2
Bad argument `192.168.1.1'
 

R. Gerrits

Senior Member
The ! should be in front of the -s

Code:
iptables -t nat -I POSTROUTING ! -s $(nvram get lan_ipaddr) -d 192.168.2.1 -j SNAT --to 192.168.2.2
 

funmonkey

New Around Here
The ! should be in front of the -s

Code:
iptables -t nat -I POSTROUTING ! -s $(nvram get lan_ipaddr) -d 192.168.2.1 -j SNAT --to 192.168.2.2
That command worked :):) but unfortunately, I can't access the modem on 192.168.2.1 But I can access the router page from 192.168.2.2 and obviously 192.168.1.1.
 

tarassippo

Regular Contributor
Try these:
Code:
ifconfig $(nvram get wan_ifname):1 192.168.2.2 netmask 255.255.255.0

iptables -t nat -I POSTROUTING -o $(nvram get wan_ifname) -j MASQUERADE
 

funmonkey

New Around Here
Try these:
Code:
ifconfig $(nvram get wan_ifname):1 192.168.2.2 netmask 255.255.255.0

iptables -t nat -I POSTROUTING -o $(nvram get wan_ifname) -j MASQUERADE
Commands work but no access to 192.168.2.1 (modem) still have access to the Router login from both IP addresses but not the modem.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top