Voxel Custom firmware build for R7800 v. 1.0.2.78SF

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

funmonkey

New Around Here
So why you can't reach your modem on 192.168.2.1 ?

Can you ping 192.168.2.1 ?
No ping to that address but can ping to 192.168.2.2, Yeah I have no idea why it won't allow me. I will plug the modem in the LAN port again to check if it's still reachable just incase.
 

tarassippo

Regular Contributor
Yes, you can ping 192.168.2.2 as it' still your Netgear router...

Can you double-check your modem IP address is actually 192.168.2.1 ?
 
Last edited:

kamoj

Very Senior Member
I remember some discussions about brwan vs ppp0.
When using PPTP, L2TP, PPPoE, nvram get wan_ifname could not be used, but rather:
Code:
ifconfig ppp0 >/dev/null 2>&1 && WAN_IF="ppp0" || WAN_IF=$(nvram get wan_ifname)
I did the this to access my modem at 192.168.100.1 :
Code:
route add -net 192.168.100.0 netmask 255.255.255.255 gw 192.168.1.1
ip route flush cache
I'm sure this should be an own thread... :oops:
 
Last edited:

funmonkey

New Around Here
I remember some discussions about brwan vs ppp0.
When using PPTP, L2TP, PPPoE, nvram get wan_ifname could not be used, but rather:
Code:
ifconfig ppp0 >/dev/null 2>&1 && WAN_IF="ppp0" || WAN_IF=$(nvram get wan_ifname)
I did the this to access my modem at 192.168.100.0 :
Code:
route add -net 192.168.100.0 netmask 255.255.255.255 gw 192.168.1.1
I'm sure this should be an own thread... :oops:
Still can't access the modem with the route command, Yeah it should be in its own thread I thought it was simple to answer. :cool:
 

utopiafallen

New Around Here
Not sure if I should make a separate thread for this, but is it possible to continue using dnscrypt-proxy when the device is running in AP Mode? I've tried setting the device's IP when in AP mode as my DNS server but that didn't work. Thanks!
 

Armitage

New Around Here
Great firmware, I've updated from official and this is miles better and nice and stable. Thank you for making it Voxel.

I do have a couple of minor questions though regarding the DLNA/Media server function. Brief background; I have two hard drives connected to the R7800's two USB ports. One's my drive full of media and I named the share as such, the other I use as storage also named as such. The media server works properly and far better than the official firmware's implimentation as playback positions are remembered and also artwork is displayed which is a breath of fresh air, but when I access it from my TV it just shows the two drives as sda1 and sdb1 where as on the official firmware it correctly labelled them as the share name I have set in the router. Is there an option I've missed to fix this?

The other thing is again with my TV, when I used to access the shares from it on the official firmware it would first show me a list of folders with media types on them (video, music, photos and all media) so I could limit what media type I saw in the folders, but the new firmware doesn't offer this when I load it on the TV, it just shows me what folders are available in the shares and shows the entire contents them. Some of the folders (in particular my tv shows) have a lot of thumbnails and nfo files in them as well as the actual videos as I use the share with a Kodi box in another room that needs that sort of thing to sort the videos. Is there a way I can enable the sorting feature from the official firmware in the new one?

Anyway thanks again!
 

Voxel

Very Senior Member
Is there a way I can enable the sorting feature from the official firmware in the new one?
Yes. Above scheme was used because of users requests. If you need the scheme like in stock you should change the file /sbin/cmddlna removing the line with "root_container=B"

. . .
notify_interval=900
serial=12345678
model_number=1
root_container=B
EOF
. . .


Try to do remove this line or to comment it.

Voxel.
 

Voxel

Very Senior Member
but is it possible to continue using dnscrypt-proxy when the device is running in AP Mode?
In general dnscrypt2 works in AP mode but there are specific iptables rules and dnsmasq work.

dnscrypt2 is using (internally) the port 64153. So if you start dnscrypt2 and if you have the Entware package bind-dig installed you can see from telnet that it works:

Code:
dig -p 64153 @127.0.0.1 www.abc.com
i.e. it is able to resolve the host e.g. www.abc.com. But it is necessary to change iptables rules allowing external requests from your LAN. Sorry, but I really do not have now a time to test/check this. If you are experienced in Linux you can try to do that yourself. Or other guys from this forum can help you :).

Voxel.
 

Armitage

New Around Here
Yes. Above scheme was used because of users requests. If you need the scheme like in stock you should change the file /sbin/cmddlna removing the line with "root_container=B"

. . .
notify_interval=900
serial=12345678
model_number=1
root_container=B
EOF
. . .


Try to do remove this line or to comment it.

Voxel.
Great that worked, thanks. I'll see if I can fix the volume labels while I'm fiddling with that script too.
 

utopiafallen

New Around Here
@Voxel Thanks for your hints. Based on my testing, the only thing stopping dnscrypt-proxy from being utilized is the fact that dnsmasq no longer runs when in AP mode. Looking at /etc/init.d/dnsmasq, I can't see why it wouldn't start at boot. Do you have any more hints for me? :) Thanks!
 

Voxel

Very Senior Member
the only thing stopping dnscrypt-proxy from being utilized is the fact that dnsmasq no longer runs when in AP mode
My R7800 in AP mode:

Code:
[email protected]:~$ ps |grep dnsmasq
 4777 root        780 S   /usr/sbin/dnsmasq --except-interface=lo -r /tmp/resolv.conf --wan-interface=br0
31260 root        636 S   grep dnsmasq
Voxel.
 

Friction57

New Around Here
@Voxel Thank you for your continued efforts and updates to the R7800 firmware.

Forgive me if this has already been discussed, but its something I have to contend with every time I update the FW. It seems the R7800, by default, provides itself as the DNS server to any client connected to it, and then sends any DNS requests to the address specified in the Internet Setup admin page. This made if difficult for me assign logical names to my clients in my local DNS filter's hosts table (a Raspberry Pi running Pihole). The solution I've encountered is the following:

1. Enable telnet via the Debug.htm page.

2. Telnet into the R7800 and change directory to /etc/init.d

3. Edit net-lan, find the line "print_dhcpd_conf()"

4. Replace "option dns $($CONFIG get lan_ipaddr)" with "option dns aaa.bbb.ccc.ddd", where aaa.bbb.ccc.ddd is your preferred DNS server. You can create up to 3 entries.

5. Save and reboot.​

I change this address to my DNS filter because without it, the filter only receives the R7800's address and I can't track what clients are having DNS requests blocked, passed, etc.

Is there a way to modify the firmware of the R7800 to pass along the DNS address that is specified in the Internet Setup admin page instead of having the requests route back through itself?

I hope this made sense. I'm still a noob at a lot of this stuff.
 

kamoj

Very Senior Member
https://www.snbforums.com/threads/kamoj-add-on-5-1-beta-testing-poll.62315/page-22#post-600674
???
@Voxel Thank you for your continued efforts and updates to the R7800 firmware.

Forgive me if this has already been discussed, but its something I have to contend with every time I update the FW. It seems the R7800, by default, provides itself as the DNS server to any client connected to it, and then sends any DNS requests to the address specified in the Internet Setup admin page. This made if difficult for me assign logical names to my clients in my local DNS filter's hosts table (a Raspberry Pi running Pihole). The solution I've encountered is the following:

1. Enable telnet via the Debug.htm page.

2. Telnet into the R7800 and change directory to /etc/init.d

3. Edit net-lan, find the line "print_dhcpd_conf()"

4. Replace "option dns $($CONFIG get lan_ipaddr)" with "option dns aaa.bbb.ccc.ddd", where aaa.bbb.ccc.ddd is your preferred DNS server. You can create up to 3 entries.

5. Save and reboot.​

I change this address to my DNS filter because without it, the filter only receives the R7800's address and I can't track what clients are having DNS requests blocked, passed, etc.

Is there a way to modify the firmware of the R7800 to pass along the DNS address that is specified in the Internet Setup admin page instead of having the requests route back through itself?

I hope this made sense. I'm still a noob at a lot of this stuff.
 

kamoj

Very Senior Member
No problem. But...
If you want Netgear to do anything, this is the wrong forum and thread.
@kamoj Apologies for bringing up an already-covered-topic...

My question isn't really about the problem or the solution, more, can the solution be baked into the firmware and why wouldn't we want it that way?
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top