Voxel Custom firmware build for R7800 v. 1.0.2.83SF

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

pege63

Very Senior Member
No i never lose the radio after update, its only that i cant enter the settings as in the photo anymore.
I tried all the resets its still the same, cant enter in any mode.
Before the update all settings worked and i could enter them all.
Unfortunately, I deleted my old Voxel FW file and i don't remember the FW version.

1617214914890.png
 

Voxel

Part of the Furniture
No i never lose the radio after update, its only that i cant enter the settings as in the photo anymore.
I tried all the resets its still the same, cant enter in any mode.
Before the update all settings worked and i could enter them all.
Unfortunately, I deleted my old Voxel FW file and i don't remember the FW version.

View attachment 32656
Maybe you have to clear the cache in the browser. Or try plain http instead of https if you are using https. Or other browser?

Voxel.
 

pege63

Very Senior Member
Maybe you have to clear the cache in the browser. Or try plain http instead of https if you are using https. Or other browser?

Voxel.
Good idea, but no luck on that.
I also can not enter into the Schedule settings as well?

1617218592202.png
 
Last edited:

Voxel

Part of the Furniture
Good idea, but no luck on that.
I also can not enter into the Schedule settings as well?

View attachment 32659
I have no ideas what's wrong.

There are nvram values to enable/disable this schedule from telnet/ssh:

to enable:
Code:
nvram set wladv_schedule_enable=1
nvram set wladv_schedule_enable_a=1
nvram commit

to disable:
Code:
nvram set wladv_schedule_enable=1
nvram set wladv_schedule_enable_a=1
nvram commit

and try to check what is in your nvram with schedules:
Code:
nvram show | grep sched

Voxel.
 

jkxs

Occasional Visitor
Finally fixed the issue of getting through setup by only having the ethernet in from ONT directly attached to the R7800 internet/WAN port.
Turned off my Verizon router and restarted my ONT battery box and R7800. Connected laptop to R7800 LAN port #1 (nothing else connected). Once the R7800 got internet, I started adding stuff onto the R7800 LAN ports.
 
Last edited:

Easy Rhino

Regular Contributor
Hey Voxel what NG firmware is the baseline for this one?
it looks like netgear's latest verson is 1.0.2.82, and was released on March 26. but I know you have said they are sometimes a few releases back on their open source downloads.
 

LeKeiser

Regular Contributor
Hey Voxel what NG firmware is the baseline for this one?
it looks like netgear's latest verson is 1.0.2.82, and was released on March 26. but I know you have said they are sometimes a few releases back on their open source downloads.
Hello,
Voxel already replied here :
 

pege63

Very Senior Member
Finally fixed the issue of getting through setup by only having the ethernet in from ONT directed to the R7800 internet/WAN port. Turned off Verizon router, restarted ONT battery box and R7800 and only connected laptop to R7800 LAN port #1. Then started adding stuff onto the R7800 LAN ports.

Yes if ONT is your incoming Fiber Box and you skip your ISP (Verizon) Router, then you connect to the R7800 WAN port.
But if you using the your ISP Verizon Router you use the WAN and from Verizon LAN port, you should connect to the R7800 LAN port IF it is in AP mode.

Dont you get your services ID to Internet, IPTV, VOIP and so on from your ISP Verizon Router?
 
Last edited:

pege63

Very Senior Member
Unfortunately it's a common problem to lose radio when updating firmware. Netgear/Voxel same issue.
Ever tried the kamoj add-on, and it's wifi supervision?
Or try this from a command prompt:
Code:
   wlan down;wlan up;for i in 1 2;do { [ "$(dni_wlan radio 11a -s)" != "ON" ] || [ "$(dni_wlan radio 11g -s)" != "ON" ]; } && wlan toggle; done
If not helping read the kamoj FAQ.txt and to the "better factory reset" described there.
Good luck!
Where can i download the kamoj add-on again, i have forget where?
 

HELLO_wORLD

Very Senior Member
Question to @Voxel :

Are packages zebra and ripngd updatable or stuck because of kernel/NG?

Version in firmware are:
Code:
[email protected]:~$ /usr/sbin/zebra -v
zebra version 0.95a (arm-openwrt-linux)
Copyright 1996-2001, Kunihiro Ishiguro
[email protected]:~$ /usr/sbin/ripngd -v 
ripngd version 0.95a (arm-openwrt-linux)
Copyright 1996-2001, Kunihiro Ishiguro
Latest version (not recent) is 1.2.4.
 

pege63

Very Senior Member
I also have problems to set NTP server for time, and it has internet connection but still does not work?
And the NTP settings are the same as on my gateway (ntp1.rgw.telia.se, ntp2.rgw.telia.se)

I notice that is shows time BUT its 1h behind, but stills get the message:
Warning:The router has failed to connect to the selected NTP server,please check your internet connectivity or try another NTP server

1617440461592.png

1617440937487.png

And what is this block schedule, block what?
And i cant enter the setting in here as well?

1617442123147.png

pege63
 

Attachments

  • 1617441950808.png
    1617441950808.png
    186.6 KB · Views: 39
Last edited:

pege63

Very Senior Member
This is to block access to the internet on certain times.
And in the screenshot, apparently you blocked all days from 00:00 to 24:00, so you blocked internet access always.
This would also explain why it cannot connect to NTP or reach cloudfare...
Yes, BUT the thing is hat i have Internet access on both LAN & WIFI and all clients can connect to the router and they all have internet access.
Must be a way to upload a "empty" *.cfg file to the router, where this is not ticked in NTP & schedule.

Or is there a code to delete the schedule settings?
But on the other side the commands from a router shell/prompt to Erase all configuration data did not worked at all, everything was still there after reboot.
 
Last edited:

redpaw.rider

Occasional Visitor
I saw the title of the post and took a bit to realize what it was. Had no idea there was firmware work going on here - i thank you too and appreciate this type of effort more than any other for many reasons so share any help or support you need.

I’m guessing this is in wireless devices or something you’ve created a device for?
 

Voxel

Part of the Furniture
Question to @Voxel :

Are packages zebra and ripngd updatable or stuck because of kernel/NG?

Version in firmware are:
Code:
[email protected]:~$ /usr/sbin/zebra -v
zebra version 0.95a (arm-openwrt-linux)
Copyright 1996-2001, Kunihiro Ishiguro
[email protected]:~$ /usr/sbin/ripngd -v
ripngd version 0.95a (arm-openwrt-linux)
Copyright 1996-2001, Kunihiro Ishiguro
Latest version (not recent) is 1.2.4.

I did not upgrade them because they are started only when IPv6 is enabled (/etc/net6conf/6service). If you test them installing e.g. from Entware and using their config I am ready to upgrade zebra/ripngd.

Voxel.
 

HELLO_wORLD

Very Senior Member
I did not upgrade them because they are started only when IPv6 is enabled (/etc/net6conf/6service). If you test them installing e.g. from Entware and using their config I am ready to upgrade zebra/ripngd.

Voxel.
The Entware version does not work. The problem is it is configured for user/group network/network, where I believe it should be root/root:
Code:
[email protected]:~$ zebra -v
zebra version 1.2.4
Copyright 1996-2005 Kunihiro Ishiguro, et al.
configured with:
        --target=arm-openwrt-linux --host=arm-openwrt-linux --build=x86_64-pc-linux-gnu --program-prefix= --program-suffix= --prefix=/opt --exec-prefix=/opt --bindir=/opt/bin --sbindir=/opt/sbin --libexecdir=/opt/lib --sysconfdir=/opt/etc --datadir=/opt/share --localstatedir=/opt/var --mandir=/opt/man --infodir=/opt/info --disable-nls --localstatedir=/opt/var/run/quagga --sysconfdir=/opt/etc/quagga/ --enable-shared --disable-static --enable-user=network --enable-group=network --enable-multipath=8 --disable-ospfclient --disable-capabilities --disable-doc --disable-nhrpd --enable-zebra --enable-ospfd --enable-bgpd --enable-isisd --enable-ospf6d --enable-ripd --enable-ripngd --enable-vtysh

Do you have the configure setup used for the NG GNU version?
EDIT: found it in your GitHub https://github.com/SVoxel/R7800/blob/master/package/zebra/Makefile
I will try to compile 1.2.4 with same setup
 
Last edited:

Voxel

Part of the Furniture
I will try to compile 1.2.4 with same setup
Compilation is not the only problem I think...

The problem is it is configured for user/group network/network, where I believe it should be root/root:
As far as I understand it is possible to use the options -u root -g root... But does not work as well. I cannot be an expert in all of packages of firmware, e.g. this zebra... Sorry.

Good luck with your attempts.

Voxel.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top