DNSMASQ fails to start after upgraded addon script. 386.4

johndoe85

Regular Contributor
I have these scripts installed.

2 open Skynet v7.2.8

4 open YazFi v4.4.1
6 open x3mRouting v2.4.5

7 open unbound Manager v3.22
8 open nsrum v30.4.0

j7 open YazDHCP v1.0.3

ag open AdGuardHome v1.0.4

ep manage Entware packages

em open email settings
sw manage Swap file /mnt/RT-AX86U 2.0G

after updating skynet and adguard home and rebooted the router i now get this in syslog.

Jan 14 13:48:27 dnsmasq[11776]: illegal repeated keyword at line 50 of /etc/dnsmasq.conf
Jan 14 13:48:27 dnsmasq[11776]: FAILED to start up

pastebin of dnsmasq.conf

line 50 contains port=553

i have tried to delete that line and reboot the router but something is putting the line back, and i dont know what.
 

ColinTaylor

Part of the Furniture
A quick search of the forum suggests that this line comes from AdGuard home. Try uninstalling that and seeing if the problem goes away. If not examine your dnsmasq.postconf file.
 

johndoe85

Regular Contributor
A quick search of the forum suggests that this line comes from AdGuard home. Try uninstalling that and seeing if the problem goes away. If not examine your dnsmasq.postconf file.
I did uninstall and reinstall yazfi and yazdhcp and it seemed to correct the error. But where it comes from i dont know, i thought it could be of interest to the coders here.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top