What's new

Flashing ZenWifi XT8 to GNUton's Merlin

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

I will power the main router off and on now... does it matter whether I use the power button on the back (where the ports are), or just unplug/plug?
Whew! Thanks for bailing me out, glens!! I've made some progress (in a fumbly way). I unplugged and re-plugged the main router, and tried to do a WPS reset on it. (I was relieved to see the LED light.) Then, I tried to proceed as though it had been successfully flashed. I rebooted the modem and connected it to the main router's WAN port, shut my computer down and turned it back on, connected the main router to computer with ethernet cable. The ASUS Welcome page came up, and I chose "set up new network". I tried to get it to detect the node, but is said it couldn't find it. But then when I went forward, and set up the SSID and the router login info, and it showed me the network, and it seemed to have the node attached by AiMesh. On the Admin>Firmware upgrade page, I could see that the node was on GNUton, but the main was still on Asus. So I flashed the FW, and this time it worked!

I am thrilled to have internet again, but was too nervous to continue with any more steps tonight - don't want to lose internet again! (Thank goodness, my cell signal - very weak at my house - was strong enough for me use to hotspot my ipad and computer. There have been times when I've been without any connectivity.)

I need to remove the ethernet cable that is still connecting my computer to the router -- I can just remove it, right? The computer shows it is on the wifi network (as well as ethernet). And then I need to move the node to where it actually is supposed to be.

And I need to do the final WPS reset on the main router - I really hope that won't screw anything up. Will I have to go thru the whole Welcome/QIS setup again?

Given that I am on GNUton-Merlin software, should I check yes or no for Administration>Firmware version>Scheduled check for new FW?

Then, I have some more questions, if anyone has the patience for them. If I set up a Guest Network - should it be 2.4 or 5 gHz? Do I need a separate Guest Network for each device (eg, smart TV, internet radios)??

If I don't enable AiProtection and Network Protection (because I am not comfortable with Trend Micro's privacy policy), are there other security settings I should set? (I plan to sign up for a paid VPN, and add that.)

Thanks again SO much!
Hi guys,
Just wanted to check in with you before attempting the same upgrade of my Zenwifi XT8 set. I have been running on an older firmware for a long time to avoid having mesh-issues. It has been running quite stable so far. But I would for multiple reasons like to upgrade to a more recent build.
Would you guys still recommend GNUton's Merlin build?
Best regards
Welcome to the forums @KristianLH.

Yes. GNUton's builds are highly recommended.
Would you guys still recommend GNUton's Merlin build?

Make a backup of your current settings, try the firmware you want. Revert, reset and restore in case of issues.

For wireless AiMesh I would recommend staying with stock Asuswrt firmware. If your XT8 setup is stable - don't touch.
We seem to be doing well on GNUton's Merlin, using XT8 on wireless AiMesh. (I think we might have been ok on the last Asus FW, as well, but we weren't on it long. And both that and Merlin seem better than the earlier Asus FW.) That's not to say that we don't have occasional, momentary glitches - I have no idea why. Like recently, I was on a cell phone call, using wifi calling, and sitting still, and the call dropped and my phone said "no service" - no wifi, and no Consumer Cellular signal - for a moment. Then, it righted itself, but I had to call back to reconnect the call.

For us, the mesh - the extra node - is really only used to get wifi into our detached garage. I think all in-house devices stay on the main router.

Oddly, my cell, for whatever reason, will sometimes switch from our main 5G/2.4G network (both with same SSID and passwords) to our 2.4 G guest network. No idea why, or if I should try to prevent that. (When I had the glitch described above, it was on the main network.)
So far GNUton's Merlin for XT8 is running smoothly here. I have no issues whatsoever. The 5 Ghz uplink to my mesh node seems to stay very stable and I have around 7 client devices on the mesh node +/-.

Actually I didn't even do the WPS-button-reset after upgrading. I didn't find any reason to do that - all my settings have just carried over from the previous (older) Asus firmware.

One of the really handy new features for me is the possibility to use different DNS-services for different clients (DNS Director).

I'm keeping an eye on the system log and watching out for any trouble. But as I said - so far - so good!

Best regards
Which firmware did you load?

388.4 -> 388.5b1 -> 388.5 is a weird progression. The middle one re-added a kernel module that had gone missing, along with some changes in 3 web pages. .5 is bit-for-bit .4 except for some compiled-in timestamps and the executable "wget". The .5 version of wget doesn't know its version number.

I've put up a thread titled something like "Gnuton's 388.5 isn't" as a result of this discovery. I surmise he'd intended to stabilize the beta but it went wrong and he didn't check the results.
Hmm okay?
I went straight to the 388.5 version and as I wrote above haven't had any issues with it so far.
The 388.5 version on /what/? If it ain't a "TUF" (if not a specific one) you're on 388.4 all the same. Except, ssh in and see what "wget" thinks its version is. I get "UNKNOWN" executing it on a system not running the "388.5" release, "proper". --version should work, but consult --help or -h if not.

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!