What's new

FriendlyElec CM3588 DIY NAS board - 4 SSD M2 slots

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

sfx2000

Part of the Furniture
This one is interesting...

 

Attachments

  • CM3588_en_01.jpg
    CM3588_en_01.jpg
    88.7 KB · Views: 59
Looks like it uses the same images as the NanoPC-T6 (RK3588) board that I use. If so then it's more of a beast than you might think - plenty of hardware acceleration! The only downside is that FriendlyElec seem to bulk build the OS image files and then release them without testing. Oh, and I don't see a case for it yet, the 0.5Kg Aluminium case on the NanoPC-T6 is enough to keep the thing cooled with no need for a fan!
 
I'd waited for some more feedback on the device as I thought of this slightly after the original post: I am wondering if the fact that the RK3588 only has 4 lanes of PCIe is going to affect performance.
 
Hi

I have the device in order to test it with the OpenMediaVault image from FriendlyElec... but I have a lot of problems installing some of the plugins :(


caja.jpg


For example, the problem appeared trying to install wireguard and the OpenMediaVault downloader plugin.

The last lines of the error log are:

Updating workbench configuration files ...
Restarting engine daemon ...
Processing triggers for initramfs-tools (0.140) ...
update-initramfs: Generating /boot/initrd.img-6.1.0-0.deb11.13-rt-arm64
W: mkconf: MD subsystem is not loaded, thus I cannot scan for arrays.
W: mdadm: failed to auto-generate temporary mdadm.conf file.
raspi-firmware: missing /boot/firmware, did you forget to mount it?

run-parts: /etc/initramfs/post-update.d//z50-raspi-firmware exited with return code 1
dpkg: error processing package initramfs-tools (--configure):

installed initramfs-tools package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:

linux-image-6.1.0-0.deb11.13-rt-arm64
linux-image-rt-arm64
wireguard
openmediavault-wireguard
initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1) in /usr/share/openmediavault/engined/rpc/pluginmgmt.inc:250


and the full log file is attached :(


HELP, please and thank you in advance
 

Attachments

  • errors_aria.txt
    71.7 KB · Views: 6
I spent a little while on this and got a few things fixed but it just seems that some of the required files from the initial image are just broken (many FriendlyElec RK3588 images seem to include broken packages or lack the needed RK3588 support).
What I haven't tried is using the DietPi image for the board - I suspect this may well work. Armbian, I had little to no luck with historically!
*running the NanoPC-T6 with the accelerated Ubuntu X11 image, which after a great deal of hard work now runs flawlessly, but it's not a project board for a complete beginner!
 
*Follow up: Running Diet Pi on an SD card and there are guides to setting up OMV on the DietPi, but most of them seem to be tales of woe!
 
*Follow up: Running Diet Pi on an SD card and there are guides to setting up OMV on the DietPi, but most of them seem to be tales of woe!
Thank you. I’ll try!

Would it be fine this version?
 

Attachments

  • IMG_9942.png
    IMG_9942.png
    105.7 KB · Views: 32
Yup that's the correct DietPi Image. If you need accelerated video it'd be a bit more work, but headerless it'll do great!
 
Nope the NanoPC-T6 is mostly working as a Cloud Gaming client (very over powered), running Resilio-Sync, and Plex Media Server. So it's X11 (the Wayland images are buggy and the screen colour is washed out) with xfce. Problem with Cloud Gaming is you pretty much have to set the screen resolution to match the stream so that's 1080p/120 for XBox + Luna, and 4K/60 for GeForce Now (TV is the limit on that). *Resilio-Sync is just a part of the backup strategy not the whole thing!
 
Yup that's the correct DietPi Image. If you need accelerated video it'd be a bit more work, but headerless it'll do great!
Thanks but I can't start DietPi image installation in my device :(

1: I upload/burn the DietPi image file in a TD card
2: Turn on the CM3588 with MASK button pushed for 3 seconds in order to avoid the startup from the eMMC... but NOT start
3: Repeaing deleting the start partition in the eMMC ... without any change :(

Help me! THANKS!

Pedro
 
Okay, so that's something that has changed between the two boards then! On the NanoPC-T6 the device will always (annoyingly) default to the SD (TF) card. My daily OS was installed using an SD to EMMC (and SPI) image, and pressing the "mask" button will reload/refresh the SPI image to EMMC. A longer press on the MASK button apparently puts the NanoPC-T6 into USB programming mode (dunno if this just writes to the EMMC or SPI too!).
*To the casual reader, the NanoPC-T6 comes in multiple configurations, some with no EMMC and no SPI some with just EMMC, and some with both. For the less casual and more pedantic readers: YES I know it's more complex than this!
 
Hi

I have the device in order to test it with the OpenMediaVault image from FriendlyElec... but I have a lot of problems installing some of the plugins :(


View attachment 55093

For example, the problem appeared trying to install wireguard and the OpenMediaVault downloader plugin.

The last lines of the error log are:

Updating workbench configuration files ...
Restarting engine daemon ...
Processing triggers for initramfs-tools (0.140) ...
update-initramfs: Generating /boot/initrd.img-6.1.0-0.deb11.13-rt-arm64
W: mkconf: MD subsystem is not loaded, thus I cannot scan for arrays.
W: mdadm: failed to auto-generate temporary mdadm.conf file.
raspi-firmware: missing /boot/firmware, did you forget to mount it?

run-parts: /etc/initramfs/post-update.d//z50-raspi-firmware exited with return code 1
dpkg: error processing package initramfs-tools (--configure):

installed initramfs-tools package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:

linux-image-6.1.0-0.deb11.13-rt-arm64
linux-image-rt-arm64
wireguard
openmediavault-wireguard
initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1) in /usr/share/openmediavault/engined/rpc/pluginmgmt.inc:250


and the full log file is attached :(


HELP, please and thank you in advance
I’ve just installed all the plugins… except WireGuard one without any problems 😝
 
Similar threads
Thread starter Title Forum Replies Date
H Commercial or DIY NAS General NAS Discussion 22

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top