GUI: "Disconnected", but I'm online

Nitec0re

New Around Here
I recently updated to 386.4 and since then, the GUI shows "Internet status: Disconnected" - and the status LED is red. I cant say which version i had before, but there was no issue.

1642800782046.png


I found out, that this issue is related to the dns.msftncsi.com request. PiHole block almost any connections to Microsoft, including dns.msftncsi.com. Is dns.msftncsi.com on the whitelist, the GUI shows me my public IP, and the status LED on the router is white.

ASUS_gui.JPG


Does the router check the connection on dns.msftncsi.com? srsly? Is there a workaround?

Thank you in advance :)
 

dave14305

Part of the Furniture
But is this "problem" new?
It’s mentioned in post #2 of the release thread.
 

Dimmie

Occasional Visitor
Post #2 of that release thread does NOT solve the problem.

To get rid of the problem:

Go to administration > system
At 'Network Monitoring' enable 'dns query'
Set 'Resolve Hostname' to 1.1.1.1
Set 'Resolved IP Addresses' to 1.1.1.1
Click 'Apply' on the bottom of the screen
At 'Network Monitoring' disable 'dns query'
Click 'Apply' on the bottom of the screen
Tick 'reboot' on top of the screen

Strange but true... Just enable 'dns query' and disable it again exactly like the above steps.. and the problem is gone... which is strange because according to GUI settings, all settings are turned back as they were before when you disable the dns query option...
 

ColinTaylor

Part of the Furniture
Post #2 of that release thread does NOT solve the problem.

To get rid of the problem:

Go to administration > system
At 'Network Monitoring' enable 'dns query'
Set 'Resolve Hostname' to 1.1.1.1
Set 'Resolved IP Addresses' to 1.1.1.1
Click 'Apply' on the bottom of the screen
At 'Network Monitoring' disable 'dns query'
Click 'Apply' on the bottom of the screen
Tick 'reboot' on top of the screen

Strange but true... Just enable 'dns query' and disable it again exactly like the above steps.. and the problem is gone... which is strange because according to GUI settings, all settings are turned back as they were before when you disable the dns query option...
As noted in posts 3 and 4 you can use any resolvable domain name provided it returns a match for the IP address.
 

Dimmie

Occasional Visitor
As noted in posts 3 and 4 you can use any resolvable domain name provided it returns a match for the IP address.
Yes but it is strange that when you revert it back (disable the manually set dns query) it still works fine. You should expect that when you disable the dns query, the problem should be back.
 

ColinTaylor

Part of the Furniture
Yes but it is strange that when you revert it back (disable the manually set dns query) it still works fine. You should expect that when you disable the dns query, the problem should be back.
This is the change is behaviour that has been discussed at length. Essentially, that option is always active now. I think Asus should remove the check boxes for DNS Query and Ping as they are redundant now.
 

alekos

Occasional Visitor
Post #2 of that release thread does NOT solve the problem.

To get rid of the problem:

Go to administration > system
At 'Network Monitoring' enable 'dns query'
Set 'Resolve Hostname' to 1.1.1.1
Set 'Resolved IP Addresses' to 1.1.1.1
Click 'Apply' on the bottom of the screen
At 'Network Monitoring' disable 'dns query'
Click 'Apply' on the bottom of the screen
Tick 'reboot' on top of the screen

Strange but true... Just enable 'dns query' and disable it again exactly like the above steps.. and the problem is gone... which is strange because according to GUI settings, all settings are turned back as they were before when you disable the dns query option...
Can confirm this does work (AC86). Hopefully it stays working.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top