1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Having trouble with Asus RT-AC66U and RT-AC68U media bridge

Discussion in 'ASUS AC Routers & Adapters' started by grimripper, Oct 18, 2019.

  1. grimripper

    grimripper New Around Here

    Joined:
    Oct 12, 2019
    Messages:
    3
    Hi

    I recently bought an Asus RT-AC68U to take over router duties from a crappy cable modem provided by my ISP. Since some reorganizations in the summer, I've had my main computer connected with my old Asus RT-AC66U as a media bridge. I also got the cable modem at about the same time, and previously had an older cable modem in bridge mode, with the 66U as a roter, and a long inconveniently placed cable instead of a media bridge.

    So there's been a lot of problems. For one thing, when I tried to set the 68U up as a router, I discovered that the 66U in media bridge mode didn't find the 68U's 5GHz WLAN at all, even though my mobile phone shows it with good scores right next to the 66U, and while the 66U has been in media bridge mode it's been using the cable modem's 5GHz WLAN. The 66U also wouldn't connect to the 5GHz WLAN when I gave it the SSID manually. It did connect to the 68U's 2.4GHz WLAN, but then my NFS drive shares didn't work at all.

    I then switched the 68U to media bridge mode and the 66U to router mode. Again, the 68U didn't find the 66U's 5GHz WLAN, but at least connected to it when given the SSID manually. My drive shares also worked. The 68U had a 2.4Ghz/5GHz option in the manual WLAN connection setup, while I think the 66U didn't.

    I did a bunch of factory resets, changed SSIDs, tried some different security settings etc. I also tried the 66U in repeater mode since I've seen it recommended over the media bridge mode, but it had the same problem. (I've got pretty good WLAN measurements everywhere in my apartment and would rather not have extra WLANs anyway).

    So I'm curious, why do these devices fail to find each other's 5GHz WLANs? I specifically bought another Asus thinking they'd work better together than devices from different manufacturers.

    Also, I'm wondering if some of the problems I've been having since switching from the old cable modem as bridge + 66U as wireless router + long cable setup to the new cable modem as wireless router + 66U as media bridge one might be related to the 66U. I read that it's pretty bad as a media bridge.

    The problems I think might've been caused by the 66U media bridge:
    • occasionally no Internet connection on my main computer, resetting the 66U helped
    • NFS drive shares would often be extremely slow, but after some tries and possibly restarting autofs, sharing would work well enough to play video files
    • occasionally the whole computer connecting to the shared drives would occasionally slow to a crawl, and needed to be rebooted (after starting it up and trying to open the shared drives)
    • sometimes requests to one particular website hanging, even if a new tab, window or a different browser was opened, while connections otherwise worked fine (websites that I've used a lot and had barely any such problems with ever)
    • websites suddenly being reloaded for no apparent reason (notably the 66U's web UI)
    The problems I think were caused by the cable modem but the 66U could possible have affected:
    • Internet connections freezing for some tens of seconds every few minutes on three different computers using 2,4GHz WLAN, 5GHz WLAN and the media bridge connected to the 5GHz WLAN (this seems to have been fixed by disabling automatic channel selection)
    • WLANs suddenly disappearing altogether
    • mobile phone not being able to connect to a WLAN (it's a piece of crap but this hasn't happened with other WLANs)
    • computers not receiving any DNS after connecting to the cable modem
    • assigned static IPs not being set correctly after connecting to the cable modem
    • supposedly connected, but no access to the Internet or other devices in the LAN
    • cable modem web UI freezing, not opening or showing only an error message
    Most of the above were fixed by restarting the cable modem and I don't really think the 66U had anything to do with any of that.

    My current setup with the cable modem in bridge mode, the 66U as wireless router and the 68U in media bridge mode has worked well since I set it up a few days ago now. This seems to be a bit backwards though, so finally, I'm wondering if there's any point to even try and use the 66U as a media bridge instead of the 68U? Intuitively I'd like to have the better device as the router and I'd think that'd be the 68U.
     
  2. Grisu

    Grisu Part of the Furniture

    Joined:
    Aug 28, 2014
    Messages:
    2,690
    Use ch. 36 for your 68U and try connect with 66U in bridge mode.
    Turn off modem 5G or use different channel.
    Maybe your 68U supports different channels and auto uses an unkown to 66U.
     
  3. Val D.

    Val D. Very Senior Member

    Joined:
    Jun 16, 2019
    Messages:
    793
    Location:
    Great White North
    Media Bridge works best on RT-AC66U routers with Asuswrt-Merlin 380.66 firmware. See my signature. My media bridge currently has 24 days uptime just because I had to unplug it few weeks ago. It stays connected forever and never drops the link, but only with this specific firmware version. Flash it clean, reset the router, don't play with settings too much and it just works.
     
    L&LD and Grisu like this.
  4. grimripper

    grimripper New Around Here

    Joined:
    Oct 12, 2019
    Messages:
    3
    I tried changing the channels on the 66U. It had four channels for 5GHz: 36, 40, 44 and 48. The first time I tried with 44, the 5GHz WLAN wasn't found. Then I selected manual setting, and the router somehow returned to the main page with 5GHz connected. Then I tried again, and the WLAN was found.

    I had three occasions where the link for "automatic IP" after selecting the WLAN didn't do anything do I reopened the main page and tried searching again. Including four channels, the thing with channel 44 and manual setting, these retries and restoring the WLAN to automatic channel, I tried nine times altogether.

    The 5GHz was found eight times out of nine, but the 2.4GHz WLAN whose settings I didn't change was found only six times. Seems just random.

    For the past couple of weeks, I haven't had any of the issues I thought were caused by the cable modem (which has been in bridge mode with WLANs turned off). Some of the other issues persist though.

    The drive shares freezing hasn't changed in any noticeable way except that I haven't seen the whole computer affected. Some websites still reload suddenly, but only two of them. Internet connection through the 68U media bridge has been breaking up and reconnecting on a few occasions. Connection was completely lost once, and I had to reboot the 68U. An improvement over the 66U doing this every couple of days instead of weeks but I'd still rather my media bridge just stayed up.

    When the 68U failed, it had been logging a LOT of this:
    Code:
    Oct 29 21:34:23 kernel: dpsta_register: null dpsta_ifnames!
    Oct 29 21:34:23 kernel: dpsta_register: null dpsta_ifnames!
    Oct 29 21:34:27 rc_service: psta_monitor 19680:notify_rc restart_wlcmode 0
    Oct 29 21:34:28 rc_service: psta_monitor 19680:notify_rc restart_wireless
    Right up to the time when I restarted it. There's 1551 lines of this, over about 1h 11min, but the log cuts off so there was probably more.

    Anyway, I'm thinking I'll try and flash the 66U, even though I'll probably end up bricking it like such things usually tend to work for me. I found these downloads for 66U:

    https://sourceforge.net/projects/asuswrt-merlin/files/RT-AC66U/Release/

    Should I get the 66 version @val-d recommended even though there are newer ones for the 66U? If the 66 version, then 66_0, 66_2, 66_4 or 66_6? I currently have version 3.0.0.4.382_51640 of Asus' firmware on the 66U.
     
    Last edited: Nov 5, 2019
  5. Val D.

    Val D. Very Senior Member

    Joined:
    Jun 16, 2019
    Messages:
    793
    Location:
    Great White North
    Asuswrt-Merlin 380.66_0 is the version running on my Media Bridge. Newer or older it doesn't matter, it's a Media Bridge, you just need it to work. Note the Uptime on the image attached below. It is connected to my RT-AC86U, 80MHz channel, link speed is full 1300Mbps most of the time. RT-AC1750 is just another name of RT-AC66U.

    Untitled.png
     
    indark likes this.
  6. grimripper

    grimripper New Around Here

    Joined:
    Oct 12, 2019
    Messages:
    3
    My setup's been running without major issues for some time now. Just web pages suddenly reloading and shared directories freezing. I thought I'd try switching the 66U to Merlin firmware anyway, and today I finally got around to it.

    The firmware change went without a hitch, as did reconfiguring the 68U to router mode. Then the 66U didn't find the 68U's WLAN again, and configuring it manually lead to a state where I couldn't connect to the 66U until I factory resetted it.

    I switched the channel from Auto (100 had been selected, oddly enough, since it was the only channel above 44 that had another WLAN overlapping) to 40, and then the 66U connected to it. Looking at my previous post, it seems the 66U might only be able to connect on channels 36, 40, 44 and 48 since it doesn't allow others for its own WLANs.

    After the factory reset, the 66U started with a "wizard" configuration, which repeatedly went either back to its initial screen where credentials are set or the login screen which required factory default credentials instead of the ones I had set in the wizard. After many of these, I got a different screen for setting credentials, and then got past this and to the 66U's main screen.

    Having successfully switched the 66U to Media Bridge mode and connected it to a WLAN, I had an issue with the 68U trying to connect to it via the 66U. The 68U would repeatedly go directly to a screen saying I had input incorrect credentials five times and had two wait for five minutes... without any input at all. I had to power cycle the 68U before I was able to log in, and then it had lost all my DHCP configurations, and when I started setting them up again, it wouldn't work and the page reloaded apparently without CSS files. A few refreshes later the UI went back to normal and the formerly vanished DHCP settings reappeared.

    Now I've got at least all the most common stuff up and running so I'll just wait and see how things go.