What's new

YazFi hostname and ip address UNKNOWN for all guest network devices

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

thank god ... I have the exact same issues just recently. at beginning only 1 device, after multiple reboot it expands to more devices using YazFi (all works before flawless).
I'll try dev version.
 
Nah...doesn't work with 4.4.4 dev version

My main LAN use 192.168.0.xxx subnet, and YazFi uses 192.168.30.xxx .
Still have issues. :-(
 
Nah...doesn't work with 4.4.4 dev version

My main LAN use 192.168.0.xxx subnet, and YazFi uses 192.168.30.xxx .
Still have issues. :-(
It looks like you may have a separate scenario, similar symptoms but different root cause, from the OP's problem. If you want to have a chance to get the issue looked at & perhaps resolved, you’ll need to provide more detailed information, along with clear screenshots, to show more context about your specific problem.

I suggest you read the following posts on this same thread and follow the instructions to supply the files & additional data points requested, as the OP did.



This coming weekend I should have some free time to take a look & review the info. The more relevant data you provide (e.g. dnsmasq.conf.add? dnsmasq.postconf? AiMesh setup? Screen captures?) the better. "A (clear) picture is worth a thousand words" is more than just a cliché.
 
Thank you M. for offering help. It's bit of strange right now that 1 device still works but other devices display as "unknown". So like you said, it's not the same issue as OP's (but similar).
Also what drive me crazy is they used to work correctly and I haven't touch anything of the router/settings for long long time (over 9 months), then all of sudden this "unknown" appeared.
I will find more time to read all the threads/detail.
 
Hello all.

I have started to have this same issue since yesterday.

My USB stick died, where the custom scripts and Skynet had their files. I tried cloning it, to no avail. Had to use a fresh USB stick, and re-install amtm.

After I re-deployed amtm, entware, Skynet, conmon, YazFi, my guest SSID network no longer has my IOT stuff connected to it.

Overall subnet: 192.168.1.0 /23
DHCP is set from 192.168.1.192 to .254

Guest Network has 'Intranet Access' enabled (Both now and originally before the issue occured).

YazFi 2.4 Ghz IP addr is set to 192.168.2.0 with DHCP start at .2 and end at .254

YazFi 5Ghz is disabled. Debug Log attached.

Any hints or tips appreciated - thanks!

1699376348931.png
 

Attachments

  • YazFi_DEBUG_Info.txt
    3.3 KB · Views: 11
Did you change any Wifi or YazFi settings, or SSID names, when resetting up YazFi?

Looks like your IoT devices may have rolled back to connecting to the main WiFi network. Something that will happen if the devices save previously connected WiFi network connections. You may want to check the IoT device itself and reconnect it to the YazFi Guest network.

Note that YazFI generally is not saved to the USB storage device. Rather it's files are stored in the JFFS directory on the router itself.
 
Did you change any Wifi or YazFi settings, or SSID names, when resetting up YazFi?

Looks like your IoT devices may have rolled back to connecting to the main WiFi network. Something that will happen if the devices save previously connected WiFi network connections. You may want to check the IoT device itself and reconnect it to the YazFi Guest network.

Note that YazFI generally is not saved to the USB storage device. Rather it's files are stored in the JFFS directory on the router itself.
No, I haven't changed any wifi / yazfi config or ssid names, except I had to re-deploy yazfi via amtm. It found its previous configuration, as all settings were unchanged when I checked the webui asp page for yazfi.

Main and Guest (yazfi) SSIDs are vastly different. The IOT devices have never connected to main SSID, although I did notice that's where they attempt to connect after I had finished up setting up amtm / yazfi on a new usb device.

To me it looks like a dhcp confusion in the router. As the devices do not have the main ssid information saved on them, I suspect connection is attempted, but at IP issue stage something goes wrong with the router trying to issue it a lease from the main 192.168.1.x pool, while yazfi is set to 192.168.2.x

Appreciate the answer and further consideration of the topic
 
Hello all.

I have started to have this same issue since yesterday.

My USB stick died, where the custom scripts and Skynet had their files. I tried cloning it, to no avail. Had to use a fresh USB stick, and re-install amtm.

After I re-deployed amtm, entware, Skynet, conmon, YazFi, my guest SSID network no longer has my IOT stuff connected to it.

Overall subnet: 192.168.1.0 /23
DHCP is set from 192.168.1.192 to .254

Guest Network has 'Intranet Access' enabled (Both now and originally before the issue occured).

YazFi 2.4 Ghz IP addr is set to 192.168.2.0 with DHCP start at .2 and end at .254

YazFi 5Ghz is disabled. Debug Log attached.

Any hints or tips appreciated - thanks!
You provided only partial debug information for review so there's some missing troubleshooting info. Based on what was there, the ARP cache confirms that no network clients are connected to the "wl0.1" interface (YazFi 2.4GHz Guest Net #1, 192.168.2.0/24), and all existing clients are in the Main LAN (192.168.1.0/??). This is then reaffirmed by the dnsmasq lease table, where all IP address leases are from the "192.168.1.0" subnet. You can even see the devices meant to be on the YazFi Guest Network with "192.168.1.XY" leases (e.g. ESP_0983FA, ESP_8F997E, ESP_F72E10), so YazFi is correctly reporting that those clients are "Not in Guest Net."

Something definitely has gone wrong with the YazFi Guest Net, perhaps when you plugged in the new USB drive and reinstalled the add-ons. I assume that you rebooted the router at some point after reinstalling & setting up everything you had before. Without further data, it's impossible to tell what or where the problem is.

Take a look at post #23 on this same thread where there are 2 links to posts with instructions for gathering more debug/troubleshooting data which could provide further clues and context.
 
  • Like
Reactions: Osy
You provided only partial debug information for review so there's some missing troubleshooting info. Based on what was there, the ARP cache confirms that no network clients are connected to the "wl0.1" interface (YazFi 2.4GHz Guest Net #1, 192.168.2.0/24), and all existing clients are in the Main LAN (192.168.1.0/??). This is then reaffirmed by the dnsmasq lease table, where all IP address leases are from the "192.168.1.0" subnet. You can even see the devices meant to be on the YazFi Guest Network with "192.168.1.XY" leases (e.g. ESP_0983FA, ESP_8F997E, ESP_F72E10), so YazFi is correctly reporting that those clients are "Not in Guest Net."

Something definitely has gone wrong with the YazFi Guest Net, perhaps when you plugged in the new USB drive and reinstalled the add-ons. I assume that you rebooted the router at some point after reinstalling & setting up everything you had before. Without further data, it's impossible to tell what or where the problem is.

Take a look at post #23 on this same thread where there are 2 links to posts with instructions for gathering more debug/troubleshooting data which could provide further clues and context.

Many thanks for the time taken - I have however ended up resetting to factory defaults and rebuilding from scratch, as the wife was doing my nuts in.

After clean deployment, seems IOT clients are correctly connecting to the YazFi guest network. I'm on 4.4.3, haven't deployed 4.4.4, wanted to keep things as vanilla as possible for now.
 
What IP address range have you configured in YazFi? If you don't assign the YazFi clients an IP address from the YazFi assigned IP address range they likely won't have their names properly listed in the YazFi interface.

Note that using 192.168.101.x and 192.168.102.x may potentially cause problems since Asus firmware itself uses those IP address range(s) for Guest WiFi. If possible try using other IP address range in YazFi. For example 192.168.5.x, 192.168.6.x and so on.

There is an alternate way to manually assign IP address to YazFi clients which works. See the following links for more information:
https://github.com/jackyaz/YazFi/wi...verse-DNS-records#a-note-on-dhcp-reservations
https://www.snbforums.com/threads/y...inc-ssid-vpn-client.45924/page-32#post-473403
Well, sure enough, for different reasons, I changed the subnet for my YazFi guest network to 192.168.2.0 and I have names and ip addresses of guest network devices shown in the table now. I apparently noticed your second paragraph so much that I missed the significance of the first paragraph. Thanks!
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top