Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

I just want it to work: USB Hard Drive and Printer

Discussion in 'ASUS N Routers & Adapters' started by GreenHorn, Feb 21, 2013.

  1. GreenHorn

    GreenHorn New Around Here

    Feb 21, 2013
    Hello folks. I just bought this router and was all excited...I'm sure you know the feeling. :D

    I'm glad you guys are here.

    I connected my USB hard drive to the router. In the router admin page it shows the drive is mounted and I can see all the folders.

    How the heck am I supposed to access the drive from my computer? I have tried to map network drive, looked in my network locations...I'm lost.

    I have read every single thread in this forum about hard drives and this router and can't find the answer!

    Same thing with the printer. I have LDR turned on. I created a new port. I uninstalled and re-installed the driver. I rebooted my computer. I used the ASUS .exe program to try and make the connection...nothing!

    Can anyone tell me how to make this work? I need it sooooo bad! :eek:
  2. linkmaster

    linkmaster Regular Contributor

    Feb 15, 2013
    I just added a set of drives to my router too...

    Just making sure ,you went into the media server option after you clicked the drive in the connected device list and ensured that Enable Share was clicked under 'Network Share(Samba) / Cloud Disk. ?

    Check that the tickboxes under r/w are set , don't bother with share with account as it sounds that currently you don't need to limit access based on login right now.

    If that's all done then this is the solution.

    There is a limitation using Map network Drive that I found under windows , you CANNOT map the drive itself as a network drive , what I had to do was make a named folder (I used the drive letter I was mapping it to) and put all your files in there.

    You can then use 'map network drive' under explorer and add that folder onto your system as a drive letter from the listed network locations.

    As for the printer , I'm afraid I've been trying to get a printer to work properly with this router since I bought it...I did manage to get it initially connected using printer.exe downloadable from the asus servers through the routers UI.

    But it won't stay connected for any long period of time.

    But here's the method..maybe you will have better luck.

    Connect your Printer , make sure it's turned on, check it's shown under the routers connected devices icons.

    Run the printer.exe , if it doesn't find a device with a printer attached...you need to exit the install and reboot the router using the power off/on method , then try again with printer.exe.

    If all is well , your system will install drivers for the printer...do not exit the printer net->USB driver install program until windows has finished the driver install.

    I hope this helps.
    Last edited: Feb 22, 2013
  3. GreenHorn

    GreenHorn New Around Here

    Feb 21, 2013
    Thank you so much for the detailed answer but I am struggling to make it work.

    I'll break my steps down - maybe you can see where I go wrong.

    Hard Drive:

    1. Drive is connected. I see it in the network map tab of the router.
    2. I click the drives icon, and then the "Media Server" button on the right side of the screen.
    3. I go to the Network Place(Samba) Share / Cloud Disk Tab
    4. I see the Seagate FreeAgent drive listed. I can click the + and it shows all the folders of the drive.
    5. I created a Z folder because that is the drive letter I will want to map to.
    6. I click the Enable Share button. It appears to have worked.
    7. Every folder in the drive is listed as R/W.
    8. I go back to Computer and click Map Network Drive.
    9. I click browse and see RT-N66U listed but when I try to select it, a window pops up that says "Cannot access \\RT-N66U there must be a problem with your network"
    10. If I type "\\RT-N66U\Z" into the folder line manually, I get the same error.
    11. I can see RT-N66U listed under the Network section in Computer when using Windows Explorer...but cannot connect to it. Same error.

    Edit: When I rebooted the router...a window popped up saying USB storage is ready and it installed print drivers. Hallelujah!

    But now...I don't even see RT-N66U in my network device list. I still can't use it. The printer printed one page, then stopped.

    I simply don't understand how ASUS can sell me $170 equipment which has features that don't work??? I think I may return it.

    Why is this router praised so highly when it doesn't do what it says it will do? I could have spent $80 on a decent router to access the internet if I knew the USB ports don't work.

Share This Page