What's new

IPTV - VPN via Router does not work, App does

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Regular Contributor

A bit vague this one, but I have a GT AX6000 running 388.5 release on a 900/100 connection. I have an IPTV which I have discovered that sometimes the 4K channels do not work, if I switch off Wi-Fi and go onto Mobile Data (5G), the streams load within 1 second and are flawless.

I have tried OpenVPN on the router and also WireGuard via TorGuard, neither work. However, If I use the iOS app for TorGuard, it works perfectly even on WiFi. I run a Synology with Adguard Home so my DNS points to that (unsure if this would make a difference), I am just not sure why when it connect via VPN directly on the phone it works, however when on the router it does not work. Any ideas?
Most channels work yes, but the 4K ones, It does not work without a VPN no

Worth noting that when I go onto the Apple TV and do a speedtest, I get around 450mbps and the IP reflects the VPN.

EDIT: I have tried setting DNS to the router and to CloudFlare to no avail.

EDIT 1: I have installed 'VPN Client Bee' on my Apple TV and imported my WireGuard config, and it works flawlessly direct on the device too, with the added benefit of I can use the full 900mbps bandwidth. However, it would still be interesting to find out why it does not work when it's on the router.
Last edited:

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!