NAT loopback only works when NAT acceleration is disabled

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

m33ts4k0z

Regular Contributor
Hello,

I'm on a 250/250Mbps connection and I run some servers through my AC88U router. Some firmware versions ago (Like summer 2019), the NAT loopback was working fine but now, on 384.13, it seems broken. I can no longer connect to my server using a direct WAN IP connection from within the LAN except when I disable the NAT acceleration. Then everything works fine but to my understanding, its recommended to leave that option on Auto since my speed is quite fast.

Any suggestions, workarounds or alternatives?

Thanks
 

QMax

Regular Contributor
RT AC66U_B1 here, with same firmware version. Today I spent 2 hours to enable NAT hw acceleration (CTF only) cause without it the max wan speed was only 250 Mbps.
With CTF enabled, speed jumps up to 950 Mbps.
It seems I haven't any problems connecting from within my LAN to my http server and transmission torrent running on the router (entware-ng), both using LAN IP address or DDNS hostname.

Inviato dal mio Z2 utilizzando Tapatalk
 

m33ts4k0z

Regular Contributor
RT AC66U_B1 here, with same firmware version. Today I spent 2 hours to enable NAT hw acceleration (CTF only) cause without it the max wan speed was only 250 Mbps.
With CTF enabled, speed jumps up to 950 Mbps.
It seems I haven't any problems connecting from within my LAN to my http server and transmission torrent running on the router (entware-ng), both using LAN IP address or DDNS hostname.

Inviato dal mio Z2 utilizzando Tapatalk
Hello,

thanks for the answer. I have no problem connecting with LAN IP or DDNS either. The problem is only with my WAN IP.
 

oso2276

Regular Contributor
I can no longer connect to my server using a direct WAN IP connection from within the LAN except when I disable the NAT acceleration. Then everything works fine but to my understanding, its recommended to leave that option on Auto since my speed is quite fast.

Any suggestions, workarounds or alternatives?
Could it be related to this change?
Code:
384.12 (22-June-2019)

- CHANGED: The router will now use ISP-provided resolvers instead of local dnsmasq when attempting to resolve addresses, for improved reliability. This reproduces how stock firmware behaves. This only affects name resolution done by the router itself, not by the LAN clients. The behaviour can still be changed on the Tools -> Other Settings page.
Try re-enablig the option

Enviado desde mi moto g(8) plus mediante Tapatalk
 

m33ts4k0z

Regular Contributor
Could it be related to this change?
Code:
384.12 (22-June-2019)

- CHANGED: The router will now use ISP-provided resolvers instead of local dnsmasq when attempting to resolve addresses, for improved reliability. This reproduces how stock firmware behaves. This only affects name resolution done by the router itself, not by the LAN clients. The behaviour can still be changed on the Tools -> Other Settings page.
Try re-enablig the option

Enviado desde mi moto g(8) plus mediante Tapatalk
Unfortunately, this is not related to name resolution since even typing the IP directly doesn't work.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top