Native IPv6 - no LAN IP's populating

Gary_Dexter

Regular Contributor
GT-AC900 running Merlin 386.5_2.

Choosing Native IPv6 yields no LAN IP's, and IPv6 tests fail (not surprisingly).

1653574177986.png


However if I use Passthrough, I get IPv6 connectivity, albeit /0 addresses/prefixes on the status page, and the connection type shows as Disabled, but IPv6 tests pass and show working connectivity.
The Gateway and Link-Local Addresses are also fe80 addresses.

1653574277699.png


I don't understand how Passthrough works over Native, since I am not connecting to a modem/bridge but into a wall-mounted ONT directly via Ethernet.

I am on a PPPoE connection in the UK on Giganet ISP on CityFibre infrastructure.
 

5stringdeath

Regular Contributor
I randomly read this post and looked at my RT-AC3100 setup page ... and mines no longer working either. I have FiOS and have had native IPV6 for some time. Also on 386.5_2

I have no idea how long its not been working :)
 

dave14305

Part of the Furniture
So use Static instead of Native in the router.
 

dave14305

Part of the Furniture
Not sure, but try the gateway in your first post.
 

Gary_Dexter

Regular Contributor
That's an fe80 link local address, yes?

Surely that should be part of the allocated /64 WAN address?
 

dave14305

Part of the Furniture
That's an fe80 link local address, yes?

Surely that should be part of the allocated /64 WAN address?
Depends what the LLA belongs to. With my ISP, it’s the LLA of their gateway/router, not any of my equipment.

Or go back to Native and manually set the LAN prefix by disabling DHCP-PD.
 

Gary_Dexter

Regular Contributor
Depends what the LLA belongs to. With my ISP, it’s the LLA of their gateway/router, not any of my equipment.

Or go back to Native and manually set the LAN prefix by disabling DHCP-PD.

Using Native an entering the LAN details automatically does not work either - IPv6 addresses get issued to clients fine, however IPv6 tests online fail.



1653652745209.png


1653652806022.png
 

heysoundude

Part of the Furniture
Screenshots below.

I looked at that page as I was directed there by their support team, but because I am using my own router they are not prepared to help - typicHmmm...Static IPv6 from the ISP's ONT...what happens if you switch the interface from PPP to ethernet on the IPv6 config page?
That page I linked to mentions PAP as the PPPoE encryption....shouldn't hurt to make the change from Auto on the WAN config page
It also quite specifically details:
1653656839884.png

so it seems you may need to dig into the Asus Docu/help for how to apply it
 

Gary_Dexter

Regular Contributor
That page I linked to mentions PAP as the PPPoE encryption....shouldn't hurt to make the change from Auto on the WAN config page
It also quite specifically details:
View attachment 41440
so it seems you may need to dig into the Asus Docu/help for how to apply it
Interestingly PAP does not work (get no connection), but CHAP does. As does Auto.

VLAN ID is also set in the Router:

1653660462290.png
 

heysoundude

Part of the Furniture
Interestingly PAP does not work (get no connection), but CHAP does. As does Auto.

VLAN ID is also set in the Router:
I'd be a friendly customer and advise the ISP their webpage may be giving false information about PPPoE encryption ;)
IF that gets you a call from them, you MAY get the right person to speak to about working out the VLAN setup and IPv6 LAN.
and if that happens, mayhaps you'll be kind enough to ask Merlin to add your ISP Profile to the list in that pulldown?
 

heysoundude

Part of the Furniture
Using Native an entering the LAN details automatically does not work either - IPv6 addresses get issued to clients fine, however IPv6 tests online fail.



View attachment 41437

View attachment 41438
the client and/or browser you're on isn't configured for IPv6 - that website tests between the client (check the IPv4 addy) and their server.
have you taken ipv6.he.net/certification ? a level or two should take an hour or less and get you in the zone here (and you can add the certificate to your LinkedIn page lol)
 

5stringdeath

Regular Contributor
the client and/or browser you're on isn't configured for IPv6 - that website tests between the client (check the IPv4 addy) and their server.
have you taken ipv6.he.net/certification ? a level or two should take an hour or less and get you in the zone here (and you can add the certificate to your LinkedIn page lol)
This has nothing to do with a browser. If the router isn't getting IPV6 information and distributing addresses across the LAN, how *would* a browser / device test anything except IPV4

"get in the zone"
 

Gary_Dexter

Regular Contributor
the client and/or browser you're on isn't configured for IPv6 - that website tests between the client (check the IPv4 addy) and their server.
have you taken ipv6.he.net/certification ? a level or two should take an hour or less and get you in the zone here (and you can add the certificate to your LinkedIn page lol)
lol have you taken it?
The client and browser both support IPv6 as shown by the fact that it works in passthrough mode.

The question at hand here is why it works in passthrough only since there’s no modem between the router and ONT.
 

Gary_Dexter

Regular Contributor
So Giganet replied to me again with the following:

Having spoken with our network team, they advise you run IPv6 in native mode on your router in order to obtain an IPv6 address.
The reasoning behind this is that there is an IPv6 address attached to your account which is fetched automatically when connecting to our RADIUS servers.
This address does not change and therefore there is no need to set a static IPv6 address on your router.


But I've advised them it's not working - awaiting their response again.
 

L&LD

Part of the Furniture
Did you reboot the router after setting it to Native IPv6 mode?

Did you fully power down the router and the ISP's equipment for a few minutes before powering everything up again?
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top