NO Internet?

JT Strickland

Very Senior Member
Some of my clients have internet but most don't. I have a 1G up & down fiber line that checks OK. I rebooted my router, and it still hasn't synced with NTP time server. I lost all my scripts. Second reboot, same thing.
Any suggestions?
 

L&LD

Part of the Furniture
Unplug the power from the router. Remove all USB devices. Wait a couple of minutes. Power it up.
 

ColinTaylor

Part of the Furniture
Disable "JFFS custom scripts and configs" in the GUI (Administration - System) and reboot. Then start to diagnose the problem. The first thing I would check is that the USB drive isn't corrupted and is mounting OK.
 

JT Strickland

Very Senior Member
Unplug the power from the router. Remove all USB devices. Wait a couple of minutes. Power it up.
Done. No change yet. Not looking good. Still hasn't synced time.
 

ColinTaylor

Part of the Furniture
Done. No change yet. Not looking good. Still hasn't synced time.
Check your WAN DNS settings are pointing to your ISP's servers or some other public servers, not any internal servers.
 

JT Strickland

Very Senior Member
Disable "JFFS custom scripts and configs" in the GUI (Administration - System) and reboot. Then start to diagnose the problem. The first thing I would check is that the USB drive isn't corrupted and is mounting OK.
Done. Usb seems OK, mounted ok. Scan doesn't show anything. Still some clients have no interenet, time hasn't synced. A lot of "*kernel:dropped*" in the log.
 

JT Strickland

Very Senior Member
Check your WAN DNS settings are pointing to your ISP's servers or some other public servers, not any internal servers.
says "DNS Server: 9.9.9.11, 149.112.112.112"
 

ColinTaylor

Part of the Furniture
A lot of "*kernel:dropped*" in the log.
Probably normal because you had Skynet installed which I think enables logging of dropped packets.

says "DNS Server: 9.9.9.11, 149.112.112.112"
That should be OK. What have you got set as the router's primary and secondary NTP Servers?

How about doing this from the router's command line:
Code:
date
service restart_ntpd
sleep 10; date

EDIT: Is it simply that your ISP connection is down? Check that your router has a working internet connection (does it say Disconnected on the Network Map?). Can the router ping 8.8.8.8? You said some clients still work - are these mobile devices that are failing over to an LTE connection perhaps?
 
Last edited:

JT Strickland

Very Senior Member
Probably normal because you had Skynet installed which I think enables logging of dropped packets.


That should be OK. What have you got set as the router's primary and secondary NTP Servers?

How about doing this from the router's command line:
Code:
date
service restart_ntpd
sleep 10; date

EDIT: Is it simply that your ISP connection is down? Check that your router has a working internet connection (does it say Disconnected on the Network Map?). Can the router ping 8.8.8.8? You said some clients still work - are these mobile devices that are failing over to an LTE connection perhaps?
pool.ntp.org, no secondary set

Code returned May 5 01:26:25 CTD 2018

It says Connected. ISP connection appears good, they say it is. ping was good, till I broke it at 34 packets.
 

JT Strickland

Very Senior Member
Is anything left but a factory reset? I need to take some screenshots.
 

ColinTaylor

Part of the Furniture
I somehow doubt a factory reset will change anything if this was working OK until today.

Try running ntpd from the command line using different servers and see if it succeeds:
Rich (BB code):
# /usr/sbin/ntp -dnqt -p time.google.com -p time.windows.com
ntp: 'time.google.com' is 216.239.35.4
ntp: 'time.windows.com' is 51.145.123.29
ntp: sending query to 51.145.123.29
ntp: sending query to 216.239.35.4
ntp: reply from 51.145.123.29: offset:-55753.128328 delay:0.017101 status:0x1c strat:3 refid:0x00e64219 rootdelay:0.008026 reach:0x01
ntp: reply from 216.239.35.4: offset:-55753.124094 delay:0.024566 status:0x24 strat:1 refid:0x474f4f47 rootdelay:0.000000 reach:0x01
ntp: sending query to 51.145.123.29
ntp: reply from 51.145.123.29: offset:-55753.128411 delay:0.017173 status:0x1c strat:3 refid:0x00e64219 rootdelay:0.008026 reach:0x03
ntp: setting time to 2022-09-01 18:30:52.502441 (offset -55753.128411s)
 
Last edited:

JT Strickland

Very Senior Member
I somehow doubt a factory reset will change anything if this was working OK until today.

Try running ntpd from the command line using different servers and see if it succeeds:
Rich (BB code):
# /usr/sbin/ntp -dnqt -p time.google.com -p time.windows.com
ntp: 'time.google.com' is 216.239.35.4
ntp: 'time.windows.com' is 51.145.123.29
ntp: sending query to 51.145.123.29
ntp: sending query to 216.239.35.4
ntp: reply from 51.145.123.29: offset:-55753.128328 delay:0.017101 status:0x1c strat:3 refid:0x00e64219 rootdelay:0.008026 reach:0x01
ntp: reply from 216.239.35.4: offset:-55753.124094 delay:0.024566 status:0x24 strat:1 refid:0x474f4f47 rootdelay:0.000000 reach:0x01
ntp: sending query to 51.145.123.29
ntp: reply from 51.145.123.29: offset:-55753.128411 delay:0.017173 status:0x1c strat:3 refid:0x00e64219 rootdelay:0.008026 reach:0x03
ntp: setting time to 2022-09-01 18:30:52.502441 (offset -55753.128411s)
It returned "ntp: bad address 'time.google.com' " etc etc etc
 

ColinTaylor

Part of the Furniture
It returned "ntp: bad address 'time.google.com' " etc etc etc
Strange. Sounds like your DNS isn't working.

Try:
Code:
nslookup www.google.com
nslookup www.google.com 8.8.8.8
nslookup www.google.com 9.9.9.11
and
Code:
cat /etc/resolv.conf
cat /tmp/resolv.dnsmasq
 

L&LD

Part of the Furniture
Have you also tried rebooting (don't shut down, then start again, that is not the same thing) the problem clients?
 

JT Strickland

Very Senior Member
Have you also tried rebooting (don't shut down, then start again, that is not the same thing) the problem clients?
yes, several times with some.
 

JT Strickland

Very Senior Member
Strange. Sounds like your DNS isn't working.

Try:
Code:
nslookup www.google.com
nslookup www.google.com 9.9.9.11
and
Code:
cat /etc/resolv.conf
cat /tmp/resolv.dnsmasq
returned:

[email protected]:/tmp/home/root# nslookup www.google.com
Server: 9.9.9.11
Address 1: 9.9.9.11

nslookup: can't resolve 'www.google.com'

[email protected]:/tmp/home/root# nslookup www.google.com 8.8.8.8
Server: 8.8.8.8
Address 1: 8.8.8.8 dns.google

Name: www.google.com
Address 1: 64.233.177.99 yx-in-f99.1e100.net
Address 2: 64.233.177.147 yx-in-f147.1e100.net
Address 3: 64.233.177.105 yx-in-f105.1e100.net
Address 4: 64.233.177.104 yx-in-f104.1e100.net
Address 5: 64.233.177.103 yx-in-f103.1e100.net
Address 6: 64.233.177.106 yx-in-f106.1e100.net
Address 7: 2607:f8b0:4002:81a::2004 atl14s20-in-x04.1e100.net


I lost my prompt after google.com 9.9.9.11
Can't break or exit out of putty
 

ColinTaylor

Part of the Furniture
Can't break or exit out of putty
Just close the program window and open a new one.

So far it's sounding like either a) an intermittent internet problem with your ISP, or b) an inability to reach Quad9's servers.

Try and complete the outstanding commands from my previous post. After that try changing your WAN DNS servers to 8.8.8.8 and 8.8.4.4
 

JT Strickland

Very Senior Member
Just close the program window and open a new one.

So far it's sounding like either a) an intermittent internet problem with your ISP, or b) an inability to reach Quad9's servers.

Try and complete the outstanding commands from my previous post. After that try changing your WAN DNS servers to 8.8.8.8 and 8.8.4.4
returned


ASUSWRT-Merlin RT-AX86U 386.7_2 Sun Jul 24 21:37:08 UTC 2022
[email protected]:/tmp/home/root# cat /etc/resolv.conf
nameserver 9.9.9.11
nameserver 149.112.112.112
nameserver 127.0.1.1
[email protected]:/tmp/home/root# cat /tmp/resolv.dnsmasq
server=127.0.1.1
[email protected]:/tmp/home/root#



That did sync ntp time after setting WAN DNS servers to google
 
Last edited:

ColinTaylor

Part of the Furniture
returned


ASUSWRT-Merlin RT-AX86U 386.7_2 Sun Jul 24 21:37:08 UTC 2022
[email protected]:/tmp/home/root# cat /etc/resolv.conf
nameserver 9.9.9.11
nameserver 149.112.112.112
nameserver 127.0.1.1
[email protected]:/tmp/home/root# cat /tmp/resolv.dnsmasq
server=127.0.1.1
[email protected]:/tmp/home/root#



That did sync ntp time after setting WAN DNS servers to google
Ok, so it looks like a problem with Quad9's servers (or your ISP).

I'm not sure why you've got Stubby's IP address in your resolv file. I guess it's because you've enabled the VPN client in Exclusive mode and have DoT enabled as well?
 

JT Strickland

Very Senior Member
Ok, so it looks like a problem with Quad9's servers (or your ISP).

I'm not sure why you've got Stubby's IP address in your resolv file. I guess it's because you've enabled the VPN client in Exclusive mode and have DoT enabled as well?
I've got DoT enabled, but no VPN clients unless its an unused leftover or something. I had a VPN server. It's still showing the Quad9's as WAN DNS servers. Maybe a reboot will cure that. Still don't have internet for some clients. They are all present on the local network, they just don't have internet. I wonder if I could get by with Quad9's "normal" servers? Maybe they took those out for something.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top