What's new

Solved OpenVPN Error: OpenSSL: error:1416F086:lib(20):func(367):reason(134)

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Regular Contributor
I created an OpenVPN configuration file using pivpn on a raspberry pi. I used this config file with iOS and Windows OpenVPN clients without any issues. When I tried it on my RT-AX86U running Merlin 386.5_2 using it as a VPN client, I kept getting this error message:
Mar 31 11:51:07 ovpn-client1[10571]: OpenSSL: error:1416F086:lib(20):func(367):reason(134)
Mar 31 11:51:07 ovpn-client1[10571]: TLS_ERROR: BIO read tls_read_plaintext error
Mar 31 11:51:07 ovpn-client1[10571]: TLS Error: TLS object -> incoming plaintext read error
Mar 31 11:51:07 ovpn-client1[10571]: TLS Error: TLS handshake failed
Clocks (in different time zones) on server and router were set correctly. After a long trial and error period, I found out that the advanced setting Verify Server Certificate Name (in the GUI) was the culprit. Once I set it to No, it worked.

This is the setting in the config file that wasn't working on the router:
verify-x509-name raspberrypi_[xxx] name

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!