OpenVPN Server RT-AC68U

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

nycelitemaster

Occasional Visitor
Hi All,

I have RT-AC68U and i finished setting up OpenVPN Server. I am able to connect to my VPN Server. The issue is when I am on an external network and I connect to VPN on my phone or any other device, I am able to access the router. However, I am not able to access anything else on the 192.168.1.x network. For example, I can't access any CUPS Server, or 3D Printer running on OctoPrint as they are on 192.168.1.x network and VPN assigns my device with 10.8.x.x IP. I have read multiple posts where it says enable push to Lan option. This option is no longer there. I also enabled the radio button for Static Route Option in LAN> Routes. But nothing working. Below is my configuration. I'd like to continue to use TUN and not looking to switch to TAP. Please assist.

Interface Type: TUN
Protocol: UDP
Server Port: 443
Authorization Mode: TLS
Username/Password Authentication: Yes
Username / Password Auth. Only: No
TLS control channel security: Disable
HMAC Authentication: Default
VPN Subnet / Netmask: 10.8.0.0 255.255.255.0
Advertise DNS to clients: No
Cipher Negotiation: Enable (with fallback)

The exported client ovpn file will require OpenVPN 2.4.0 or newer.
Negotiable ciphers: AES-128
Legacy/fallback cipher: AES-128-CBC
Compression: Disable
Log verbosity: 3
Manage Client-Specific Options: No
 

eibgrad

Very Senior Member
I assume you're using the stock ASUS firmware. If the OpenVPN server GUI has a custom config field, you can always push the local network to the OpenVPN client yourself.

Code:
push "route 192.168.1.0 255.255.255.0"
 

bbunge

Part of the Furniture
Hi All,

I have RT-AC68U and i finished setting up OpenVPN Server. I am able to connect to my VPN Server. The issue is when I am on an external network and I connect to VPN on my phone or any other device, I am able to access the router. However, I am not able to access anything else on the 192.168.1.x network. For example, I can't access any CUPS Server, or 3D Printer running on OctoPrint as they are on 192.168.1.x network and VPN assigns my device with 10.8.x.x IP. I have read multiple posts where it says enable push to Lan option. This option is no longer there. I also enabled the radio button for Static Route Option in LAN> Routes. But nothing working. Below is my configuration. I'd like to continue to use TUN and not looking to switch to TAP. Please assist.

Interface Type: TUN
Protocol: UDP
Server Port: 443
Authorization Mode: TLS
Username/Password Authentication: Yes
Username / Password Auth. Only: No
TLS control channel security: Disable
HMAC Authentication: Default
VPN Subnet / Netmask: 10.8.0.0 255.255.255.0
Advertise DNS to clients: No
Cipher Negotiation: Enable (with fallback)

The exported client ovpn file will require OpenVPN 2.4.0 or newer.
Negotiable ciphers: AES-128
Legacy/fallback cipher: AES-128-CBC
Compression: Disable
Log verbosity: 3
Manage Client-Specific Options: No
Use a different port than 443. You do have a lot to choose from
 

nycelitemaster

Occasional Visitor
Sorry, I forgot to mention, I am using Merlin's firmware. 384.19. I found 386 to be a bit heavy on resources.

443 1194 are default, so I switched to 443 since its widely enabled everywhere.

If you recommend something, happy to hear suggestions.
 

nycelitemaster

Occasional Visitor
@eibgrad - thank you. that worked like Charm! God Bless you! Saved me so much. I was going to go buy Raspberry Pi to create OpenVPN server. I guess I do not need to spend that money anymore.
 

eibgrad

Very Senior Member
I only suggested doing so manually in custom config under the assumption this was stock firmware.

If you're using Merlin, on the OpenVPN Server config page, under VPN Details->General, make sure "Client will use VPN to access" is set to "LAN only" or "Both". Either one will automatically push the local network (192.168.1.0/24) to the OpenVPN client.
 

nycelitemaster

Occasional Visitor
I only suggested doing so manually in custom config under the assumption this was stock firmware.

If you're using Merlin, on the OpenVPN Server config page, under VPN Details->General, make sure "Client will use VPN to access" is set to "LAN only" or "Both". Either one will automatically push the local network (192.168.1.0/24) to the OpenVPN client.
It was set to both. it never worked until your config.

Once you told me to enter that and it worked like champ
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top