Solved opkg / amtm not utilising https

  • ATTENTION! You'll notice a Prefix dropdown when you create a thread. If your post applies to one of the topics listed, please use that Prefix for your post. When browsing the thread list you can use the Prefix to filter the view.
  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

eleVator

Occasional Visitor
Hi, how would i enable the use of https on my current stable Merlin RT86U?

So far i installed amtm but i was watching http file pulls, tried with opkg install wget but no dice.
Didn't get lucky with searches either so far. Someone suggested in some other thread to opkg install busybox but that baffles me why they would be related, anyway i tried that one too.
 

thelonelycoder

Part of the Furniture
Hi, how would i enable the use of https on my current stable Merlin RT86U?

So far i installed amtm but i was watching http file pulls, tried with opkg install wget but no dice.
Didn't get lucky with searches either so far. Someone suggested in some other thread to opkg install busybox but that baffles me why they would be related, anyway i tried that one too.
That appears to work without
Code:
opkg install wget ca-certificates
and omitting changing the $PATH on my routers. Just adding https in /opt/etc/opkg.conf
Either the wiki is outdated or the routers built in wget supports it now.
 

RMerlin

Asuswrt-Merlin dev
I added root certificate support to wget quite a few years ago...
 

thelonelycoder

Part of the Furniture
I added root certificate support to wget quite a few years ago...
Right, I should have known all along. Just never realised how Entware opkg really works and simply employs wget.
I guess that means that amtm and Diversion will use https for Entware operations after installation with the next updates.
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top