What's new

Port Forwarding Issue

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

gussie5555

Occasional Visitor
Hi,

I have an Asus RT-AC68U running FW 386.7_2 with nine Panasonic ipcams connected. I'm using standard port forwarding on the router to enable the cameras to be seen externally. The cameras use the Panasonic ViewNetCam DDNS service. The cameras can be seen via the Android i-PRO Mobile APP or directly via unique browser links.

But I have a strange issue with this setup.

If I use a PC connected to the internet or my smart phone connected to my home Wi-Fi there are no issues seeing the cameras instantly.

If I am outside my home network using my phone on mobile data or connected to an external Wi-Fi network then I will experience a long delay before connection is made to any of my cameras i.e using bookmarked links in my Android Chrome browser it will typically take nearly 20 to 30 seconds to establish a connection to any of my cameras - thereafter I will continue to see the image streamed OK. This delay means the i-PRO Mobile APP will reject any requested connection because it times out!

I also have an older RT-AC66U router running FW 380.70_0 which gives the same problem and I have tried the RT-AC68U with the latest FW 386.10_0 - again same issues.

My broadband is the BT Fibre 500 product that comes with the BT SmartHub2 router - my measured DL/UL speed is around 500Mb/s and 72Mb/s.

Now here's the thing - if I use the BT SmartHub2 configured with the same Port Forwarding rules - I have no issues when accessing my cameras from outside my home network - connections are almost instantly established.

Furthermore I have four other Panasonic cameras sited elsewhere in other locations. Three are connected to a property running BT FTTC broadband with a BT HomeHub6 router and one is abroad connected to an AIS HG 180 FibreHome router - all these routers were configured by me and all four cameras can be accessed without any issues.

This leaves me with a problem - my two Asus routers don't seem to like being accessed externally unlike the BT and AIS routers.

I've checked and checked again my ASUS configs but I just cannot figure out why I am having this issue - or am I missing something really obvious!

Are there any brainy bods out there that can help?
 
Sorry I should have been clear, I'm not using the BT SmartHub2 and the Asus Router at the same time.

With FTTP you get an ONT that converts the Fibre to regular ethernet and you coonect either the BT supplied router or in my case either of my Asus routers to the ONT.
 
Sorry I should have been clear, I'm not using the BT SmartHub2 and the Asus Router at the same time.

With FTTP you get an ONT that converts the Fibre to regular ethernet and you coonect either the BT supplied router or in my case either of my Asus routers to the ONT.

Maybe the smarthub has UPNP enabled and the asus doesn't, and you're missing something in your port forwarding rules?
 
Thanks for your replies.

For now, I'm using the BT SmartHub2 which gives me good access to my cameras using the i-PRO Mobile APP on my phone when using 4G mobile data.

As described in my first post, both of my Asus routers will cause long delays (20-30 secs) before a connection is made to any of my cameras when using 4G mobile data - but not if I connect my phone to my home broadband Wi-Fi.

I repeat this delay does not occur when using the BT SmartHub2 router.

FYI please see the attached screenshots of my broadband speed, Asus RT-AC68U and BT SmartHub configs.

The BT SmartHub2 has UPnP disabled and I have tried both Asus routers with UPnP enabled or disabled - it makes no difference.

I'm sure I'm missing something obvious in my Asus config - but I just cannot see it!
I would like to use the ASUS router but at the moment I would find it very hard to see my cameras when I'm away from home.
 

Attachments

  • speed test.jpg
    speed test.jpg
    67.2 KB · Views: 47
  • ASus RT-AC68U Internet Connection_1.jpg
    ASus RT-AC68U Internet Connection_1.jpg
    111.4 KB · Views: 52
  • ASus RT-AC68U Internet Connection_2.jpg
    ASus RT-AC68U Internet Connection_2.jpg
    83.4 KB · Views: 52
  • ASus RT-AC68U Internet Connection_3.jpg
    ASus RT-AC68U Internet Connection_3.jpg
    68.6 KB · Views: 48
More attachments
 

Attachments

  • Asus RT-AC68U Lan DHCP Server_1.jpg
    Asus RT-AC68U Lan DHCP Server_1.jpg
    229.4 KB · Views: 49
  • Asus RT-AC68U Lan DHCP Server_2.jpg
    Asus RT-AC68U Lan DHCP Server_2.jpg
    169.9 KB · Views: 51
  • ASus RT-AC68U Port Forwarding.jpg
    ASus RT-AC68U Port Forwarding.jpg
    86 KB · Views: 50
More attachments
 

Attachments

  • BT SmartHub2 My Network IPv4 configuration.jpg
    BT SmartHub2 My Network IPv4 configuration.jpg
    98.3 KB · Views: 52
  • BT SmartHub2 Firewall Configuration.jpg
    BT SmartHub2 Firewall Configuration.jpg
    73 KB · Views: 47
  • BT SmartHub2 Firewall Port Forwarding.jpg
    BT SmartHub2 Firewall Port Forwarding.jpg
    113 KB · Views: 42
Probably unrelated to your problem but you should remove the IP addresses from LAN - DHCP Server > DNS 1 and DNS 2.
 
Probably unrelated to your problem but you should remove the IP addresses from LAN - DHCP Server > DNS 1 and DNS 2.
Thanks - will remove when I get the chance to try the RT-AC68U again.

.... Awaiting any further suggestions from anyone.

The BT SmartHub2 is still behaving OK and I can access my cams now when I'm away from home,
 
I'll note that internal and external ports are configured on BT router, not on ASUS
Unless it's needed, disable UPnP
 
I'll note that internal and external ports are configured on BT router, not on ASUS
Unless it's needed, disable UPnP
I tried UPnP disable and enabled - it made no difference
I tried entering internal port number - it does only allows one to be entered - it nade no difference
 
If no solutiin is found - only thing left is to load latest ASUS stock FW onto the RT-AC68U , do a factory reset and enter everything again. - if only to eliminate Merlin as the possible cause.
 
@gussie5555 From the information you provided it seems you have given all your IP cameras a fixed ip address and outside the IP pool.
This also implies that you have set the DNS server ip address in all cameras manually, correct? If so what is the given DNS IP address?
 
Hi @gussie5555,

From my past experience, when accessing IPCAM via WAN + DDNS with manual port forwarding (PnP off), I had to disable the DoS protection option:

1682860643201.png


If I had that option enable (DoS), I always had "time out's" on the connection to IPCAM from WAN.

From a few years ago, I only access my IPCAM's via VPN Server.

I don't know if you had already tested this option, but I hope it helps you with something.
 
@gussie5555 From the information you provided it seems you have given all your IP cameras a fixed ip address and outside the IP pool.
This also implies that you have set the DNS server ip address in all cameras manually, correct? If so what is the given DNS IP address?
All Panasonic ipcams can use this free service ...


this gives you a personal web address where you can view live images from your camera on the Internet - so even if my WAN ip address changes the ipcam will automatically check in regularly to update - the time interval is configurable.
 
this gives you a personal web address where you can view live images from your camera on the Internet - so even if my WAN ip address changes the ipcam will automatically check in regularly to update - the time interval is configurable.
Yes, that DDNS service gives you easy access over the internet to your cameras. But the camera itself needs a DNS server IP adres to be able to get these assigned DDNS names.
So my question remains , what did you use as a DNS server IP adres in your cameras?
Screenshot 2023-04-30 162028.jpg
 
Yes, that DDNS service gives you easy access over the internet to your cameras. But the camera itself needs a DNS server IP adres to be able to get these assigned DDNS names.
So my question remains , what did you use as a DNS server IP adres in your cameras?
View attachment 49806
This is the Network Config page of my cams - you can see that I simply point the cams DNS at the router gatewasy address or I could put in a dedicated DNS server ip address.
 

Attachments

  • VP104_Network config.jpg
    VP104_Network config.jpg
    192.8 KB · Views: 37
Hi @gussie5555,

From my past experience, when accessing IPCAM via WAN + DDNS with manual port forwarding (PnP off), I had to disable the DoS protection option:

View attachment 49804

If I had that option enable (DoS), I always had "time out's" on the connection to IPCAM from WAN.

From a few years ago, I only access my IPCAM's via VPN Server.

I don't know if you had already tested this option, but I hope it helps you with something.
Thanks, I will try this when I'm back home.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top