Problems with google domain DDNS?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

pwnapple

New Around Here
Hello,

I am new to the forum. I apologize if someone has already posted this questions, but I am wondering if my problem is specific.
I am trying to enable DDNS with my router (with asus-merlin) with google domain. I am having an "authentication failure". Here is my log:

Dec 6 14:16:40 watchdog: start ddns.
Dec 6 14:16:40 rc_service: watchdog 1430:notify_rc start_ddns
Dec 6 14:16:40 custom_script: Running /jffs/scripts/service-event (args: start ddns)
Dec 6 14:16:40 start_ddns: update DOMAINS.GOOGLE.COM [email protected], wan_unit 0
Dec 6 14:16:40 inadyn[11386]: In-a-dyn version 2.7 -- Dynamic DNS update client.
Dec 6 14:16:40 inadyn[11386]: Update forced for alias [HOSTNAME], new IP# [IP ADDRESS]
Dec 6 14:16:40 inadyn[11386]: Fatal error in DDNS server response:
Dec 6 14:16:40 inadyn[11386]: [200 OK] badauth
Dec 6 14:16:40 inadyn[11386]: Error response from DDNS server, exiting!
Dec 6 14:16:40 inadyn[11386]: Error code 50: Authentication failure

----------------------------

any help will be appreciated. Thanks!
 
Last edited:

RMerlin

Asuswrt-Merlin dev
"badauth" and "authentication failure" indicates that your username/password is incorrect.
 

pwnapple

New Around Here
Thank you for the reply.
I double-checked my username and password and it still did not work.

However, I installed 386.1_beta1 and it registers properly now! I am not sure if this was a glitch but I will stick with this version for now.

For some reason, when I try to use Let's encrypt, it is stuck in "authorizing". I tried deleting all my previous certs and keys and ran "/sbin/le_acme" and it is able to generate new ones no problem, but the server certificate still says "authorizing". Does anyone know how to "force renewal"? In the log it says the following:

Dec 6 16:12:27 kernel: [Sun Dec 6 16:12:27 EST 2020] Skip, Next renewal time is: Thu Feb 4 20:50:24 UTC 2021
Dec 6 16:12:27 kernel: [Sun Dec 6 16:12:27 EST 2020]
Dec 6 16:12:27 kernel: Add '--force' to force to renew.

I am wondering if this might remedy my issue. I already tried factory resetting with no luck. I tried "/sbin/le_acme --force" but that does not seem like the right command...
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top