1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

[R7800] wireguard-go doesn't get working

Discussion in 'NETGEAR AC Wireless' started by Tume, Apr 8, 2020.

  1. Tume

    Tume Occasional Visitor

    Joined:
    Oct 9, 2018
    Messages:
    19
    Hi! I tried to get wireguard-go working with Voxel FW.

    I have Mullvad VPN. I created .conf file by their site and it looks like this:
    Code:
    [Interface]
    PrivateKey = XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
    Address = 10.66.131.5/32,fc00:bbbb:bbbb:bb01::3:8304/128
    DNS = 193.138.218.74
    
    [Peer]
    PublicKey = YYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYY
    AllowedIPs = 0.0.0.0/0,::0/0
    Endpoint = 185.204.1.203:3024
    First problem is, when I try to set that .conf file to my wg0 interface, it says:

    [email protected]:/$ wg syncconf wg0 wg.conf
    Line unrecognized: `Address=10.66.131.5/32,fc00:bbbb:bbbb:bb01::3:8304/128'
    Configuration parsing error

    Okay, that's fine. Let's remove that line.

    [email protected]:/$ wg syncconf wg0 wg.conf
    Line unrecognized: `DNS=193.138.218.74'
    Configuration parsing error

    Let's remove that line too. Then it works. now command wg show us:
    Code:
    [email protected]:/$ wg
    interface: wg0
      public key: ZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZ
      private key: (hidden)
      listening port: 51907
    
    peer: ny9u5anjMGsoe2Yrf3wqZMvSifNtTknVMz3KfblWpi0=
      endpoint: 185.204.1.203:3024
      allowed ips: 0.0.0.0/0, ::/0
    ip link show us:
    Code:
    [email protected]:/$ ip link show wg0
    34: wg0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1420 qdisc pfifo_fast state UNKNOWN mode DEFAULT qlen 500
        link/none
    OK. Then I add ip address to wg0 interface
    Code:
     ip address show wg0
    34: wg0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1420 qdisc pfifo_fast state UNKNOWN qlen 500
        link/none
        inet 10.66.131.5/32 scope global wg0
    Then I just give command: ip link set up dev wg0

    It doesn't give any response after that. It just doesn't affect at all and I don't have any idea why?

    - Tume
     
    Last edited: Apr 8, 2020
  2. Voxel

    Voxel Very Senior Member

    Joined:
    Dec 9, 2014
    Messages:
    1,641
    Very brief.

    This add-on is not tested yet and is published for testing by kamoj. He did not test this yet. So there is no readme for this. I cannot test myself unfortunately because of self-isolation.

    If you want to test yourself with your provider you should:

    (1) Install both packages

    (2) Prepare /etc/wireguard.conf according to this instruction (end of my very first post, WireGuard client).
    https://www.snbforums.com/threads/custom-firmware-build-for-r9000-r8900-v-1-0-4-38hf.61402/

    (3) Enable /etc/init.d/wg-client
    Code:
    /etc/init.d/wg-client enable
    nvram set wg-client=1
    nvram commit
    
    (4) Run it manually or by reboot of your router
    Code:
    /etc/init.d/wg-client start
    
    (5) Check its log /var/log/wireguard-client.log in the case of problems.

    P.S. Do not expect super fast speed from Wireguard-Go...

    Voxel.
     
  3. Tume

    Tume Occasional Visitor

    Joined:
    Oct 9, 2018
    Messages:
    19
    Hi Voxel!

    Thank you for helping me!

    Code:
    INFO: (wg0) 2020/04/09 12:42:48 Starting wireguard-go version 0.0.20200320
    RTNETLINK answers: File exists
    RTNETLINK answers: File exists
    RTNETLINK answers: No such process
    Restart firewall to apply iptables rules for WireGuard client.
    Generating Rules...
    Done!
    Starting Firewall...
    Done!
    Still https://am.i.mullvad.net/ say You are not connected to Mullvad. I'm out of ideas again.

    /etc/wireguard.conf looks like this:
    Code:
    EndPoint="185.204.1.203"
    LocalIP="10.66.131.5"
    PrivateKey="XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX="
    PublicKey="YYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYY="
    Port="3024"
    I also set echo "nameserver 193.138.218.74" >> /etc/resolv.conf as their conf file said. WG just doesn't work.
     
  4. Voxel

    Voxel Very Senior Member

    Joined:
    Dec 9, 2014
    Messages:
    1,641
    There should not be such messages. It is bad. As I said I did not test it. Only very initial tests long time ago by kamoj.

    Try to disable wireguard in nvram, reboot your router, enter by telnet/ssh and run

    /etc/init.d/wg-client start

    manually. To check that it is OK. After that result of "route" command. And your log file.

    And to check that you are connected or not:

    ping 8.8.8.8
    traceroute 8.8.8.8

    Voxel.
     
  5. kamoj

    kamoj Very Senior Member

    Joined:
    May 12, 2017
    Messages:
    717
    Voxel and L&LD like this.