R9000 running Voxel's 1.0.4.42HF rebooting randomly.

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

multicast

Occasional Visitor
Hi everyone

need some ideas where to check and what to check, my router is rebooting randomly, can't see anything in log-messages, is is there anything else I can check?
 

Voxel

Very Senior Member
Hi everyone

need some ideas where to check and what to check, my router is rebooting randomly, can't see anything in log-messages, is is there anything else I can check?
1. Try to check temperature of CPU/Wi-Fi modules of your R9000 in debug page:

http://routerlogin.net/debug.htm

2. Try to disable QoS if enabled. I've seen similar report from myopenrouter forum. But I cannot reproduce: my R9000 is working fine with QoS enabled.

Voxel.
 

multicast

Occasional Visitor
1. Try to check temperature of CPU/Wi-Fi modules of your R9000 in debug page:

http://routerlogin.net/debug.htm

2. Try to disable QoS if enabled. I've seen similar report from myopenrouter forum. But I cannot reproduce: my R9000 is working fine with QoS enabled.

Voxel.
@Voxel my CPU temp is 59F, my home is 72F all day long and go down to 67F at nights, haven't seen a spike in temp to be honest, but I will check more often with a script if possible

I'm not running QoS, have 1Gbps :) not needed.

The only thing I see in the logs, is this:

39503:[wifi1] FWLOG: [22719] WAL_DBGID_XCESS_FAILURES ( 0xffff, 0x3, 0x1 )
39503:[wifi1] FWLOG: [23465] WAL_DBGID_XCESS_FAILURES ( 0xffff, 0x3, 0x1 )
39504:[wifi1] FWLOG: [23743] WAL_DBGID_XCESS_FAILURES ( 0xffff, 0x4, 0x1 )

what is this? something to be worried about ?

I've disabled the 160Mhz feature, disabled and enabled MIMO and Beamforming only, having a script capturing log-message in my NAS, I've enabled the Kernel.panic capture as well but can't reproduce the issue on demand, have to wait till reboots though.

Is there any way to check dmesg? when I execute it doesn't show anything.

@Voxel thanks for taking the time in replying
 

Voxel

Very Senior Member
The only thing I see in the logs, is this:

39503:[wifi1] FWLOG: [22719] WAL_DBGID_XCESS_FAILURES ( 0xffff, 0x3, 0x1 )
39503:[wifi1] FWLOG: [23465] WAL_DBGID_XCESS_FAILURES ( 0xffff, 0x3, 0x1 )
39504:[wifi1] FWLOG: [23743] WAL_DBGID_XCESS_FAILURES ( 0xffff, 0x4, 0x1 )

what is this? something to be worried about ?
Well. These are DEBUG messages. Internals of QCA and NG. As I said you should ignore them. They are inside the kernel module /lib/modules/3.10.20/umac.ko and this module is included into NG GPL sources in binary form so I do not control it. For example the command:

Code:
cat /var/log/log-message | grep XCESS | wc
displays me result in 1086 such messages. Debugging information left by unclear reason in this module in release mode...

I do use the alias set in my /root/.profile file:

Code:
#!/bin/sh
export PATH=/opt/bin:/opt/sbin:/bin:/sbin:/usr/bin:/usr/sbin
alias dmesg='cat /var/log/log-message | grep -v "FWLOG:"'
to avoid this "spam".

I've disabled the 160Mhz feature, disabled and enabled MIMO and Beamforming only, having a script capturing log-message in my NAS, I've enabled the Kernel.panic capture as well but can't reproduce the issue on demand, have to wait till reboots though.
I hope this is something temporary. Maybe it has a sense to save your config, reset to factory and restore from backup if you face this again. My uptime is almost three days. No reboots.

Voxel.
 

paddyr

New Around Here
Hi everyone

need some ideas where to check and what to check, my router is rebooting randomly, can't see anything in log-messages, is is there anything else I can check?
I've also experienced this behavior but was putting it down to me been a newb and doing something wrong.
Updated firmware from Netgear v1.0.5.2
 

multicast

Occasional Visitor
Thanks
Well. These are DEBUG messages. Internals of QCA and NG. As I said you should ignore them. They are inside the kernel module /lib/modules/3.10.20/umac.ko and this module is included into NG GPL sources in binary form so I do not control it. For example the command:

Code:
cat /var/log/log-message | grep XCESS | wc
displays me result in 1086 such messages. Debugging information left by unclear reason in this module in release mode...

I do use the alias set in my /root/.profile file:

Code:
#!/bin/sh
export PATH=/opt/bin:/opt/sbin:/bin:/sbin:/usr/bin:/usr/sbin
alias dmesg='cat /var/log/log-message | grep -v "FWLOG:"'
to avoid this "spam".


I hope this is something temporary. Maybe it has a sense to save your config, reset to factory and restore from backup if you face this again. My uptime is almost three days. No reboots.

Voxel.
@Voxel for this info, very appreciated. I did a full reset/restore when my R9000 turned into a brick, I was able to restore it using TFTP, I flashed it with 1.0.5 then refreshed it with yours 1.0.4.41, no .42, I did a full config from scratch after it turned into a brick
 

multicast

Occasional Visitor
I've also experienced this behavior but was putting it down to me been a newb and doing something wrong.
Updated firmware from Netgear v1.0.5.2
What did you do wrong? maybe I am doing same mistake without knowing is wrong. Thanks in advance for any info you can provide.
 

multicast

Occasional Visitor
I've disabled QoS so fingers crossed. Max CPU is 62C for me. (143F)
I do not use QoS. Thanks for the feedback.
Quick question, the temp shown in debug page is Centigrades or Fahrenheit? I have 59-60 usually. But not idea if C or F now.
 

det721

Part of the Furniture
It's Celsius. So 60 C would be 140 F
 

multicast

Occasional Visitor
hello,

my r9000 is crashing/rebooting randomly since 1.0.4.41HF .. 1.0.4.42HF didnt fix it.

need help :(
I did some changes in my config, I disabled 160Mhz channels, tried using non-overlapping channels in my 2.4Ghz and 5Ghz, so far 1day and 19hrs up, but still under testing and capturing logs.

One question, do you have Kamoj add-on installed? if so, did you tweak Network Options and Congestion Protocol?
 

paddyr

New Around Here
Disabled QoS but still got a reboot, thankfully it wasn't during business hours.

Will give a try of your suggestions and see if there is an improvement. I do have kamoj installed but nothing tweaked as of yet.

Only changes I made was to transmission to setup a watch directory in the settings.json, now only able to see this going to port 9091, clicking thru the link in the interface doesn't show downloads.

Having this is awesome many thanks to voxel for his firmware.

Actually one other tweak I've made is setup openvpn.
 
Last edited:

multicast

Occasional Visitor
Disabled QoS but still got a reboot, thankfully it wasn't during business hours.

Will give a try of your suggestions and see if there is an improvement. I do have kamoj installed but nothing tweaked as of yet.

Only changes I made was to transmission to setup a watch directory in the settings.json, now only able to see this going to port 9091, clicking thru the link in the interface doesn't show downloads.

Having this is awesome many thanks to voxel for his firmware.

Actually one other tweak I've made is setup openvpn.
Since I disabled the 160Mhz feature my router has been up for 3days in a row, crossing my fingers...
 

Arnout Verbeken

Occasional Visitor
Just chiming in that I also had some random reboots last week. But it started after installing the laste Kamoj beta addon and enabling Adguard Home. I now reverterd back to plain Voxel (removed the addon) and it seems to be stable for the moment (almost 24h now).
I'll keep an eye on it.
 

multicast

Occasional Visitor
Just chiming in that I also had some random reboots last week. But it started after installing the laste Kamoj beta addon and enabling Adguard Home. I now reverterd back to plain Voxel (removed the addon) and it seems to be stable for the moment (almost 24h now).
I'll keep an eye on it.
Since I did my changes my router has been up for 4 days straight.

Current config has Voxel's FW 1.0.4.42HF, Kamoj add-on beta 5.3b9, 160Mhz feature disabled, not Plex nor QoS enabled.
 

paddyr

New Around Here
Since I did my changes my router has been up for 4 days straight.

Current config has Voxel's FW 1.0.4.42HF, Kamoj add-on beta 5.3b9, 160Mhz feature disabled, not Plex nor QoS enabled.
Thanks for the update, the only thing I changes was to disable QoS. 3 days running. There didn't seem to be anything consistent between the actions taken to identify what was/is causing the reboots. As I know you said that you never had QoS enabled to start with.

Must get my finger out and write a log shipping script to keep the last log prior to one of these reboots, although it may miss that vital part couple of seconds. Need to make sure it didn't overwrite it after the reboot as well was thinking something like an uptime+date stamp on the file.
 

kamoj

Very Senior Member
You have this functionality in the kamoj add-on:
Save the system logs to USB. (or /opt/kamoj/logs if no USB detected)

Thanks for the update, the only thing I changes was to disable QoS. 3 days running. There didn't seem to be anything consistent between the actions taken to identify what was/is causing the reboots. As I know you said that you never had QoS enabled to start with.

Must get my finger out and write a log shipping script to keep the last log prior to one of these reboots, although it may miss that vital part couple of seconds. Need to make sure it didn't overwrite it after the reboot as well was thinking something like an uptime+date stamp on the file.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top