Router crashes repeatedly when Guest Network 1 (5Ghz) is used and IPv6 is configured on the router

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

JWoo

Senior Member
Good day @ASUSWRT_2020 . Just sharing that the closed source Guest Network function has some significant bugs in it. I have tested this with build FW_RT_AX56U_300438645898 but I believe the faults can be replicated with any 386 based build.

If you use Guest Network 1 (I used 5Ghz band) and also are using the IPv6 function (native, prefix delegation), your router will crash frequently (appears to be an interaction between the Asus closed source guest network function and the Broadcom mcast driver). It would be desirable to correct this so Guest Network 1 would be stable when IPv6 is configured on the router.

See this thread for problem reported on Merlin which further documents this fault: https://www.snbforums.com/threads/i...addresses-in-any-386-build-on-rt-ax56u.75301/

I marked this "solved" on Merlin because I used Guest Network 2 as a workaround which works with IPv6. But Asus should correct the closed source Guest Network function so Guest Network 1 will work with IPv6.
 

L&LD

Part of the Furniture
I may not understand the issue here @JWoo, but I'm running RMerlin firmware 386.4 Alpha 1 for months with IPv6 and no issues with GN1 and with a wired 2.5GbE backhaul (and LAN) via 2x QNAP QSW-1105-5T's and 2x RT-AX86U AiMesh set up (yes, not the router firmware you're specifying in your post here).

While it may be helpful to report this to @ASUSWRT_2020, did you also report this to Asus directly via the feedback link when you were running stock/official firmware? That may give more weight to your issues for released firmware.
 

KingBravery

Senior Member
Thats true.. I can see the wifi will crash after day 3 on my AX86U using latest stable Merlin firmware.. At first, I dont believe and after day 3 for second and third time, I just turn off the guest network 1.
 

JWoo

Senior Member
@L&LD as also confirmed by @KingBravery, I reported that if you use Guest Network 1 and have IPv6 turned on, you will have repeated router crashes on any of the 386 based builds. You will also see an ancillary defect in the software that I reported which is that the Guest Network devices on Guest Network 1 will not have any IPv6 addresses reported in System Log -> IPv6.

If you switch to any 384 based build you can keep using Guest Network 1 and it will function correctly. On any 386 based build, you have to use Guest Network 2 or 3 in order that:
- the router will not crash
- Wireless and IPv6 logs report correct IPv6 addresses for your guest network devices
 

L&LD

Part of the Furniture
Curious then why none of the routers I have access to show this effect with IPv6 enabled?

Has RMerlin's Alpha 1 been tested too?

What other scripts, features, or options are being used to trigger it?
 

JWoo

Senior Member
I am also using Stubby, but I don't think that has any impact from my testing. All of my IoT devices on the 5Ghz Guest WIFI can accept an IPv6 LAN side address. I have 8 - 9 devices on that guest network and they generate a lot of IP traffic. I am currently on the Alpha 1 and it is very stable on Guest Network 2. When I use Guest Network 1 on the Alpha 1 build, yes I will get the first crashes within a day or so. And as I indicated above, you can tell this guest network function is broken because the IPv6 log will show no IPv6 addresses assigned to the guest network devices when Guest Network 1 is used. When I use Guest Network 2 or 3, the router properly assigns IPv6 addresses as shown in the IPv6 log.

Note that this is a fault on all 386 builds after Asus redesigned the closed source Guest Network function; the guest networks worked fine with IPv6 on the 384 based builds.

@L&LD as to why you have not experienced the fault on the 386 based builds: One reason would be that your guest network devices are not compatible with IPv6. Second, it may take 1 - 1.5 days before you get the first crash. Lastly, as stated earlier, you should check the IPv6 log to see if any devices on your guest network are getting IPv6 addresses. If you see no guest network devices in the IPv6 log, you will sooner or later get the crash.
 
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top