RT-AC86U - works perfectly except for all my PLAYSTATIONS!

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

preseznik

New Around Here
Hi,

I have a pretty strange problem I can't seem to solve on my own.

My setup:
- Technicolor CGA2121 cable modem set to BRIDGE MODE
-> RT-AC86U
-> my various PCs (work perfect, full speed)
-> my Xboxes (360,X1X,XSX) (work perfect, full speed)
-> my Playstations (3,4,5) - THEY CAN'T EVEN CONNECT



Situation 1: With everything set to default, what happens is I get a WAN IP (dhcp) and everything works fine for a minute (even Playstation connectivity- then connection drops ("Your ISP'S DHCP does not function properly"). This is obviously unusable.
Situation 2: I set "Spoof LAN TTL value" in the WAN config and suddenly everything works and connection doesn't drop - but Playstation connectivity is borked ("failed" when checking internet access).


I have no idea what to do. At some point I managed to get PS connectivity up, but at sub 100kbit speeds, while everything else worked full speed.
The settings I played around with:
LAN -> IPTV -> enable multicast routing
WAN -> Extend the TTL value
Disable Firewall

I tried on official FW (RT-AC86U_3.0.0.4_386_40451-g30f1b6c) and on Merlin (RT-AC86U_384.19_0), same problem.
Before buying RT-AC86U, I was on TL-WR1043ND and everything just worked.

Any help would be greatly appreciated.
Apologies if I put this in the wrong forum, seemed like the best fit.
 

L&LD

Part of the Furniture
If you're blindly flashing back and forth between stock and RMerlin firmware, stop.

Flash the firmware you want on the router. Then follow the steps below to get it to a good/known state.

M&M Config https://www.snbforums.com/threads/n...l-and-manual-configuration.27115/#post-205573

Only change/add a customized configuration once the network has proven itself stable (several hours or days, if necessary).

I would further suggest following the suggestions below too.

Sanitize Network https://www.snbforums.com/threads/rt-ac66u-slow-wan-to-lan.12973/page-3#post-269410

You can find more links (including the two above) in the link below.

L&LD | SmallNetBuilder Forums
 

preseznik

New Around Here
Hi, thanks for the reply.

I only flashed once, after I exhausted everything I could (to the best of my ability) on the offical FW.

I checked your links, thanks, I appreciate it, but I was hoping for something more related to my very specific problem outlined above.

TLDR;
It seems my ISP needs "Spoof LAN ttl value" to even keep a connection for more than a minute (no idea how), but this causes every Playstation device to immediately lose the ability to connect.
 

L&LD

Part of the Furniture
I'll repeat for your benefit; flashing RMerlin firmware requires a full reset to factory defaults (and a minimal and manual configuration afterward).

Doing so allows the router's firmware to properly see and use the defaults it's expecting. Right now, this isn't happening.

Trying to troubleshoot 'your specific problem' is a wild goose chase at this point.
 

preseznik

New Around Here
I understand, but the problem is present without any flashing at all.
Behaviour exhibited was out of the box.

Not sure what you're expecting me to do. I know flashing didn't cause this problem.
 

ColinTaylor

Part of the Furniture
I understand, but the problem is present without any flashing at all.
Behaviour exhibited was out of the box.

Not sure what you're expecting me to do. I know flashing didn't cause this problem.
He's asking you to factory reset your firmware after installing Merlin. Without doing that any testing you do will be meaningless.

It's possible there is some sort of bug in the stock firmware that isn't present in Merlin, but it seems unlikely it would only be triggered by Sony products.
 

preseznik

New Around Here
I went through the process last night.
For whatever reason, it still won't hold a connection to my ISP without spoofing TTL, and with that enabled none of my Playstation devices will connect through to the internet, wired or wireless.

Tried my old TL-WR1043ND and that worked fine.

So now I put a RT-AX55 behind the RT-AC86U and hooked up only my Playstations to that (I have many, so the testing was thorough) - and it works.
But now I have two routers, chained.

At least it works, while I continue trying to figure this out.

Edit: I just read this about my new PS5:
1605953001880.png


I assumed the problems started when I got my new router, but I did get the PS5 at the same time... Not sure why that would affect my PS4s and PS3s, but another thing to consider.
 
Last edited:

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top