What's new

RT-AX58U and IFTTT won't link

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here

For the past few days, I've been trying to figure out why RT-AX58U is unable to link to my IFTTT-account.
After generating an activation code in the admin-gui, I head over to https://ifttt.com/asusrouter and hit "connect".
So far so good. Then I paste my activation code and hit "Activate". After a few seconds, the activation fails and I get a error hint stating that I need to verify that my DDNS and WAN-access are enabled. It seems to be a general error pre-rendered in the HTML-markup. So I don't believe that is very accurate.

It says "Please check the following settings: Enable DDNS, Enable Web Access from WAN".
As far as I'm concerned, these settings are configured correctly from my end.


I have tried the following:
  • Reinstalled latest the asuswrt firmware (
  • Used a different DDNS provider besides asuscomm.com (I Tried noip.com)
  • Tried both with/without SSL enabled on the DDNS
  • Port forwarding on/off
  • Factory reset of the RT-AX58U
  • Created another IFTTT-account
  • Tested the linking procedure from multiple browsers/devices
No matter what I do I get the same response. Unfortunately, IFTTT uses PHP and forms here so there is no plain client XHR request that I can interpret in the browser network log.
I've monitored the system log in the RT-AX58U, but nothing is recorded there during the activation.

What can I do next?

Best Regards /

These are my current WAN and DDNS-settings:



Last edited:
Just guessing because I've never used IFTTT, but maybe it's hard-coded to use the default port (8443) rather than your custom port.
Thanks for the input. I did try 8443 as well, without success unfortunately.
I’ll probably give up and look for another solution. My intention was to trigger a web request when a specific device connects to my router. A working IFTTT-integration would have saved me some python lines. But I’ll try nmap and ping-looping from another device instead. Perhaps more secure than ifttt anyway.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!