What's new

RT-AX86U, RT-AX68U to 388.1 firmware, aimesh now shows no ethernet uplink

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
Hi all,

I have a potential aimesh issue since upgrading to asus-merlin 388.1, and I would really appreciate if you have any suggestions on how to resolve it.

In my house I have an aimesh network consisting of an RT-AX86U in my front room that acts as the primary router, and two RT-AX68Us in my attic and garden studio that are connected to the RT-AX86U via ethernet cable.

I upgraded the firmware of all devices from 387.x to 388.1. It looks like this may have caused issues with the ethernet connection between the primary router and the node:
- In the web portal, aimesh tab, the diagram went from showing green lines between the router and nodes to grey lines with crosses over them
- When I click on each AI node, it says the connection quality is 'Great' but also shows a red speech bubble which contains the warning 'Your AiMesh node cannot connect to your uplink AiMesh device. Ensure that both devices have been powered on. If your node still fails to connect, power cycle your devices and move them closer to each other'
- When I click on the Network tab of each aimesh node,it gives the uplink type of Ethernet but then displays a red cross on the diagram

However, all devices have clients connected to them, and show ethernet transmit/receive stats, so I'm not sure if there is an actual issue with the ethernet connection, although my family have been regularly complaining about the wifi connection and ability to connect to the internet (in the main house, i.e. where the main router and Attic node are).

Do you think I have a connection issue? If so, can you suggest how I can resolve the issue? I've tried resetting the two nodes and reconnecting but it hasn't helped. I could reset the primary router, if you think it will help.

Any help appreciated



  • Screenshot 1 - main view.png
    Screenshot 1 - main view.png
    169.6 KB · Views: 78
  • Screenshot 2 - first node (attic).png
    Screenshot 2 - first node (attic).png
    164.8 KB · Views: 78
  • Screenshot 3 - second node (garden room).png
    Screenshot 3 - second node (garden room).png
    165.6 KB · Views: 78
Have you tried using Merlin in the main router and AsusWRT in the nodes? For some reason, this combination tends to work better than all Merlin.

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!