What's new

Solved Samsung Galaxy S24 Ultra Doesn't Detect 6Ghz Band on Wifi Router

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

Just like in a civil suit, the preponderance of the evidence puts the ball in Samsung's "court."

I don't get it. Isn't this stuff that has standards? How hard is it to adhere to them?
Perhaps it could be a Wifi module issue? Noticed that Samsung gradually transitioned away from BCM Wifi modules to QCA. The S21U-S22U used BCM4389 chips while the S23U-S24U both use the QCA FastConnect7800. Probably takes them a generation or two to iron out the bugs when switching to a new vendor.

Also the whole WiFi regulatory landscape is pretty complicated with only a handful of countries allowing the full 6Ghz spectrum for unlicensed wireless use and some with caveats I think. Makes worldwide implementation a major headache...

I just heard back from Samsung Tech Support and they pretty much told me, word-for-word, the exact same solution which I discovered for myself. Maybe someone from their team reads SNBForums too.

But it still doesn't explain why my HP Spectre with the AX211 WiFi module immediately detects and connects to the 6Ghz SSID automatically without me having to manually select channels though.
 
Perhaps it could be a Wifi module issue? Noticed that Samsung gradually transitioned away from BCM Wifi modules to QCA. The S21U-S22U used BCM4389 chips while the S23U-S24U both use the QCA FastConnect7800. Probably takes them a generation or two to iron out the bugs when switching to a new vendor.

Also the whole WiFi regulatory landscape is pretty complicated with only a handful of countries allowing the full 6Ghz spectrum for unlicensed wireless use and some with caveats I think. Makes worldwide implementation a major headache...

I just heard back from Samsung Tech Support and they pretty much told me, word-for-word, the exact same solution which I discovered for myself. Maybe someone from their team reads SNBForums too.

But it still doesn't explain why my HP Spectre with the AX211 WiFi module immediately detects and connects to the 6Ghz SSID automatically without me having to manually select channels though.
Two modules by the two different vendors yet the same issues with both? That’s Samsung doing poor coding and not paying attention to the bugs. None of the other mobile phone vendors are having those same issues.
 
Two modules by the two different vendors yet the same issues with both? That’s Samsung doing poor coding and not paying attention to the bugs. None of the other mobile phone vendors are having those same issues.
That's true. I highlighted this glaringly obvious issue to Samsung Tech Support as well and told them to work things out and roll out an OTA software update asap.
 
I definitely noticed the 6ghz bands showing up immediately on my S21/S22 ultra phones when I turned off the "Switch to better wifi networks" under intelligent wifi settings on my BE98 Pro. I sent feedbck to asusi for whatever it's worth I guess. More of a samsung issue anyway. Maybe it will help. I don't have any iphones to compare behavior but I will test next time I have a friend/family over who have an iphone. Curious to see.
 
I'm sure they're already doing it!;)

Sarcasm aside (or not), have to give them credit for being smart enough to 'allegedly' seek a quick fix to my connection issue on this forum. :D

Also doesn't hurt that they kept trying to offer me free stuff and discount codes, which I politely declined.
 
Oh, I'm all for freebies but not stuff which I don't need like a proprietary 'fast' wireless charger that'll degrade the battery more quickly than if I'd used good old wired 'slow' charging.
 
Oh, I'm all for freebies but not stuff which I don't need like a proprietary 'fast' wireless charger that'll degrade the battery more quickly than if I'd used good old wired 'slow' charging.

LoL - I totally get that one - OnePlus Nord N20 - with their proprietary charger, it does warm the device up a bit - for me, it's a test device, not a daily driver, but I can only imagine that it's boiling the cells in the battery...
 
Yeah, they'll get right on that!

All due respect - they probably are... the S24 is pretty fresh still as of the 2nd of February 2024, and it's a flagship device, so if there is any chance of a fix, this really is the time...

I think between 6GHz in general, and 802.11BE specifically, there's a fair amount of interoperability to sort out.

Just note on devices like the S24 and others - it's not just the WiFi that is a challenge - 4G/5G wireless can be a challenge as well - as 5G has two modes - Standalone and Non-SA...
 
One of the issues I am having with my s24 ultra is it will on connect on Wifi 6 not Wifi 7. It shows my guest access point as Wifi 7 and if I delete the main SSID from the phone and it shows its a Wifi 7 SSID. Then right when I connect it drops to Wifi 6. I did disable PSC. Sometimes it will show 7 and about 90% its on Wifi 6.

Edit:
This morning my phone said not internet on the wifi.I disabled and re-enable it, then it's good. Hopefully Samsung fixes this soon.
 
Last edited:
hungarian, S24ultra and GT-AXE16000 Wifi 6GHz = Perfect :)

Same here (Brazil), S24 Ultra and 6GHz GT-AXE16000 working fine, but my Alienware X17R2 (Killer AX1675) does not see the 6GHz bands, no matter what (drivers/channels/whatever), Dell has blocked 6E here for ALL their notebooks (6E were not validated by local Regulatory Agency - ANATEL), I need BIOS update, according to Dell they will update it in April 2024, I really don't care, since 5GHz 160 gives me my full ISP bandwidth, but it sucks to not use a more "free" frequency as 6GHz.
 
Last edited:
One of the issues I am having with my s24 ultra is it will on connect on Wifi 6 not Wifi 7. It shows my guest access point as Wifi 7 and if I delete the main SSID from the phone and it shows its a Wifi 7 SSID. Then right when I connect it drops to Wifi 6. I did disable PSC. Sometimes it will show 7 and about 90% its on Wifi 6.

Edit:
This morning my phone said not internet on the wifi.I disabled and re-enable it, then it's good. Hopefully Samsung fixes this soon.
You need to go to Wifi settings in the router and switch from "WPA" or "WPA2" to "WPA2 + WPA3" in order to use Wifi 7 on 2.4Ghz and 5Ghz.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top