SNMP monitoring issue after upgrading to 384.4_2 on RT-AC5300

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

orion44

Occasional Visitor
I've always used SNMP to monitor my WAN traffic (among others) and after upgrading to 384.4_2 the data returned no longer includes WAN traffic and instead is the LAN traffic.

Prior setup under 380.xx
Monitoring interface 005 (eth0) via SNMP
Shows only WAN traffic

Current setup under 384
Monitoring interface 005 (eth0) via SNMP
Shows all LAN traffic combined

upload_2018-5-9_16-15-9.png


upload_2018-5-9_16-17-38.png



I'm assuming the interface number wouldn't have changed as the result of a firmware update. Is there any hope to regain collecting WAN only traffic again?
 

orion44

Occasional Visitor
To note, I've tried downgrading back to 380 and the monitoring of eth0 is still LAN traffic (combined). I re-upgraded to 384, did a factory default restore, new manual config, and still no dice. Is this something that transcends firmware? It seems odd it can't be remedied with the old FW version or a factory default restore. Losing out on WAN traffic data is pretty crappy as well.
 

orion44

Occasional Visitor
Tools - System Information leads me to believe WAN traffic is now under vlan2 -- however the link state is down and no traffic is logged. Is this the root cause of the issue?

upload_2018-5-9_23-27-55.png


upload_2018-5-9_23-27-36.png
 

orion44

Occasional Visitor
I'm not able to reproduce the issue with my RT-N66U since I can't run the new firmware. Is anyone else using the SNMP feature for monitoring and noticing a change in eth0 after updating to 384.x?

The only thing I haven't tried is going back to 380.x and then doing a factory reset. When I previously downgraded, it was a dirty downgrade. I'd rather not go backwards, but it might be my only option.
 

orion44

Occasional Visitor
Success!

Steps to correct the SNMP issue:
  1. Flash 380.x firmware
  2. Perform factory reset
  3. Power cycle router (optional)
  4. Manually configure settings
  5. Confirm SNMP working as expected
  6. Restore prior config (optional)
upload_2018-5-13_12-19-21.png


I also noticed the average CPU usage dropped as well after reverting to 380.x

upload_2018-5-13_12-26-8.png


The increase was observed when I upgraded to 384.x last month
upload_2018-5-13_12-28-51.png
 

orion44

Occasional Visitor
Any idea if the SNMP issue can be corrected in a future 384 release? I'd rather not stay on 380 long term.
 

RMerlin

Asuswrt-Merlin dev
If the Ethernet driver doesn't play nice with SNMP then there's nothing I can do about it.

Try monitoring the vlan instead, see if you get better results.

Sent from my P027 using Tapatalk
 

orion44

Occasional Visitor
I already tried monitoring every port, vlan or otherwise. None of the them provided WAN traffic data. Guess I'll stay on 380 until the next botnet targeting ASUS devices bricks it. By then the hardware should need replacing anyway.
 

develox

Regular Contributor
Just as an added option, I use collectd to collect various data from the router, including WAN and LAN traffic.
Screen Shot 2018-11-16 at 15.45.29.png
 
Last edited:

orion44

Occasional Visitor
Interesting, thanks for sharing. I've never used collectd previously and it looks way more accurate than SNMP under the current firmware.
 

cburkins

New Around Here
Bit of an older thread, but wondering if it's still impossible to use SNMP to track WAN-only traffic ?
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top