spdMerlin spdMerlin - stuck Upgrading database

  • ATTENTION! You'll notice a Prefix dropdown when you create a thread. If your post applies to one of the topics listed, please use that Prefix for your post. When browsing the thread list you can use the Prefix to filter the view.
  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Plompie

Occasional Visitor
Hi all,

Since last update spdMerlin did not show any results in the graphs anymore and scheduled test were not running. Logged into AMTM via SSH and when trying to open de spdMerlin option (j4) I received below message. Restarted the router, tried to remove the scrip manually for re-install but no luck, the error keeps coming back.

Any idea's how I could get it running again?


Initial error: (AMTM -> j4)

Code:
Segmentation fault
Segmentation fault
Segmentation fault
Segmentation fault
Upgrading database...

Could not access the script within AMTM so looked up the directories and files and manually removed:

Code:
/jffs/addons/spdmerlin.d/
/jffs/scripts/spdmerlin
/tmp/spdmerlin-binary
/tmp/spdMerlin.lock
/tmp/spdstats-upgrade.sql
/tmp/spd-stats.txt

After above manual removal: (retried install via AMTM)

Code:
Welcome to spdMerlin v4.4.1, a script by JackYaz

By installing spdMerlin you are agreeing to Ookla's license: https://raw.githubusercontent.com/jackyaz/spdMerlin/master/speedtest-cli-license


Do you wish to continue? (y/n)  y
Checking your router meets the requirements for spdMerlin

Installing required packages from Entware

Downloading https://bin.entware.net/aarch64-k3.10/Packages.gz
Updated list of available packages in /opt/var/opkg-lists/entware
Package sqlite3-cli (3330000-2) installed in root is up to date.
Package jq (1.6-1) installed in root is up to date.
Package p7zip (16.02-3) installed in root is up to date.
Package findutils (4.8.0-1) installed in root is up to date.
New version of spdstats_www.asp downloaded

Mounting WebUI tab for spdMerlin

Mounted spdMerlin WebUI page as user3.asp

Segmentation fault
Segmentation fault
Segmentation fault
Segmentation fault
Segmentation fault
Segmentation fault
Upgrading database...
 

Jack Yaz

Part of the Furniture
Segmentation fault suggests a possibly failing USB drive
 

Plompie

Occasional Visitor
Thank you!

It took a while due traveling and not having a new/spare USB drive but after exchanging the drive and reinstall Entware, it works fine now.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top