What's new

Strange problem with Zen Wifi ET12 when cable modem restars (also present with AX88U)

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Regular Contributor
Hello! I have been posting this on the community forum of my ISP and very knowledgeable people over there recommended that I post my issue here.

My modem is bridged and I used two different ASUS router. When the modem is turned off and turned on again, my windows computer never thinks it has lost internet, and when the modem is back on and connected all services fail (mail, web, zoom) saying that they are finding an invalid certificate and the connection is not secure: instead of connecting to the internet, while the modem is rebooting I get an alert of invalid ssl certificate the certificate instead of accessing any services.

This is solved by either restarting the computer or unplugging the ethernet cable and plugging it again, but it is very inconvenient and I am not sure how to solve it. Why doesn’t windows detect that I’m not connected to the internet when I’m connected to my router but the modem is off? Why when I restart all DNS traffic is router to the modem instead of to the internet? It is very strange.

The extensive details including screen captures of configuration of the router (running the latest firmware) as well as the specific errors are posted on this post on the

Rogers forum

Please click if you can, since the whole discussion with the ISP people is there.

I wonder if anybody knows anything about this very annoying problem. As a bonus, this happened also with the AX88U as well as with both stock firmware (what I'm running now) or Merlin.

Edit: the post with all the screen captures is here:



Occasional Visitor
Have you tried changing the "Enable WAN down browser redirect notice" setting on the Admin - System page?


Regular Contributor
Have you tried changing the "Enable WAN down browser redirect notice" setting on the Admin - System page?
Yes, that option is on by default and I kept it on. Edit: indeed this worked! switching it off did the trick. I wonder why that option is there. It was preventing windows from realizing lack of internet connection. Thanks for the help!
Last edited:

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!