Tailscale on Asus RT-AX86U router

Aerandir14

Occasional Visitor
Hello,

I've been trying to make Tailscale work on my Asus router for the last few days.

I actually made it run successfully by installing the tailscale package on Entware.

However, I noticed that if I configure Tailscale to override local DNS with my router's Tailscale IP, my Tailscale devices won't get any answer from the DNS anymore.
I noticed that if I disable IPv4 firewall on the Asus webpage, my Tailscale devices succeed to resolve their DNS requests, but it looks like the firewall activates again a few seconds later and I lose DNS resolution again.
It seems like the router won't answer any DNS request that don't come from a routed IP address. By using Tailscale, the DNS requests come from 100.100.100.100 and I can't find how to configure my router for it to accept requests from Tailscale devices.

The only way for my Tailscale requests to be answered is to set a Subnet Route to my local IP range on another Tailscale device, and set the Tailscale DNS to my router's local IP address.
I found a tutorial explaining how to install Tailscale on a pi-hole where they explain how to solve this issue (DNS working with local network IP address but not with Tailscale IP address), but it's recommended to enable "listen on all interface, permit all origins" but I can't find anything similar on my router.

I added "interface=tailscale0" to dnsmasq.conf.add, with no success.

If you have any idea about how to configure the router to accept DNS request outside of the local IP address, I'd be very grateful!
Thanks !
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top