What's new

Ting-fire device can't get DHCP addr direct from Asus router wifi...can get address from Asus router via TP-Link extender

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

anastrophe

Occasional Visitor
I have a 'Ting' electrical system monitor - amazing device - reported loose neutral on mains, PG&E checked even though they didn't believe it could diagnose it - neutral into mains apparently had never had its retaining screw tightened since house built in 1987! - But I digress.

A few weeks after updating my RT-AX3000 to 3004.388.5 (just a correlation), my Ting device (which can only do 802.11n) reported it couldn't connect to wifi. It had been connected - less than ten feet away (100% signal) - to the 802.11n network on the Asus router for a couple of years. But after a few hours, it reconnected on its own without issue.
Then yesterday, the Ting device disconnected again and I could not get it to reconnect after resetting it. The logs on the Asus - which provides DHCP across my network including three TP-Link extenders (Two RE505X v1.0 and an RE450 for guest net) - showed that DHCP discovered the device, offered an IP, got an ACK from the Ting, but then would disassociate and after repeated tries by the Ting device it would fail - "reason: Disassociated because sending station is leaving (or has left) BSS (8), rssi:0". Rebooted router, same. Had not made any changes to the router config since the firmware update. Contacted Ting, since it appeared that the device could be corrupted or failing in some other way. This morning I got a reply asking me to go through the standard scripted list of steps again, unplug router, etc etc, even though I'd provided them with a section of the logs showing how it was failing. I was writing a lengthy peeved response (coffee not onboard yet), 'I know what I'm doing, decades as sysadmin, LAN/WAN engineer', etc etc....But I figured I should do due diligence and try through a different wi-fi device just for shirtes and giggles - one of the RE505X extenders.

It immediately connected and is happily connected to the RE505X - with the same IP address as the Asus would delegate when it failed on its own wifi. What. The. Heck!!

I updated to 3004.388.6 and tried again on the main router, same failure - again, just a weak correlation, I don't think it's Merlin but can't say for sure. I can connect a freshly powered-up cellphone to the Asus router's 802.11n just fine. I'm at a loss as to what the failure mode here is.

Relevant Asus settings are
802.11n "N only"
WiFi Agile Multiband "Disable"
Target Wake Time "Disable"
Channel bandwidth "20/40 MHz"
Control Channel "Auto Current Control Channel: 10"
Extension Channel "Auto"
Authentication Method "WPA2-Personal"
WPA Encryption "AES"
WPA Pre-Shared Key (lol nope)
Protected Management Frames "Capable"
Group Key Rotation Interval "0"

I believe all the other associated tab values are at defaults, I don't believe I've mucked with the "Professional" tab settings (is there an easy way to snarf configs such as these in text format?)

Attached is full log since reboot on 3004.388.6 (just to be thorough), ends at the failed DHCP session

And here's just the end of the log after reconnecting device through RE505X, completely uneventful:
Jan 20 14:15:34 dnsmasq-dhcp[2039]: DHCPDISCOVER(br0) c4:7f:51:a6:89:8b
Jan 20 14:15:34 dnsmasq-dhcp[2039]: DHCPOFFER(br0) 192.168.1.190 c4:7f:51:a6:89:8b
Jan 20 14:15:34 dnsmasq-dhcp[2039]: DHCPREQUEST(br0) 192.168.1.190 c4:7f:51:a6:89:8b
Jan 20 14:15:34 dnsmasq-dhcp[2039]: DHCPACK(br0) 192.168.1.190 c4:7f:51:a6:89:8b Ting-8B-89

Thoughts??
 

Attachments

  • syslog direct to 802.11n on Asus router.txt
    115.5 KB · Views: 7
Protected Management Frames should be off/disabled.

I don't think you should change the 2.4GHz network to 'n only' either. It should be left on Auto, even if you need to turn off AX capabilities.

Control Channel 10 is not right. Use either 1, 6, or 11 to not cause/have interference from multiple APs in the neighborhood.

Change Channel Bandwidth to 20Mhz.

Reboot the router after all changes above are made, and verify that they have stuck.
 
PMF can be a challenge for some devices - so yes, either optional or turn it off...

Look closely at your network elements - there can only be one DHCP server on a LAN subnet/segment

this is the way...
 
Protected Management Frames should be off/disabled.
Okay, I'll look what that does. Some things in the configs have a popup info box, that one doesn't. I know a lot about networks, but obviously not everything, and the nitty gritty details of wifi aren't an area I spent a lot of time in before semi-retirement...

I don't think you should change the 2.4GHz network to 'n only' either. It should be left on Auto, even if you need to turn off AX capabilities.

Interesting, okay, I'll try it. Since there's no devices on prem that do anything less than N, it seemed appropriate.
Control Channel 10 is not right. Use either 1, 6, or 11 to not cause/have interference from multiple APs in the neighborhood.
I'd thought I had set the 2.4GHz at one point, but I guess not. Usually I set specific channels, as there is a ton of wifi visible from our home, dozens of SSIDs. On 5GHz I hae all of channel 58 to myself.

Change Channel Bandwidth to 20Mhz.
Will do.
Reboot the router after all changes above are made, and verify that they have stuck.
Thanks, appreciate your suggestions, and will try them shortly.
 
PMF can be a challenge for some devices - so yes, either optional or turn it off...
Interesting, as above. I guess I did muck about with a few things, geez.

Look closely at your network elements - there can only be one DHCP server on a LAN subnet/segment

Of that, I'm certain. All three wifi extenders have their local DHCP turned off, forwarding on through to the Asus. I do have an assortment of devices across the network, a GPS disciplined time server (Raspberry pi), an ADS-B receiver, two Raspbi resolvers, and an assortment of "smart" plugs and AV equipment.

this is the way...

The way can be difficult at times...
 
I don't think you should change the 2.4GHz network to 'n only' either. It should be left on Auto, even if you need to turn off AX capabilities.
When I switch it to auto, it offers the option disable 11b. I guarantee I have no devices running that. Should I leave it be or can I disable it?
 
Control Channel 10 is not right. Use either 1, 6, or 11 to not cause/have interference from multiple APs in the neighborhood.
There's tons of neighborhood AP's on 1, 3, 6, and 11. At least from the screenshot here, I have most of 10 to myself (all 'woof' networks are mine)?

photo_2024-01-20_20-08-48.jpg
 
No luck. Changed settings as recommended save for the channel, still on 10, same as the extender (woof is the asus 2.4GHz, woof_saturn is the extender 2.4GHz). Also didn't do anything with the 'disable b' option that showed up after changing it to auto. Connected to the extender fine, albeit the extender's signal is a bit further away, so 74% rather than 100% signal.
Would love to figure out this strange behavior, but it's a low priority...
 
Forget what a WiFi analyzer shows. Test all Control Channels and pick the one with the least issues.
 
Forget what a WiFi analyzer shows. Test all Control Channels and pick the one with the least issues.

Okay, but there are no issues with the wifi on channel 10. The router and extenders are all on channel ten. The Ting device in question, which was stable for the last year and a half I've owned this Asus router can no longer get an IP directly from the router's DHCP, per the logs. Neither device - until this issue - has been in any different location in the house, I've only moved the Ting device a couple of times in trying to remedy this. The Ting device when going through an extender, which delegates DHCP to the router, can get an IP - just not through the router itself directly, which is nonsensical, but there it.

If I were to test all control channels, what tool would you recommend using? I'm not too keen on dropping a couple of grand on a Fluke wifi analyzer!
 
Alrighty, after a good night's sleep and some strong coffee to send a refresh signal through my aging neurons, I did some reading, and I've learned the fascinating fact that I don't know my arse from a whole in the ground when it comes to dealing with the 2.4GHz range. At some point in the past, I conflated 'less interference' with 'fewest AP's on the same channel', instead of 'least _overlap_ of channels with strong signals' - all other things being equal.

So, from just that one snapshot of the wifi analyzer, there's only a small number of AP's, at low signal strength, on channel 11, which has the least overlap. I'll reconfigure accordingly (after doing a longer survey of AP's present and signal strength, as they tend to come and go in the graph depending on whether they're transmitting or not.

Being an expert doesn't mean you can't be wrong. Being a professional doesn't mean you're an expert. Being sloppy in one's research precludes either from obtaining!

It is curious that the Asus chooses channel 10 when set on auto, all that in consideration.
 
I'll wrap this up here, unsolved. Moved to ch 11, as only four other neighboring AP's using it, none better than -75 dBm. Set to only 20 Mhz, protected management frames disabled, wireless mode 'auto'. All devices around the house that are on the 2.4 GHz band happily chugging along. Ting device never gets a delegated IP directly from the router. Connected to either the TP-Link RE550X extender or even the TP-Link Re450 guest network - both of which pass through the DHCP to the router - no problem getting an IP.
Completely bizarre that it just stopped doing so, no evidence that it's blocked in any way, so the mystery will just have to stay that way.

Thanks again for the answers here, definitely put me on the path to a better understanding of the many variables at play.
 
Interesting. I've had a similar problem with some sort of a "smart" device not being able to get a connection/IP address. A device identified by its MAC address as Tuya Smart was trying to connect to the 2.4 GHz band and repeatedly logging associate/disassociate. Could be called log spam. Knowing the MAC address I checked all the WIFI devices in the house but nothing operating had that MAC. I blocked it in Wireless MAC Filter which stopped the log spam and no one has complained their device stopped working.

Interesting that you have a device that detected a loose neutral. Several years ago I got a call from an Uncle who lived in Oklahoma City. They had returned home from an extended stay at the beach. He said some of their lights in the house would not turn on until they turned on the stove. I asked him if it had rained recently in OKC. He could not understand what that would have to do with an electrical problem but said no, it had not rained in quite a while. I told him to call the power company and tell them he had a loose neutral. I further explained the no rain issue was the ground was dry and the system ground rod was not doing its job. He was a good guy but we lost him during the COVID pandemic.
 
My Ting will cycle through a period of disconnections and I narrowed it down to either advanced 2.4G features or forcing DoT. If you read the Ting help, it states required 443 and 80 TCP connections along with 9500 and 9503 UDP. I noticed several UNREPLIED after plugging it in and authenticating but these were a false herring for me, tested port triggering, forwarding, and DMZ - still disconnects.

My Ting is on the first 2.4GHz guest network with three other IoT devices, one notoriously fickle device is the PurpleAir, and mine was more stable the the Ting. Again, after one or two periods of "settling out" disconnects upon a reboot, I find that it will only occasionally drop and reconnect. Ting will notify you if there are any problems with monitoring on their end - they have not reached out to me yet. I also do not receive anymore "cannot conect" problems when opening the app.

I have 802.11ax enabled on 2.4GHz too, none of the advanced features really but ax capable. I was excited to give TWT a try for my IoT devices and, though the Ting tolerated it, there were still more disconnects than I felt necessary. I can add a screenshot if you're still having difficulties because I know there's minimal info out there after some intense searching.
 
Heh, I gave up on it and took the path of least resistance - just set it up through the extender AP where it happily sits chugging away, not a care in the world. I _have_ had issues with some smart plugs recently, two of them failing in ugly fashion (one 'behind' two UPSes and other on the UPS 'behind' my PC, to monitor total energy used on all my stuff) - just intermittently and randomly doing a quarter second on-off-on, instantly turning off my PC and causing the UPSes to react. I'm about to give up on all eight of the Emporia smart plugs I have deployed.

I turned off 802.11ax, since the only devices that use the 2.4GHz network are IoT devices and such which simply don't need any meaningful bandwidth.

All these modern conveniences of life, driving me batty.
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top