What's new

USBIP host on TUF-AX5400

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
Hi there,

can someone please help me to bring "usbip-host" driver working on TUF-AX5400.
of course, I know that the device is not supported yet but since from kernel perspective it is the same as
already supported AX-58U I'd expect to just add required kernel modules.. but, actually, I've run into some issues :)

what I did:

- on top of stock firmware I've added entware and have installed usbip-common package to get userspace binaries
- have cloned "https://github.com/RMerl/asuswrt-merlin.ng.git" repo, setup build VM, configured building of 58U device by using `tools/build-all` script
- changed kernel config in `release/src-rt-5.02axhnd.675x/kernel/linux-4.1/config_base.6a.6750`, add/change options

-# CONFIG_USBIP_CORE is not set

- then uploaded 2 kernel modules to the device and inserted both (`/opt` - directory where entware installed)
insmod /opt/lib/modules/4.1.52/extra/usbip-core.ko
insmod /opt/lib/modules/4.1.52/extra/usbip-host.ko

finally I got an error when binding device to usbip-host driver

# usbip list -l
Local USB devices
- busid 2-1 (05e3:0612)
2-1:1.0 -> hub

- busid 2-1.1 (0951:1666)
2-1.1:1.0 -> usb-storage

- busid 3-1 (05e3:0610)
3-1:1.0 -> hub

- busid 3-1.4 (0cf3:7015)
3-1.4:1.0 -> unknown

# usbip -d bind -b 3-1.4
usbip: debug: usbip.c:134:[run_command] running command: `bind'
usbip: debug: usbip_bind.c:162:[unbind_other] 3-1.4:1.0 -> unknown
usbip: debug: utils.c:65:[modify_match_busid] write "add 3-1.4" to /sys/bus/usb/drivers/usbip-host/match_busid
usbip: debug: usbip_bind.c:101:[bind_usbip] bind driver at 3-1.4:1.0 failed
usbip: error: could not bind device to usbip-host
usbip: debug: utils.c:65:[modify_match_busid] write "del 3-1.4" to /sys/bus/usb/drivers/usbip-host/match_busid

I also have tried to backport actual usbip driver sources from Linux master but the issue remains the same.
It looks the bus driver doesn't call "probe" handler.

so, the question is - is there any way to boot the device with custom kernel compiled with additional debug?
I'd prefer to keep using stock firmware but if there is a way how to flash custom firmware and then revert
back to stock it also would be ok.

thanks in advance
did you try compiling these too?


im trying to do the same thing on an at-rx3000
If anybody is able to make this work then please let us know... I too tried to compile usbip modules and succeeded to the same point than OP, but also got the same error: could not bind device to usbip-host. Commercial VirtualHere works just fine and sharing BLE donge over ethernet to Home Assistant server works well, but their licensing model is too harsh for me to buy a license...

Other modules like cp210x do work just fine and am able to run zigbee2mqtt on router so compile environment seems to be ok...

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!