vlan tagging on aimesh node

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

collider

New Around Here
new merlin firmware supports one 2.4GHz and one 5GHz guest WiFi sync to aimesh node. This is a great feature. But looks like copy the vlan tag script to aimesh node doesn't work properly. Any idea?
 

L&LD

Part of the Furniture
What router? Which specific firmware?

What have you tried, what 'almost' works, in your testing?

Have you looked into @Jack Yaz's YazFi script? Others?
 

collider

New Around Here
What router? Which specific firmware?

What have you tried, what 'almost' works, in your testing?

Have you looked into @Jack Yaz's YazFi script? Others?
I have two AC 68U. One is configured in AP mode (A). The other is aimesh node (B). Two of them are on 386.1 beta5. The following code works on the A with all correct vlan tag when connect to the corresponding guest SSID. first 2.4GHz SSID -> vlan 9, second 2.4GHz SSID -> vlan 11, first 5GHz SSID -> vlan 13.

Code:
robocfg vlans reset vlan 1 ports "0 1 2 3 4 5t" vlan 9 ports "0t 5t" vlan 11 ports "0t 5t" vlan 13 ports "0t 5t"
vconfig add eth0 9
ifconfig vlan9 up
vconfig add eth0 11
ifconfig vlan11 up
vconfig add eth0 13
ifconfig vlan13 up
brctl delif br0 wl0.1
brctl delif br0 wl1.1
brctl delif br0 wl0.2
brctl addbr br1
brctl addif br1 wl0.1
brctl addif br1 vlan9
ifconfig br1 up
brctl addbr br2
brctl addif br2 wl1.1
brctl addif br2 vlan11
ifconfig br2 up
brctl addbr br3
brctl addif br3 wl0.2
brctl addif br3 vlan13
ifconfig br3 up
nvram set lan_ifnames="vlan1 eth1 eth2"
nvram set lan_ifname="br0"
nvram set lan1_ifnames="vlan3 wl0.1"
nvram set lan1_ifname="br1"
nvram set lan2_ifnames="vlan11 wl1.1"
nvram set lan2_ifname="br2"
nvram set lan3_ifnames="vlan13 wl0.2"
nvram set lan3_ifname="br3"
killall eapd
eapd

With the new sync feature, B broadcasts first 2.4GHz and 5GHz SSID (seems it only supports one 2.4GHz and one 5GHz guest network). But when connect to B, no vlan id is tagged. I copied the above code to B and enabled the script in nvram. after reboot, B will never connect to A.

After reset, I tried a simple version as following. This time, B connects to A, and I can see all the SSID broadcasting from B. But can't connect, always complain password is not right

Code:
robocfg vlans reset vlan 1 ports "0 1 2 3 4 5t" vlan 9 ports "0t 5t"

vconfig add eth0 9
ifconfig vlan9 up

brctl delif br0 wl0.1

brctl addbr br1
brctl addif br1 wl0.1
brctl addif br1 vlan9
ifconfig br1 up

nvram set lan_ifnames="vlan1 eth1 eth2"
nvram set lan_ifname="br0"
nvram set lan1_ifnames="vlan3 wl0.1"
nvram set lan1_ifname="br1"

killall eapd
eapd
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top