WAN_Connection: ISP's DHCP did not function properly.

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

bearever

Regular Contributor
Thanks. Tried that last night, but it didn’t help. All that does is reduce the DHCP requests.


I fixed mine by disabling Network Monitoring (both Ping and DNS) and disable WAN down redirect browser notice in Administration / System


Sent from my iPhone using Tapatalk Pro
 

EmeraldDeer

Very Senior Member
Administration > System > Basic Config > Network Monitoring
I use ping to the first hop Comcast router (if you traceroute 1.1.1.1, it will be the first line)
I just want to know if Comcast is online.
By default WAN being up is determined by a DNS lookup. If that fails, then the router goes into a loop of recycles.
 

bbunge

Part of the Furniture
My ISP has a Dhcp lease time of 15 minutes. And my IP address can change several times a day! Agressive Query Mode is a must as well as turning off Network Monitoring.

Sent from my SM-T380 using Tapatalk
 

Allan Marcus

Regular Contributor
thanks folks. I turned off IPTraffic and so far so good. If it doesn't fail for a week, I will turn it back on and see if it fails. If it does, I will disable network monitoring. Unfortunately, it can been a few days between failures, so isolating this issue will take time.
 

Allan Marcus

Regular Contributor
well, it seems the issue in not IPTraffic. It's still happening.
Next I'm going to change network monitoring from ping to DNS query.
Simply toggling the WAN off and on seems to get a DHCP address, so the issue (I'm guessing) is with the ASUS router, not the Netgear modem.
 

Allan Marcus

Regular Contributor
crud. Now i'm in an intersting state. I saw the dreaded message in the log:

Apr 27 08:12:40 rt-ac68u-0230.local WAN_Connection: ISP's DHCP did not function properly.

The internet status shows disconnected in the summary, yet I have an IP address in the detail (crap, I forgot the take a screen shot).

Using "nmram show | grep wan0", the only difference I can see between the router in the odd state, and connected correctly is this var:

wan0_auxstate_t=2
(odd state)

wan0_auxstate_t=0
(correct state)

What does wan0_auxstate_t refer to?
 
Last edited:

Allan Marcus

Regular Contributor
I had comcast come out to check out the line. everything within specs. I contacted Netgear, and they agreed to an RMA on the CM1000 modem, but I suspect there is nothing wrong with it. I replaced the netgear modem with an older motorola modem I have and all was fine until about 15 minutes ago. Same issue. The router give the "ISP's DHCP did not function properly" error and lost its WAN IP address. In fact, as I'm writing this, the same thing just happened! I wrote a script to detect this state (as best I can), and renew the lease. This is really annoying. Any ideas at all?
 

lcasadonte

New Around Here
Allan I'm having the same issue but with a Verizon Fios Quantum router and asus ac68p. I have the fios router in bridge mode so the wan ip is passed to the asus router. In this config, it drops repeatedly all day long right now. I think it has to do with the asus renewing the dhcp lease from verizon and the bridge i am using (quantum). I believe verizon is renewing its lease often but am unsure at the moment. I've played with all the options you mentioned that i had. I am running the merlin fimware and am on a slightly older release. I am not home to upgrade that right now so I don't know if upgrading the firmware will fix the problems.
 

Sean Rhodes

Regular Contributor
Do you have VPN enabled? I followed L&LD’s post and l haven’t had a problem so far.

I’m going to enable a VPN in a couple of days and i’ll See if that’s the issue. So far there is no root cause only speculation unfortunately
 

lcasadonte

New Around Here
I have to be home to flash the router. Just updated my remote location that has the same router but cox for the isp. That was what i had at home and then switched to fios and am using their router in bridge mode. I am itching to flash the router. How long has it been up for you?
 
Last edited:

Sean Rhodes

Regular Contributor
I have to be home to flash the router. Just updated my remote location that has the same router but cox for the isp. That was what i had at home and then switched to fios and am using their router in bridge mode. I am itching to flash the router. How long has it been up for you?
3 weeks without issue and I had one lockup 3 days ago, but none since. I wiped it clean, then went back to stock firmware and ran that for about a week before going back to Merlin. I haven’t setup optware yet either, I left that off and VPN. If after VPN test it still works I will load optware and keep my fingers crossed
 

L&LD

Part of the Furniture
This time, try installing Entware via amtm. :)


See my signature for the link to the amtm Step-by-step guide.
 

Rick D

New Around Here
SOLVED (for me): I had the same issue with comcast and an ASUS RT-N66U. Went through all the trouble shooting with comcast. Called ASUS and, after some testing, they told me the router wasn't compatible with my new Netgear Nighthawk CM1150V cable modem. Called comcast back, and two things were different. First, she said my modem wasn't registered properly (even though the online registration seemed to work and I had internet access if I plugged pc directly into modem). So she did a manual registration. Second, in addition to sending a Restart signal to my modem, she also sent a ping to my modem. Suddenly the error message went away and everything worked. No one else at comcast had sent the ping.
 

RMerlin

Asuswrt-Merlin dev
When dealing with DOCSIS cablemodem, it's important to power down the modem for a good 5-15 minutes whenever you are moving the modem to a different client (be it a different router, or connecting a PC directly to it). Cable providers will generally only provide a single DHCP lease to the first MAC address they see. Leaving the modem powered down for an extended period of time will ensure that the existing MAC will be flushed from their end.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top