WAN_Connection: ISP's DHCP did not function properly.

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

camedia

Occasional Visitor
The "workarounds" I found on forums don't seem to work. I suspect the router is pinging too often and cause the ISP considering it some kind of attack. I have a dual WAN setup. Once I changed network monitoring from Ping to DNS Query, the problem is gone.
 

cplay

Senior Member
Changed dhcp query frequency to normal form aggressive see if that helps it works for me.

That is exactly what I believe has fixed the issue for me.

Have 4g router in bridge mode connected to ac86u, the cell phone towers gives the router a new ip address every 6 hours.

Previously when dhcp frequency was on aggressive the 4g modem the router would always give the error every 6 hours;
ISP's DHCP did not function properly.

Changing dhcp frequency from aggressive to normal appears to have fixed this issue for the past two days at least.
 

cplay

Senior Member
I have changed my configuration to a double NAT scenario where I disabled everything (dhcp, wifi, etc) from the cable modem and forwarded all traffic to my Ac1900.
This has now been running stable for a week now..
It's this bridge mode setup that's trouble. But running double NAT is less than ideal..

Really hope that Merlin or anyone else can figure out what the problem is.
Maybe a more granually settings based WAN dhcp mode? You know a manual setting of the dhcp pool frequency rather than just two settings?

Just diable NAT in the ASUS .

No more double nat and still being protected by nat on modem.
 

solstyce

Occasional Visitor
Likely not related, but if anyone here is using Adaptive QoS and having WAN disconnects due to DHCP renewal failing, check out this post.

I've been struggling with Adaptive QoS for weeks, and just discovered the Asus Adaptive QoS rules were blocking DHCP traffic. Major problem when my DHCP lease is only 10 minutes...
 

vblackman

New Around Here
The only way that I found after several years of use is to connect my old d-link router to one of the providers (dual wan, the second channel works fine) and to it ASUS RT AC66U-B1 with static address
 

zzz

Occasional Visitor
Just bough ASUS RT-AX88U a couple of weeks ago and already had this issue 2 times. Has anyone tried to disable DHCP on provider's router and use static IP intead? I have not found this in this thread.
 

Vexira

Part of the Furniture
Just bough ASUS RT-AX88U a couple of weeks ago and already had this issue 2 times. Has anyone tried to disable DHCP on provider's router and use static IP intead? I have not found this in this thread.
What kind of connection, on mine I'm using a third party router in bridge mode I'm running VDSL 2
 

zzz

Occasional Visitor
What kind of connection, on mine I'm using a third party router in bridge mode I'm running VDSL 2
If ISP's modem/router is running in bridge mode it is not possible of course.
In my case ISP's modem/router (fiber optic line) is running in router mode so I can handle DHCP to my LAN. I will change the settings today and will monitor. I will post the results after 1-2 weeks of testing.
 

ApexRon

Very Senior Member
Just bough ASUS RT-AX88U a couple of weeks ago and already had this issue 2 times. Has anyone tried to disable DHCP on provider's router and use static IP intead? I have not found this in this thread.
Don’t disable DHCP unless you are paying for static IP address. Go to WAN settings and make sure DHCP query frequency is set to normal.
PNG image.png
 

zzz

Occasional Visitor
Don’t disable DHCP unless you are paying for static IP address. Go to WAN settings and make sure DHCP query frequency is set to normal.
I am afraid there is a misunderstanding here.
As I am using 2 routers (one is ISP's and the other one is my Asus) I actually have 3 DHCPs enabled:
1) From ISP to ISP router
2) From ISP router to my Asus
3) From my Asus to my client devices.
You are talking about DHCP 1) above. I am not using static Internet IP and I do not do any changes here.
I am changing the setup of 2) above. I have excluded my Asus IP from DHCP range on ISP's router and made it static on Asus router. So basically I disabled DHCP on my Asus facing to ISP router. That is where the problem seems to be.
DHCP 3) above was not changed as well.

Sorry for a bit messy explanation but could not do it simpler )
Actually I have already made the change. So far so good but as I had this issue approximately once a week I need at least 1-2 weeks to wait until I can estimate the result.
 

ApexRon

Very Senior Member
2) From ISP router to my Asus
Definitely static on ASUS to ISP router.

For my home network I have devices that use DHCP and others with static but I don’t setup static on ASUS for those devices. Devices with static are those devices that never leave home.
 

zzz

Occasional Visitor
So, 10 days passed since I did the change and the issues did not re-appear. Hope it is resolved in my case though I will continue monitoring.

To explain better what was done I have drawn the diagram which I attach here.
Some explanations to it.

First, I want to emphasize that the below is true ONLY for the case when ISP’s device at your home is running in ROUTER mode (and not as a bridge).

Having said that you will have 3 DHCP instances (Server-Clients) on the way from ISP to your home end clients:

DHCP1 – ISP issues IP address and ISP’s router gets it on WAN interface
DHCP2 – ISP’s router issues IP address and your Asus router gets it on its WAN interface
DHCP3 – your Asus router issues multiple IP addresses and your clients get them (laptop, phone, TV, etc.)

Error “ISP's DHCP did not function properly” which we discuss here is happening on WAN interface of your Asus router which is “DHCP2 Client” on this diagram and I put it into red circle.

For some reason Asus router cannot renew the IP address in its WAN interface (though other devices on this segment in my case can do it) which means that DHCP2 Client is not functioning properly.

If that is so, let us not use this faulty client and instead assign static IP address here which I did.
So, you login to your Asus router, go to WAN tab and choose “WAN Connection Type” = “Static IP”.
Upon completion you will get new section “WAN IP Setting”. Provide IP Address, Subnet Mask and Default Gateway settings here. Once done, exclude this IP address from the distribution range of DHCP2 Server (you need access to ISP’s router for this).

Hope, my experience will be of some help to others.

Asus_error.png
 

Zamana

New Around Here
(...)
For some reason Asus router cannot renew the IP address in its WAN interface (though other devices on this segment in my case can do it) which means that DHCP2 Client is not functioning properly.

If that is so, let us not use this faulty client and instead assign static IP address here which I did.
(...)

Does anybody know if the ASUSWRT-MERLIN firmware's developers are aware of this?
 

Zonkd

Very Senior Member
Does anybody know if the ASUSWRT-MERLIN firmware's developers are aware of this?
Yes they are all aware of it. There is no official guaranteed fix and I doubt one is coming. I don’t think they identified the precise cause. Some people report the issue disappeared after changing one setting or another, such as changing dhcp from aggressive to normal or continuous mode. They’re lucky. I’ve tried everything and nothing has worked. The problem always returns. I wrote a script which runs every minute to ping google and if ping fails restarts the WAN interface.
 

Zamana

New Around Here
Hi.

Well... in my case the normal was already configured, so it doesn't seem the culprit.

What I realize was that, at some point, I clicked that "Mac Clone", and my router started to use the MAC address of my notebook. I want to believe that somethng done on my notebook was affecting the communication between my main router and the ISP's router (bridge mode).

After remove the cloned MAC, my router seems to be ok now.

Let's see.

Thanks.
Regards.
 
Last edited:

RamGuy

Senior Member
So, 10 days passed since I did the change and the issues did not re-appear. Hope it is resolved in my case though I will continue monitoring.

To explain better what was done I have drawn the diagram which I attach here.
Some explanations to it.

First, I want to emphasize that the below is true ONLY for the case when ISP’s device at your home is running in ROUTER mode (and not as a bridge).

Having said that you will have 3 DHCP instances (Server-Clients) on the way from ISP to your home end clients:

DHCP1 – ISP issues IP address and ISP’s router gets it on WAN interface
DHCP2 – ISP’s router issues IP address and your Asus router gets it on its WAN interface
DHCP3 – your Asus router issues multiple IP addresses and your clients get them (laptop, phone, TV, etc.)

Error “ISP's DHCP did not function properly” which we discuss here is happening on WAN interface of your Asus router which is “DHCP2 Client” on this diagram and I put it into red circle.

For some reason Asus router cannot renew the IP address in its WAN interface (though other devices on this segment in my case can do it) which means that DHCP2 Client is not functioning properly.

If that is so, let us not use this faulty client and instead assign static IP address here which I did.
So, you login to your Asus router, go to WAN tab and choose “WAN Connection Type” = “Static IP”.
Upon completion you will get new section “WAN IP Setting”. Provide IP Address, Subnet Mask and Default Gateway settings here. Once done, exclude this IP address from the distribution range of DHCP2 Server (you need access to ISP’s router for this).

Hope, my experience will be of some help to others.

View attachment 26242


Why would you want to run your network like this? Double-NAT is never a good solution. You should have the least amount of network address translations as possible. Doesn't your ISP router feature any kind of bridge mode?
 

Rguiher

New Around Here
No idea if this will apply to any of you, but just find a major clue for my problem...

Tldr; my isp must have changed the dhcp lease to a shorter expiration, but my Asus still had a longer expiration despite reboots of both cable modem and router.

Couldn't figure out why I was getting multiple disconnects per day all of a sudden, with all the symptoms described in this thread. Lease was showing as 20 hours, but would disconnect multiple times per day. Somehow I had a value in the Mac clone field, though I don't remember ever setting it. Maybe a result of firmware upgrade without a factory reset? Don't know...

Anyway, when I removed it and rebooted both I saw that not only had I gotten a new ip address, the lease had been changed to only 1 hour!!!! So, my hypothesis is that the isp changed a policy, and either the cable modem or the Asus somehow got the old lease time stuck. The server thought the lease had expired, but the router didn't, so it kept throwing this error. We'll see if this fixes it, but it makes a bunch of sense given that I went from perfectly stable to multiple disconnects overnight with no changes on my end and no errors in the log.

Btw, Asus doc says continuous mode (which I haven't set yet) queries at 12hz, so realize you're sending 12 requests per second if you switch to that.
 

Kanji-San

Regular Contributor
Btw, Asus doc says continuous mode (which I haven't set yet) queries at 12hz, so realize you're sending 12 requests per second if you switch to that.
The documentation is wrong. It's 12 requests per minute, one every 5 seconds. This means it's 0.2Hz.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top