What's new

WD Sharespace, the NAS you DO NOT want to rely on.

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
I recently purchased a WD Sharespace NAS with a whopping 4TB of RAID 5 storage, given the size of the files from my newly acquired Beyonwiz I figured an off-pc store would be ideal. Three weeks into service one of the HDD's failed and the RAID continued to perform in "degraded" mode pending the defective drive being replaced. After several emails to and from WD support (staffed by Kindergarden dropouts) in which they were/are clearly on their own learning curve, I finally reinstalled my brand new HDD into the unit and performed a recovery in accordance with the WD tech support instructions - the unit recovered the full RAID array and presented me with a fully restored and ready to go unit sans data.!!! That's right, if you have a drive failure and then replace the drive the unit will restore the datastore to the factory state - blank! The unit deletes all user created shares as part of the recovery process, so if you have created a custome share or folder and placed data in it, then backup first, because the idiotic WD coding will zap everything. The point of RAID is redundancy, but not if its a Western Digital, they have their own idea of what the RAID5 specification is all about, there you go - backup your redunant device - what is the point (I think the concept is lost on the boffins at Western Digital)

Bottom Line: If you value your data - do not use Western Digital.

Looks like the official response from Western Digital is to hide and say nothing. A great way to treat a customer that has just spent over $1000+ on their product.

Lab test: To be sure it wasn't me, I have just finished trying to repeat the error by reinstalling the drive, syncing and then creating shares "Upload" and "Cabinet" - I populated the shares with a few hundred meg of files and pulled drive #3. The NAS then dropped into "degraded mode", I reinstalled the drive (after formatting) and then selected the "clear drive" option from the NAS control interface, the drive then presented as "new", I then re-synced as per the instruction from the WD support team, and hey presto - exactly the same result, a perfectly clean and blank drive, all shares deleted by the OS.

DUMB, DUMB, DUMB - Bad Firmware, Bad Coding. Violation of the RAID-5 specification (see re-sync).

I doubt WD will ever formally respond, but steer clear of this unit if you need a truly redundant NAS, get something else.
Thanks for the post.

I am asking WD for comment on your findings. I'll let you know what I find out.
Sounds like WD decided to beta test with the public. Nice!! This is exactly why I'm not an early adopter!! I've been burned too many times.

Sorry to hear about your WD disaster. While I can understand your concern, I'm quite sure WD will fix something as severe as this. probably sooner than later.
thiggins: Thanks for the response. Forgive my cynicism but dont hold your breath. I just got a note back from WD support letting me know that my issue has been escalated to WD in the US office for further review and I may expect to hear in a few days as it is thanksgiving holidays right now and they will response after the festivities. Fortunately all WD Raid-5 units are pre-programmed not to fail during thanksgiving so my data will remain safe for now.:confused:

It seems this may not be the first time this type of problem has surfaced on this site: I re-read an article by TIm Higgins at this url:
and it appears Tim had a similar issue that required additional undocumented support from WD. Tim doesn't say if he actually tested the late advice from WD on inserting a clean-new drive to overcome his initial difficulty, however I can confidently say it would not have made a scrap of difference. Tim's data would be lost. He may wish to update his review.

Another point: The undocumented assistance from WD that Tim refers to in his article is still undocumented. You'd think that if WD were even slightly customer focussed, they'd update the WD KB with a post addressing how to replace a failed drive in a WD SS NAS RAID-5. Well they have not. Maybe WD think that Tim is the only person in the whole world that will suffer a HDD failure in a NAS unit? Silly boys and girls at WD aren't they.

claykin, Thanks for your response: You said "While I can understand your concern, I'm quite sure WD will fix something as severe as this. probably sooner than later." I'd love to agree, but I am not so sure and dont share your confidence. Apart from the above comments that put WD in a certain box concerning customer focus, WD recently removed the user feedback forums from their support site because users were voicing too many negative comments and flaming WD.!!! Now, if that isn't stuffing your head in the sand I don't know what is. Hey WD guys - the user community is giving you feedback and railing your quality for a reason. I doubt the quality is any better or worse than most other offerring from your competitors, the difference is that your technical support and consumer management systems are woeful.

I feel that WD technical management suffer from primadonna syndrome, the conceit is palpable. Do WD actually believe there is nothing to be learned from the user community? It's bad enough that we are treated as guinea pigs, it's something else to be then treated as idiots and somewhat ignored. I have offerred suggestions for updated FW and front end features - silence is the response, at least have the strength to tell me I'm off the rails if you dont like my ideas! Better still, have the strength to recognise that if your product is less than ideal, to accept constructive criticism and improve, before the constructive criticism becomes negative. (Consumer Managment 101)

McDonalds has better systems for dealing with bad fries.
Last edited:
Well, if you really have such little confidence (and maybe I can't blame you) its best to take the bull by the horns and see what dirt you can stir up.

Below is WD's corporate office info. Ask for John Coyne, its CEO and President. I shouldn't have to tell you that you get a lot further with honey than fire.

BTW, if they won't connect you, ask for the President's office or their escalation team. Tell them you've worn out all support options.

Good luck to ya!

Corporate Headquarters
Western Digital
20511 Lake Forest Drive
Lake Forest, CA 92630-7741
Phone: 949.672.7000
Toll Free: 888.935.8893
FAX: 949.672.5408
Here is the latest from WD on this issue...

I wanted to take a moment and thank you for bringing this to our attention. We have created a new knowledge base article that will be release in the next 1 to 2 business days addressing this issue.
Update from WD.

They have finally posted a "fix" on the WD KnowledgeBase.

Sadly it's wrong. What WD do not tell you is that the unit will now boot into a completely pointless UI blank white screen, with a small green dot in the corner, and the words "Starting up" in the middle of the screen. Somehow, you are supposed to understand that the unit is actually doing something.

This is what the screen should say:
Progress Xxxxxxxxxxxxxxxxxxxxxxxxxxx

Hello there user, the system has detected a new drive has been installed and is now re-syncing the RAID-5 array. The useless green dot you see in the top corner is actually a progress bar, that will slowly grow across the screen as the RAID array rebuilds. Please do not interrupt this process.

If you are rebuilding a large array this may take up to 16 hours before the dot becomes a line, patience little one :)

This is what is does say:

Starting up...

Did you find the green dot?

All of the above is not documented and the update in the KB is next-to-useless, I have informed WD of this, it seems the update to the KB may take another week to fix. The quality assurance and sanity checking process at WD don't seem to extend to the KB support group (sadness)....
Did you use a WD drive as the replacement drive?

Aside from not informing you as to the progress of the rebuild, if you replace the drive and wait, does the array successfully rebuild?
It sounds like your unit does not have a fault, aside from the piss poor rebuild screen that WD provides??

The Sharespace appears to have some LED's on the front panel. What were they telling you during the rebuild?
Remote Access to WD NetCenter

I own a WD NetCenter and want to remote access it outside of my network. It has been designed more as just an external hard drive that can share folders and files within your network. It is not equipped with any sort of additional software for remote access and the only file that was on the NetCenter when I bought it was the default .html file, which is used as the admin settings page. However, you can not see the shared folders or their files from this area. I was wondering if there was a way to add html code to the .html file or add an additional file to be able the view the shared folders and files. I have already assigned a static IP address to the NetCenter and opened the port on my router, and can actually access the admin settings page from outside my network, but as I said, I can’t view the shared folders and files from this page. If anyone has any ideas it would be appreciated. Thanks.
Thats not the only thing that is broken. It seems Active directory support doesnt quite work either. It "joins" the domain, but there is no way to specify users or groups from the AD for permissions.
Hi Guys,

I'm selling a Western Digital ShareSpace 2TB 4-Bay NAS Raid on ebay

I've had a question asked of me to which I don't know the answer.. Can someone help??

Q: "hello will this work with 4 WD 2tb hard drives or with just the 1tb hard driver and is it sata hd it work with thanks"

Thanks guys!!

Hi Guys,
Q: "hello will this work with 4 WD 2tb hard drives or with just the 1tb hard driver and is it sata hd it work with thanks"

It is SATA II (and I).

About size: I'm wondering abouth the same thing.

1. Can I put 1.5 TB or 2 TB WD disks in the ShareSpace NAS (and exceed the "4 TB")?
2. If yes, do the disks have to be of same size? Even in a two RAID1 volume configuration?

Thanks for a very interesting review!

Rune, Norway
Firmware update with MBW (White) features

I own one of the ShareSpace for about a month now and was disappointed to see it doesn't support AFP and HFS+ even though they claim on their website it works with Mac OS X, well it does, but not 100%.

I just read the review of the MBW (White) edition and it seems this one has the same firmware loaded but with some additional features (AFP, HFS+ & SSH access) i would be really interested in.

I emailed WD and ask if those features would be coming to the Sharespace but haven't gotten any reply from them (couple of days now).

Have the users on this forum any insight if this might or might not happen in the near future? It would seem to be a straight forward thing to update the ShareSpace firmware, but not sure if there are any technical limitation due to the different hardware?

Many thanks!
WD ShareSpace not usable with DLNA applications

Few weeks ago I got my brand new 2TB ShareSpace box which is foreseen to store all my media files (video, photo, music). My decision was driven by the need of a reliable archiving system (RAID-based) and a DLNA media server capability.

One having installed the box (I had to upgrade to the latest firmware 2.1.3 first and set-up RAID 1), I copied all my media data onto the box. Media playback with my Samsung TV LA40B650 worked fine for 3 days ... until twonky media server on the WD box seems to quit it's service and even worse overwriting WD config and operating files (at least my guess).
Since then no access to WD ShareSpace was possible - even reset and support did not help.

I decided to return the box for advanced replacement. After one week I got a brand new box (now 4TB) with fw-version 2.1.3 already pre-installed.

But installing my media data and operating the box with DLNA caused the same damage after a few days. I can not access my data nor the config-portal of the box any more !!!

Several call to WD support are indicating a systemic problem on WD ShareSpace.
My eMail requests to WD headquarter / support are not answered since 2 weeks.

Thus im considering to return the box to my dealer for a credit voucher.
But what to buy ??? Buffalo, Linux based PC system + SW RAID + DLNA server.
what a heap of garbage

I am truly disappointed in my 4TB Sharespace that I recently purchased.
1. Would not perform firmware upgrade
2. Can't access your files unless you screw around with the settings and change them from one setting back to Share
3. Drives constantly lost volumes after transferring data to them
4. Technical Support ís terrible. Your write EXACTLY what is wrong and send descriptions and tere email system deletes the attachments and then you are asked the same questions that you have already detailed in emails..
5. Try getting throught to Technical support(in my case Singapore) what a joke....

Overall, this is my 2nd WD device, the other one was a Worldbook 1TB, that also crashed and no one can work out WHY..

I am sorry but I thought that WD had finally got there act together, obviously NOT
Active Directory authentication

Hello guys.

All these negative experiences don’t sound any good at all. I really thought that WD was a serious, respected company producing high quality storage equipment. After purchased a WD ShareSpace 4TB RAID 5 NAS, I’m not so sure anymore...

I've now used hours trying to get the Active Directory integration / user authentication to function. The AD-integration itself seems to work, - the unit register in AD but I have to manually register it in DNS. About the user authentication, I successfully manage to access one of my custom data shares using UNC-path in Windows Explorer and copy data to and from the unit, but I am NOT ABLE TO DELETE or RENAME any files on my custom made data shares. (If I i.e. try to delete a Word-file, it’s just saying “Access denied” and the file copies itself into some kind of temp file.) Pretty weird! (Of course I have assigned myself “Full access” to the actual share.) Anyone else then JOSHB experienced issued with the AD-integration and user authentication?
WD SharePace --> NEVER AGAIN

We used the WD sharespace (4TB) for some time now. The ADS did not work properly (groups like domain Admins were not selectable) and we i asked about this they told me it was only for small workgroups????

With some work-arounds it worked. This morning i did a firmware update ( and again problems with security. I reconnect to the domain controller and now it seems that the problems we had before are solved....

The next NAS i buy will not be a WD, but a Qnap/Thecus/Readynas. The price is higher, but they work (fast)
WD Sharespace

Hi guys,

I've had similar problems with this unit, currently I have no way of accessing the Web interface as there seems to have been some error with the configuration files the error message I get is:

XML error: no wixnas object found!

I can see the data on my folder shares and can access the twonky media server, but can't get to WDSharespace interface. After backing up all my data (and waiting for over a week for a response from WD) I decided that I would try a soft reset in case this cleared the problem (along with clearing the media server database etc etc...) the problem persists (the 3rdand most terminal I've had since I got the box 8 months ago in January 2009) - . I think this is probably something VERY simple since the unit for the most part seems funtional - with no loss of data - I just can't find a way to reset the user interface.

Anyway - Thought I'd add this post here to warn folks that from everything that I've learned you REALLY need to get the most up to data firmware, and not demand too much from this unit for the time being - my impression is that the problems all relate to poorly thought out firmware. rather than the hardware (which as far as i can see is solid)

PS - Any suggestions to help fix my problem more than welcome!! :eek:)

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!