1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

WOWLAN re-revisited... router reboot wakes computer via AC 3168 wireless card.

Discussion in 'Asuswrt-Merlin' started by 000111, Feb 22, 2019.

  1. 000111

    000111 Senior Member

    Joined:
    Apr 1, 2014
    Messages:
    469
    Location:
    Florida
    I come back to WOWLAN once in awhile hoping I can get it working. It works perfectly, perhaps too well since it keeps unintentionally waking up from two things-

    1) GTK rekeying (I mitigate this issue by changing the GTK rekey interval on the router since my AC 3168 wireless card does not seem to be able to GTK rekey without waking despite settings that suggest otherwise).

    2) Router reboot causes the computer to wake up via WOWLAN (this is may also occur because of a GTK rekey event during rebooting that the wireless card is not able to sleep through).

    I ask this question here because I thought some of you may be able to hypothesize what is happening when the router reboots-

    Is it really a GTK rekey type of event that is causing the computer to wake from WOWLAN when it reboots? Or is there some other process during rebooting the router that might be waking the card?

    Maybe I need to pull another switch or setting to get the wireless card to sleep through a GTK rekey event- could there be some sort of OS dependencies or advanced settings in the card that are needed?

    Under the AC 3168 wireless card settings I have-

    under advanced settings:

    GTK rekeying for WoWLAN Enabled
    NS offload for WoWLAN Enabled
    Sleep on WoWLAN Disconnect Disabled
    Wake on Magic Packet Enabled
    Wake on Pattern Match Disabled

    under power management:
    Allow the computer to turn off this device checked
    Allow this device to wake the computer checked
    Only allow a magic packet to wake the computer checked
     
    Last edited: Feb 22, 2019