AC86U on 386.2 cpu load with adaptive qos

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Michael Schäfer

Occasional Visitor
Hi,

I've noticed that the cpu load (with download traffic) is extremly high with the bcmsw_rx process basically using one core all the time. Disabling QoS and restarting the device solves the issue. This did not happen with the 384.x version I was using earlier. I've also disabled AIProtection, but that had no impact at all.

Any ideas except not using either QoS or 386 firmware?
 

Adooni

Regular Contributor
in 386 changelog for example
- REMOVED: fq_codel support for Adaptive QoS. Due to a change in how Trend Micro configures QoS, it is no longer possible to intercept these to inject fq_codel.

I am still using it as this is still possible via amtm and FlexQoS

check if in Tools - HW acceleration is still enabled (if not LAN - switch control - NAT Acceleration is auto and reboot).
 

Michael Schäfer

Occasional Visitor
Thank you, this sheds some light on it. I tried using FlexQoS, I assume you ment that it is possible to switch to ASUS instead of using fq_codel? Sadly it didn't change a thing, neither after installing FlexQoS nor after changing.

I do have hardware acceleration.
 

Michael Schäfer

Occasional Visitor
You don't need QoS on Gigabit ISP line.
I am a bit lost for words, to be honest. Lets just put it this way, my line may change to something slower again in three month and I'd like to have a working router that doesn't mangle my VoIP calls. Sheesh.
 

Tech9

Very Senior Member
If the router is working properly, what exactly you are trying to fix? With much slower ISP the CPU load will go down. VoIP calls need 50Kbps.
 

CriticJay

Senior Member
You don't need QoS on Gigabit ISP line.

You do if it's assymmetric Gigabit, which is what's commonly made available on DOCSIS 3.1 cable internet providers.

I would agree that FTTH Gigabit, which should be symmetric, shouldn't need QoS.

Relevant post re: my need for FlexQoS / Adaptive QoS on a 1000/30 connection.

With regards to CPU usage on the RT-AC86U with Adaptive QoS enabled during 1000mbps downloads - no issues. Peak CPU usage hitting 70%, average is usually 50 to 60%. on firmware 386.2_6
 

Tech9

Very Senior Member
You do if it's assymmetric Gigabit

You may need it in some cases, if someone on your LAN is downloading/uploading torrents with bandwidth unrestricted client. I have 500/30 cable and QoS enabled/disabled doesn't make any difference. A family of 4 with >1TB monthly traffic. I do download some Linux distros from time to time with restricted upload and it doesn't affect anyone's VoIP, Teams etc. work/learn from home things. My main point is different though - CPU load is no concern if the router is working properly.
 

CriticJay

Senior Member
You may need it in some cases, if someone on your LAN is downloading/uploading torrents with bandwidth unrestricted client.

Right, for many of us we have use cases where we don't have the ability (or can't be bothered) with ensuring our clients are appropriately bandwidth-limiting their bandwidth-hogging applications. It need not only be bittorrent, I can think of a few other applications which fall into the same boat.
 

Michael Schäfer

Occasional Visitor
You do if it's assymmetric Gigabit, which is what's commonly made available on DOCSIS 3.1 cable internet providers.

I would agree that FTTH Gigabit, which should be symmetric, shouldn't need QoS.

Relevant post re: my need for FlexQoS / Adaptive QoS on a 1000/30 connection.

With regards to CPU usage on the RT-AC86U with Adaptive QoS enabled during 1000mbps downloads - no issues. Peak CPU usage hitting 70%, average is usually 50 to 60%. on firmware 386.2_6

I've tried FlexQoS but it didn't work much better, it may need some tuning, but the charm of the AdaptiveQoS was that it worked fine without a significant amount of time spent. I will probably just downgrade the firmware if I cannot solve the issue by other means (i.e. do not download while on the phone).

Beside that I am simply tired of the way this thread developed and will delete it soon.
 

dave14305

Part of the Furniture
Beside that I am simply tired of the way this thread developed and will delete it soon.
Perhaps if you clarify the original post a bit you might get better responses.

My questions:
  1. What is the maximum download speed you can achieve with Adaptive QoS on and the bcmsw_rx using a lot of CPU? is the CPU usage impeding your throughput at all?
  2. Does the CPU utilization subside when the router is idle?
If you’re getting your full throughput, but you don’t like the CPU usage required in 386 to achieve it, there isn’t much to be done. Downgrading is a bad idea due to security fixes that won’t exist in 384 firmware.

On my AC86U I can download about 480Mbps (ISP speed) and the bcmsw_rx CPU only reaches about 30% max and then drops (watch with top -d1).
 

Michael Schäfer

Occasional Visitor
Perhaps if you clarify the original post a bit you might get better responses.

My questions:
  1. What is the maximum download speed you can achieve with Adaptive QoS on and the bcmsw_rx using a lot of CPU? is the CPU usage impeding your throughput at all?
  2. Does the CPU utilization subside when the router is idle?
If you’re getting your full throughput, but you don’t like the CPU usage required in 386 to achieve it, there isn’t much to be done. Downgrading is a bad idea due to security fixes that won’t exist in 384 firmware.

On my AC86U I can download about 480Mbps (ISP speed) and the bcmsw_rx CPU only reaches about 30% max and then drops (watch with top -d1).

There is not much to clarify. CPU load is constantly 50%, but one core is running at 80-95% with just one steam download active, nothing else. Performance is ok, but the router is not very responsive to anything else, including the web ui. The CPU usage is ok when idle.

It used to be different with the earlier firmware, which was the reason I asked.
 

goncalossilva

Occasional Visitor
I'm having the same problem on my RT-AC68U on Merlin 386.2_6 and FlexQoS v1.2.5.

My connection is 500/100. Some scenarious:
- No QoS, speedtest shows 510/120
- Adaptive QoS + FlexQoS, speedtest shows 180/110 w/ CPU pegged at 100%
- Adaptive QoS only (i.e., FlexQoS disabled), speedtest shows 450/110 w/ CPU at 75%

To note, Hardware acceleration is "Enabled" in Tools > Sysinfo, and NAT Acceleration is "Auto" + "CTF (Cut Through Forwarding) is enabled." in LAN > Switch Control. No traffic analysis or "ai features" are enabled.

I've changed a few settings, like:
  • Clearing the list of rules, no change
  • Using ASUS instead of fq_codel, speedtest drops further to ~165/110
  • Disabling NAT Acceleration entirely, no change
So it seems that disabling FlexQoS is the only way to get things working as intended... except I want to use FlexQoS. Any advice?
 

Attachments

  • Screenshot 2021-06-25 at 02.24.07.png
    Screenshot 2021-06-25 at 02.24.07.png
    437.5 KB · Views: 23
  • Screenshot 2021-06-25 at 02.25.23.png
    Screenshot 2021-06-25 at 02.25.23.png
    473.3 KB · Views: 24
Last edited:

L&LD

Part of the Furniture

dave14305

Part of the Furniture
Enabling Adaptive QoS, it drops down to 180/120 with a CPU core pegged to 100% during the entire test.
Disabling FlexQoS via SSH has speedtest at 450/110 with the CPU pegged at 75%
What’s the difference between these two statements? Is FlexQoS enabled in the first case? Is Adaptive QoS still enabled in the second case?
 

Kingp1n

Very Senior Member
I'm having the same problem on my RT-AC68U on Merlin 386.2_6 and FlexQoS v1.2.5.

My connection is 500/100. Disabling QoS, speedtest shows 510/120. Enabling Adaptive QoS, it drops down to 180/120 with a CPU core pegged to 100% during the entire test. Hardware acceleration is "Enabled" in Tools > Sysinfo, and NAT Acceleration is "Auto" + "CTF (Cut Through Forwarding) is enabled." in LAN > Switch Control. No traffic analysis or "ai features" are enabled.

I've changed a few settings, like:
  • Clearing the list of rules -- no change
  • Using ASUS instead of fq_codel -- speedtest drops further to ~165/120
  • Disabling NAT Acceleration entirely -- no change

Disabling FlexQoS via SSH has speedtest at 450/110 with the CPU pegged at 75%, which is basically what I want... except I want to use FlexQoS. Any advice?
With these speeds...doubt you even need QoS.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top