Adding an AIMesh Node - why is this so hard?!?

webreaper

Occasional Visitor
Hi all,

I have an AC86U running Asus Merlin latest firmware (386.9) and an AC68U which I want to set up as an AIMesh node. But I can't get it to work, at all. I've done this before - but had to factory reset the AC68U earlier this week for something else, and now can't restore it as an AIMesh node. Every time I add it, it spins through to 100% and then shows me the 'problem' dialog. Things I've tried:

1. Factory resetting the AC68U
2. Upgrading the AC68U to 386.9 Merlin
3. Reverting to the latest Asus firmware
4. Putting the routers 3m away, or 30cm away

Whatever I do, I simply cannot get the two to connect. It's so infuriating. I don't want to factory reset the AC86U ('master') as it has a bunch of config I don't want to lose etc.

I read somewhere that it's possible/easier to get this to work by connecting the two routers via an ethernet cable, and then doing it over a wired connection. I think the same comment said that Merlin doesn't support AIMesh discovery over wifi. But when I tried that, it didn't seem to work either.

Can anyone give me ELI5 steps to make this work (ideally with a wired connection, if it'll be more reliable)? It's absolutely driving me crazy. Please help!!
 

Yota

Very Senior Member
Check if the 2.4GHz WPS of your RT-AC86U is turned on? Many people turn it off for security reasons, but it will affect the pairing of AiMesh, once you paired, you can turn off the WPS function.
 

mmacedo

Regular Contributor
What I always have to do is disable WAN in the router before connecting the node.
 

Crimliar

Senior Member
Commonly mentioned on these boards is that initial pairing when using Merlin often only works using an ethernet cable between the devices. Once the pairing is complete you can remove the cable!
 

webreaper

Occasional Visitor
Thanks for this. Is there any trick to connecting the ethernet cable - ie the order things are done in, which port to use, etc? Or do you just connect the ethernet, press-and-hold reset to factory reset, then once it's booted up go into the primary router and do 'search'?
 

Crimliar

Senior Member
Using a dedicated mesh-ready AP, it just needs to be reset. If you are using a router/ap then you'll probably want to access it and put it into "Mesh" mode! Everything else should just work!
 

Yota

Very Senior Member
Connect the cable to the LAN port of the main router, and the other end to the WAN port of the node, but even if it is hardwired, you still have to enable the WPS of the main router. This is an option that has tripped me up countless times.
 

mmacedo

Regular Contributor
Before you connect the other end of the cable to the WAN port of the node, disable WAN on the router. Only enable WAN again after the add node process has completed. I've never noticed the need to enable WPS though.

1674598231551.png
 

Crimliar

Senior Member
It may be because I'm using the RP-AX56 (AiMesh capable WiFi extender) now, but when setting up with a cable I've never had to disable either WPS or the WAN port.

*The RP-AX56 works very differently compared to setting up a router as an AiMesh node!
 

Dedel66

Regular Contributor
1. Factory resetting the AC68U
2. Upgrading the AC68U to 386.9 Merlin
3. Reverting to the latest Asus firmware
You have to reset a router or node AFTER flashing a new software.
 

webreaper

Occasional Visitor
Before you connect the other end of the cable to the WAN port of the node, disable WAN on the router. Only enable WAN again after the add node process has completed. I've never noticed the need to enable WPS though.
Thanks. I don't actually have a WAN at the moment (I'm currently waiting for BT OpenReach to provision my broadband, but that's an entirely different conversation!!).
 

lighting

Regular Contributor
Only way I found to do this was to switch temporarily to stock ASUS firmware to set up the mesh network. Then switched back to Merlin.
 

Elmer

Senior Member
I have zero success with initializing aimesh units with ethernet connected. Wireless always works, it just takes patience.
1) factory reset the aimesh unit (power on /w wifi button pressed - some models are different)
2) reset the aimesh unit using the reset button.
3) place the aimesh unit close to the router.
4) from the dashboard on the router click on the aimesh icon, then use the search button that appears. Wait for the wifi lights to illuminate on your aimesh unit (can take a while).
5) Click search and let the search complete and time out, even if it doesn't find the device on the first go. If you try another search before it times out you'll often get the "someone else is ..." message.
6) if it didn't find the device on the first search, do a reset, using the button, before trying again.
7) I'm meshing an ac88, an ac68, and a 1750b. I've never had to do more than two searches to get a connection on any of these devices (I use the latest Asus FW on mesh units).
8) sometimes the intialization process (% complete), will fail. Again, let things time out, do a reset on the mesh unit using the button and try again.
9) Once it announces success, take the aimesh unit where you want it, and now you can install ethernet backhaul if you want (WAN port!). I leave discovery on auto. I've had problems with "use 1G first."
10) Make sure your wireless "roaming assistant" on the professional tab is turned on.
11) Let the system bake for a couple days as it distributes clients.
 

mmacedo

Regular Contributor
In my experience, when I have an unit that I've just reset and I connect a cable with Internet connection to its WAN port, it detects this internet connection and after a few minutes sets itself to router mode. Then you can't add it as a node anymore until you reset it again. This happens even if I had been able to find the unit and started the add node process, so it fails midway.

The solution I found is to disable Internet on the router before connecting the ETH cable to the WAN port of the node to be added. After this node is added to the AiMesh, then you can enable Internet again.
 

mmacedo

Regular Contributor
BTW, I always add the nodes using the wired connection, so I don't have to move them from where they are installed. As they are all currently wired, I have two options, depending on my mood:

a) remove the ETH cable from the node; reset it using the buttons; wait the node to boot up; disable internet; connect the cable to the node; add node; enable internet

or

b) disable internet; reset node either using the buttons or the GUI; wait the node to boot up; add node; enable internet
 

Elmer

Senior Member
BTW, I always add the nodes using the wired connection, so I don't have to move them from where they are installed. As they are all currently wired, I have two options, depending on my mood:

a) remove the ETH cable from the node; reset it using the buttons; wait the node to boot up; disable internet; connect the cable to the node; add node; enable internet

or

b) disable internet; reset node either using the buttons or the GUI; wait the node to boot up; add node; enable internet
We may be talking two different cases here. I'm talking about adding an aimesh unit that has never been discovered. Once a unit has been discovered, then I have also had no problems with reestablishing the aimesh unit without moving it, especially if it has an ethernet backhaul.
 

mmacedo

Regular Contributor
We may be talking two different cases here. I'm talking about adding an aimesh unit that has never been discovered. Once a unit has been discovered, then I have also had no problems with reestablishing the aimesh unit without moving it, especially if it has an ethernet backhaul.
I am talking about an unit that has been reset, so it is as it had never been discovered. Why do I have to do that? After I install a firmware upgrade I reset everything, including the router, to have a clean install. And then I do all the settings manually.
 

webreaper

Occasional Visitor
Okay, so multiple attempts later, and still no success. Can't get it to work via wifi - it always gets to 100% and then shows the error dialog.

If I connect via wired/ethernet when I go to http://192.168.1.1 I get the post-reset setup page of the AIMesh node (AC68U) so I can't go into the AIMesh router (AC86U)'s settings page to search. Any ideas?
 
Last edited:

mmacedo

Regular Contributor
Okay, so multiple attempts later, and still no success. Can't get it to work via wifi - it always gets to 100% and then shows the error dialog.

If I connect via wifi, when I go to http://192.168.1.1 I get the post-reset setup page of the AIMesh node (AC68U) so I can't go into the AIMesh router (AC86U)'s settings page to search. Any ideas?
Are you connecting to the right SSID? You have to connect to the router's SSID, not the node's. BTW, shouldn't it be 192.168.50.1 after a reset? Have you tried it wired instead?
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top