1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Android 9.0 Broke Tethering

Discussion in 'Asuswrt-Merlin' started by dominatorstang, Oct 17, 2019.

  1. dominatorstang

    dominatorstang Occasional Visitor

    Joined:
    Jul 18, 2013
    Messages:
    14
    I have been tethering for years with no problem on an AC56U using a Samsung J7 on Android 7.x.x.
    I then swapped to an LG V30 with Android 8.0.0 and all was still great. I updated to Android 9.0 on the V30 and boom, it no longer works. I then tried my LG G7 with Android 9.0 to see if it worked, but it did not either. I swapped back to the Android 7.x.x phone and it is working again.

    Both Android 9.0 phones tether fine with Windows 10 though... I also read another thread from a couple months ago where Avalenti was having an issue that sounded the same with Samsung phones. I cant be sure if it was exactly the same until I hear back from them though.

    When I say not working, I mean the WAN never gets an IP address. Something also strange is my LG G7 actually makes a phone call almost like a modem as it calls something like *99# and then another time is was like *99***1 or similar.

    I searched high and low on the internet to understand what may have changed in tethering with Android 9.0, but I found little to nothing.

    I also recently got in my new AC86U which I purchased for the hardware specs and to have Merlin updated firmware versions for a few more years since the AC56U no longer is. It responds the same as the AC56U though. Both routers are on the latest FW offered.

    Attached are 2 logs, both from my AC56U and just a snapshot of connecting the tether. One is of the working Android 7.x.x (jpg because the upload was rejecting the txt of it) and the other is of the not working Android 9.0.
     

    Attached Files:

    Vexira likes this.
  2. elorimer

    elorimer Very Senior Member

    Joined:
    Dec 16, 2013
    Messages:
    885
    You might browse through the issue tracker: https://issuetracker.google.com/issues/127534392

    At least one problem with USB tethering in pie is identified as fixed as of 9/20/19.

    Edit: I just tried, and my 87U connected over my Pixel 3 with Android 10. I haven't enabled the USB tethering for the router in years, but in setting it up I see there is a toggle between an Android phone and a USB modem (with that dialing number). Is your toggle set?
     
    Last edited: Oct 18, 2019
  3. dominatorstang

    dominatorstang Occasional Visitor

    Joined:
    Jul 18, 2013
    Messages:
    14
    Thanks Elorimer, for testing yours on android 10 and the info about the identified and resolved android 9 issue.

    The latest security patch for my V30 and G7 was 9/1/19. So maybe in the near future another patch will come through and I can report back.

    Your android 10 working shifts my thinking now to a bug in android 9 like you said. I previously though something with tethering had just evolved to where older scripts or such didnt work anymore.

    I am using the Android phone selection but yes I also noticed those modem commands were listed under the USB modem.